Bug Hunting Session
Bug 92733 - LibO 5: two crop image entries in format image menu; rename non-dialog one to "Interactive Crop" or "Direct Crop"
Summary: LibO 5: two crop image entries in format image menu; rename non-dialog one to...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.0.0.3 rc
Hardware: All All
: medium enhancement
Assignee: Yousuf Philips (jay) (retired)
URL:
Whiteboard: target:5.3.0
Keywords:
: 101296 (view as bug list)
Depends on:
Blocks: Impress-Menus
  Show dependency treegraph
 
Reported: 2015-07-14 14:26 UTC by sergio.callegari
Modified: 2016-09-02 19:32 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description sergio.callegari 2015-07-14 14:26:49 UTC
In LibO 5.0.0.3 the Format->Image menu has two crop image entries. Only the one opening the crop dialog should be there. The one calling the action that lets one graphically edit the crop marks is available in the context menu.

In fixing this, take care of leaving the crop dialog available from the Format->Image menu. This is the only way to accurately set crop values *numerically*.
Comment 1 Cor Nouws 2015-07-14 22:16:43 UTC
Hi Sergio,

thanks for the report.
Can you please explain what two entries you mean? I see only one Crop image in the context menu.
(Clean user profile, 5.0.0.3, Ubuntu 32 bits)

Cheers - Cor
Comment 2 sergio.callegari 2015-07-15 08:02:17 UTC
Recent draw/impress have two different ways to control cropping of images.

One of them is the traditional one: a crop dialog with 4 text boxes where you can enter numbers, namely the left, right, top and bottom lenghts. The dialog also shows a preview of the cropped image.

The other one is the interactive graphical tool where crop handles are substituted for the standard object handles.

The two tools have different goals: the interactive graphical one is much more handy for a quick cropping, while the dialogue is the only way to have accurate control on the cropping lengths, that is indispensable e.g. to assure that two objects having the same role get exactly the same cropping treatment.

Now, I think that - in perspective - the object context menu should activate the interactive cropping tool, and that the numeric info in the cropping dialogue should be incorporated in the properties pane.  During this transition an until the properties pane gets updated to include the cropping info, the dialogue should stay and should be activated by the Format->Image->Crop menu.
Comment 3 Cor Nouws 2015-07-15 18:30:53 UTC
(In reply to sergio.callegari from comment #2)

> Now, I think that - in perspective - the object context menu should activate
> the interactive cropping tool,

as is..

> and that the numeric info in the cropping
> dialogue should be incorporated in the properties pane.  During this
> transition an until the properties pane gets updated to include the cropping
> info, the dialogue should stay and should be activated by the
> Format->Image->Crop menu.

I'm not sure if those transition stuff will work. It's all work after all.
But this issue could be an enhancement to get cropping incorporated in the side bar.. ? Will there be enough space??
Comment 4 sergio.callegari 2015-07-15 18:59:42 UTC
It is just my hypothesis that the dialog content will be eventually moved in the properties pane, since I see that most "detail" information is being moved there.

For sure there is not much to do either if this is what shall eventually happen or not. For now, the only requirement is to remove the second "crop image" entry in the Format->Image menu as it causes confusion to have two identically labelled entries.

Only the item opening the dialog should stay there in the format->image menu. The other, should be in the context menu only.
Comment 5 Yousuf Philips (jay) (retired) 2015-07-27 18:07:58 UTC
Yes a similar issue also happened in Writer as there were two insert frame option - one being interactive where you can draw the frame shape and the one which opened a dialog to specify the frame options before it was inserted.

So the likely solution is to rename the non-dialog one to something like Format > Image > Interactive Crop.
Comment 6 Cor Nouws 2015-08-10 15:19:48 UTC
(In reply to Yousuf (Jay) Philips from comment #5)
> So the likely solution is to rename the non-dialog one to something like
> Format > Image > Interactive Crop.

I agree with that, or something alike
Comment 7 Yousuf Philips (jay) (retired) 2016-08-07 16:14:33 UTC
Patch is in - https://gerrit.libreoffice.org/27939
Comment 8 Yousuf Philips (jay) (retired) 2016-08-07 16:25:23 UTC
*** Bug 101296 has been marked as a duplicate of this bug. ***
Comment 9 Commit Notification 2016-08-08 20:01:19 UTC
Yousuf Philips committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=bc611f3373030082a8da518239cbfc1b58b25535

tdf#92733 Better labels and tooltips for crop functions

It will be available in 5.3.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Adolfo Jayme 2016-08-09 05:24:29 UTC
I find the “Non-Interactive” label really geeky. Don’t think it’s an improvement.
Comment 11 Yousuf Philips (jay) (retired) 2016-08-09 06:16:56 UTC
(In reply to Adolfo Jayme from comment #10)
> I find the “Non-Interactive” label really geeky. Don’t think it’s an
> improvement.

Initially i was going with changing .uno:Crop to interactive crop, but only impress and draw have .uno:GrafAttrCrop in their menus, which would make .uno:Crop look strange in writer and calc. The alternative i was thinking was to have it as 'crop dialog...'. Do you prefer that?
Comment 12 Yousuf Philips (jay) (retired) 2016-08-09 06:18:01 UTC Comment hidden (obsolete, spam)
Comment 13 Regina Henschel 2016-08-09 08:03:58 UTC
My first thought was 'Crop Dialog' and 'Crop Handles'. That would use the word 'crop' as noun and I'm not sure, that it has the desired meaning. That is a question for a native speaker. But using 'dialog' in some way, would be better.
Comment 14 Yousuf Philips (jay) (retired) 2016-09-02 17:32:27 UTC
Patch is in - https://gerrit.libreoffice.org/#/c/28625/
Comment 15 Commit Notification 2016-09-02 18:16:28 UTC
Yousuf Philips committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=c261d785f3b39f4d96dc20a52ee5f2cb498cc71c

tdf#92733 Even better labels and tooltips for crop functions

It will be available in 5.3.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.