Bug 92734 - LibO 5: missing screen refresh with OpenGL rendering
Summary: LibO 5: missing screen refresh with OpenGL rendering
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
5.0.0.3 rc
Hardware: x86-64 (AMD64) Linux (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Impress-OpenGL
  Show dependency treegraph
 
Reported: 2015-07-14 14:31 UTC by Callegar
Modified: 2016-01-09 18:50 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Callegar 2015-07-14 14:31:00 UTC
Seen in Linux with Intel Graphics. Possibly this is different in other architectures. With LibO 5, the screen often does not refresh unless one scrolls up and down a little. Seems to be triggered by "OpenGL rendering everywhere".

This happens during *edit*, not *presentation*
Comment 1 Buovjaga 2015-07-29 18:14:53 UTC
What is your kernel version? What graphics card exactly and what driver?
What Linux distro?
Still continuing with 5.0 RC4 or RC5?
Comment 2 Buovjaga 2015-07-29 18:19:51 UTC
Screencast would be a bonus :)
Comment 3 Callegar 2015-07-29 21:11:46 UTC
Linux version 3.19.0-25-generic (buildd@lgw01-07) (gcc version 4.9.2 (Ubuntu 4.9.2-10ubuntu13) )

In fact, the ubuntu vivid standard kernel

Intel Gen8 Graphics
VGA compatible controller: Intel Corporation Crystal Well Integrated Graphics Controller (rev 08)

Mesa 10.5.2
In fact the ubuntu vivid standard graphics stack

Working without OpenGL rendering everywhere seems to workaround the issue without any apparent problem.

Will check with newer LibO as soon as possible.
Comment 4 bach_leipzig 2015-08-28 21:07:25 UTC
I know this is an Impress bug, but I found LO5 Writer immediately unusable because of screen refresh issues. Major portions of pages would disappear and not come back, and the menus would go blank. Not sure if I'm seeing this same bug, but this one seemed close. I had to go back to 4.4.5.

Ubuntu 12.04. 3.13 kernel. GeForce GT 430. Nvidia Driver 331.113.

I'm not sure where the "OpenGL rendering everywhere" setting is to be found.
Comment 5 Michael Meeks 2016-01-09 18:50:11 UTC
We've fixed so many bugs around OpenGL; please re-test with 5.1.0 RC2 (due next week) and re-open if you still get this.

Tools->Options->View has the OpenGL options on it - but on Linux it should be off by default.

Thanks !