Bug 92737 - ENHANCEMENT: Save Document should include Size-Dimension on open in the document
Summary: ENHANCEMENT: Save Document should include Size-Dimension on open in the document
Status: RESOLVED DUPLICATE of bug 75644
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.4.3.2 release
Hardware: Other Mac OS X (All)
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-07-14 17:58 UTC by Manfred
Modified: 2019-02-22 11:18 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Nothing to do with Start Center?! (1.03 MB, image/jpeg)
2019-02-22 11:13 UTC, Manfred
Details
step2 (31.61 KB, image/jpeg)
2019-02-22 11:15 UTC, Manfred
Details
step3 (676.26 KB, image/jpeg)
2019-02-22 11:15 UTC, Manfred
Details
step4 (27.01 KB, image/jpeg)
2019-02-22 11:16 UTC, Manfred
Details
step5 --> wrong size at Doc 1 (841.05 KB, image/jpeg)
2019-02-22 11:18 UTC, Manfred
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Manfred 2015-07-14 17:58:23 UTC
NO BUG, JUST AN ENHANCEMENT REQUEST !!!!

It’s a pity…

I had kicked out Microsoft Products on my Mac and would never go back.
But you will have to help me, to untempted me:

To save a file with loved LibreOffice in Landscape mode:
Will open every other file, formerly not saved in Landscape mode ..........
in Landscape mode…

Nearly every app I use could that better…

Please: Store last size after save:  !!!!  INSIDE THE DOCUMENT !!!
It’s only 20-40 bytes…


Manfred
Comment 1 Buovjaga 2015-07-29 18:23:30 UTC
Could not reproduce.

1. In Writer, Format - page - page - orientation: landscape
2. Save
3. Close file
4. Create new file: orientation is portrait

Win 7 Pro 64-bit, Version: 4.4.4.3
Build ID: 2c39ebcf046445232b798108aa8a7e7d89552ea8
Locale: fi_FI
Comment 2 Alex Thurgood 2015-07-30 07:50:55 UTC
No repro

Version: 5.1.0.0.alpha1+
Build ID: e2281331b1ab40288494ab3659d9c66e13d3e905
Locale : fr-FR (fr.UTF-8)

OSX 10.10.4

No repro 

Version: 5.0.0.4
Build ID: cf112dc905650fb985306a7a03d2fe3fcc6c978f
Locale: fr-FR (fr.UTF-8)

OSX 10.10.4

Also no repro with LO 4432

@Manfred : you'll have to be a bit more specific on what you do, which kind of files are affected, version of OSX...

NEEDINFO
Comment 3 Manfred 2015-07-30 07:58:19 UTC
Sorry, I did not explain correctly…
I did mean the window-size, not the page-format - page-orientation.

Please try the following with calc.

1. save a spreadsheet, much columns, therefor the window more broadly than high.
2. save an other spreadsheet, less columns, much rows, therefor the window more highly than broad.


3. Open the first saved spreadsheet: The window-size will not match, it is wide like the last saved file.

If one has to open much different files a day, it is boring to change the window-size every time.

Manfred

Mac OSX Yosemite (10.10.4)
LO 4.4.5.2
LO 4.4.3.2
Comment 4 Alex Thurgood 2015-07-30 16:01:20 UTC

*** This bug has been marked as a duplicate of bug 75644 ***
Comment 5 Manfred 2019-02-22 11:13:57 UTC
Created attachment 149523 [details]
Nothing to do with Start Center?!

Since no solution was found yet to save the size of the files individually when opening, I would like to explain again more exactly what is the problem with Mac OSX.

The documents are not opened via the Start Center, but directly by double-clicking.

All steps as attachments.
Comment 6 Manfred 2019-02-22 11:15:01 UTC
Created attachment 149524 [details]
step2
Comment 7 Manfred 2019-02-22 11:15:40 UTC
Created attachment 149525 [details]
step3
Comment 8 Manfred 2019-02-22 11:16:38 UTC
Created attachment 149526 [details]
step4
Comment 9 Manfred 2019-02-22 11:18:04 UTC
Created attachment 149527 [details]
step5 --> wrong size at Doc 1