Bug 92763 - FILEOPEN: crash/hang when opening .doc file
Summary: FILEOPEN: crash/hang when opening .doc file
Status: VERIFIED DUPLICATE of bug 63955
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4.4.3 release
Hardware: Other All
: high major
Assignee: Caolán McNamara
URL:
Whiteboard:
Keywords: bibisected, regression
Depends on:
Blocks:
 
Reported: 2015-07-15 12:17 UTC by abma
Modified: 2015-12-15 11:03 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
the document which breaks writer (25.50 KB, application/msword)
2015-07-15 12:17 UTC, abma
Details

Note You need to log in before you can comment on or make changes to this bug.
Description abma 2015-07-15 12:17:47 UTC
Created attachment 117249 [details]
the document which breaks writer

when opening the attached document, libreoffice just hangs.

LO 5.0.0.2 hangs, too.
Comment 1 raal 2015-07-15 18:48:49 UTC
I can confirm crash with Version: 5.1.0.0.alpha1+
Build ID: 9be553f4c61f220ebbe212dc76cb9cce4ae1c106
TinderBox: Linux-rpm_deb-x86_64@46-TDF, Branch:master, Time: 2015-07-13_22:45:19

I can open file in word2010 without problem. I can open file in LibreOffice 3.5.0 Build ID: d6cde02, regression
Comment 2 Michael Weghorn 2015-07-15 20:35:38 UTC
bibisect result (using bibisect43-all repository):

e65850d4d23beb93ded3cab9e5945dd39c530738 is the first bad commit
commit e65850d4d23beb93ded3cab9e5945dd39c530738
Author: Bjoern Michaelsen <bjoern.michaelsen@canonical.com>
Date:   Wed Dec 7 05:16:40 2011 +0100

    source-hash-a44dda4b7d71f8d2b4e0cca79d732eab89588c3a
    
    commit a44dda4b7d71f8d2b4e0cca79d732eab89588c3a
    Author:     Matúš Kukan <matus.kukan@gmail.com>
    AuthorDate: Fri Sep 2 03:21:23 2011 +0200
    Commit:     Matúš Kukan <matus.kukan@gmail.com>
    CommitDate: Fri Sep 2 11:49:25 2011 +0200
    
        process more idl files at once - second part: makefiles

:100644 100644 6fbf255c3a7ff698bd1077b31bb78fc656d66c43 ab0595641102029f7ba0a38bda6553bf144f6d62 M	autogen.log
:100644 100644 9e5b8e49ccf5e2259565c67680a3fa8568ed582c f1776e218e615ee16234fda621551b17913e87b7 M	ccache.log
:100644 100644 496231332d58ca1dfc93e962b4023e5eedf14262 e4bfdb45b33fb0ec0cafb2b41f0b35a389bf26bd M	commitmsg
:100644 100644 ff78528271a5a87f4943854ba914b03498394775 b76274ecc9f917a09f00a032b12352db356e377b M	dev-install.log
:100644 100644 9d8b57d00ca90aa6e3601d10017dc532ec1bed28 d8894603ec34f90e21ef518aac5c5b0fa425b34e M	make.log
:040000 040000 58bc0ef52488b6b81c2f58a7ae59d22e08f31d94 015bad708b8e165da96667dcf17f583220b4ae10 M	opt

---

$ git bisect log
# bad: [423a84c4f7068853974887d98442bc2a2d0cc91b] source-hash-c15927f20d4727c3b8de68497b6949e72f9e6e9e
# good: [65fd30f5cb4cdd37995a33420ed8273c0a29bf00] source-hash-d6cde02dbce8c28c6af836e2dc1120f8a6ef9932
git bisect start 'latest' 'oldest'
# bad: [e02439a3d6297a1f5334fa558ddec5ef4212c574] source-hash-6b8393474974d2af7a2cb3c47b3d5c081b550bdb
git bisect bad e02439a3d6297a1f5334fa558ddec5ef4212c574
# bad: [8f4aeaad2f65d656328a451154142bb82efa4327] source-hash-1885266f274575327cdeee9852945a3e91f32f15
git bisect bad 8f4aeaad2f65d656328a451154142bb82efa4327
# bad: [369369915d3582924b3d01c9b01167268ed38f3b] source-hash-45295f3cdceb4c289553791071b5d7f4962d2ec4
git bisect bad 369369915d3582924b3d01c9b01167268ed38f3b
# bad: [351622aec2dff3cc3bbbb020ad0097c4322d2a21] source-hash-2c4537471c932b65e6f72e41881b505c4bbad12c
git bisect bad 351622aec2dff3cc3bbbb020ad0097c4322d2a21
# bad: [035c276ec5a8da669e6043a3db6b0701dd3c2ade] source-hash-dc8249af103741415a074d9bbf8b1211f24a7c3f
git bisect bad 035c276ec5a8da669e6043a3db6b0701dd3c2ade
# bad: [4225403645019b6af53db0bf9ba9bbd063e9aa93] source-hash-cf16ef6c250a2755155a02f24bad861b35a1f92b
git bisect bad 4225403645019b6af53db0bf9ba9bbd063e9aa93
# good: [07e8171f32b03a1146ef80d086c2dd61f3def5aa] source-hash-886762160996dfa3fee07cf135e53dfe952ed298
git bisect good 07e8171f32b03a1146ef80d086c2dd61f3def5aa
# bad: [a0486a18ac4ea6508f02804cf2624c46607674af] source-hash-a0a1c3f4fb730ed3614593c3d8ddb50c23204c29
git bisect bad a0486a18ac4ea6508f02804cf2624c46607674af
# bad: [f89e78929fb81d824ac5ad2b3063a7f73ed47c9a] source-hash-a705aec5117fe9123236ebdeb0d6f271b83f8af4
git bisect bad f89e78929fb81d824ac5ad2b3063a7f73ed47c9a
# bad: [e65850d4d23beb93ded3cab9e5945dd39c530738] source-hash-a44dda4b7d71f8d2b4e0cca79d732eab89588c3a
git bisect bad e65850d4d23beb93ded3cab9e5945dd39c530738
# first bad commit: [e65850d4d23beb93ded3cab9e5945dd39c530738] source-hash-a44dda4b7d71f8d2b4e0cca79d732eab89588c3a
Comment 3 Michael Stahl (allotropia) 2015-08-21 15:20:37 UTC
was fixed by:

commit f794f6501bcf18e5430d57128699fc579251f900
Author:     Caolán McNamara <caolanm@redhat.com>
AuthorDate: Wed Jul 15 10:09:16 2015 +0100

    Resolves: tdf#63955 clip 19km long line to some sane limit

*** This bug has been marked as a duplicate of bug 63955 ***
Comment 4 raal 2015-08-21 15:27:00 UTC
Verified, works OK with Version: 5.1.0.0.alpha1+
Build ID: 6b7354ae66db40246a09e00aa876443057655a43
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2015-08-19_01:05:16
Comment 5 Robinson Tryon (qubit) 2015-12-15 11:03:08 UTC Comment hidden (obsolete)