Bug 92777 - unable create database file
Summary: unable create database file
Status: RESOLVED DUPLICATE of bug 92706
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
5.1.0.0.alpha0+ Master
Hardware: Other All
: medium critical
Assignee: Not Assigned
URL:
Whiteboard: havebacktrace
Keywords: bibisected, regression
Depends on:
Blocks:
 
Reported: 2015-07-15 21:56 UTC by Terrence Enger
Modified: 2015-12-17 09:25 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
gdb output without symbols (12.86 KB, text/plain)
2015-07-15 21:56 UTC, Terrence Enger
Details
log from WinDbg (22.11 KB, text/plain)
2015-07-16 00:46 UTC, Terrence Enger
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Terrence Enger 2015-07-15 21:56:13 UTC
Created attachment 117267 [details]
gdb output without symbols

The gdb output has a backtrace without symbols.  The LibreOffice was
daily dbgutil bibisect version 2015-07-15.  

I also see a crash on Windows Vista with daily build from 2015-07-09
when I try to create a .odb linked to Microsoft Access database.


STR
---

(1) Run soffice with command line parameter --base.  Program presents
    "Database Wizard", Step 1.

(2) Type "<Enter>".  Program presents "Database Wizard" Step 2.

(3) Type "<alt>+O <alt>+F".  Program presents dialog "Save".

(4) In filename field type "\tmp\a1<Enter>"
    Expected : The program presents database window.
    Observed : SIGSEGV.


Working in the daily dbgutil bibisect repository, I see from `git
bisect good` ...

    43d971d013fc757bfbe0fdec122ed1a9a693bd47 is the first bad commit
    commit 43d971d013fc757bfbe0fdec122ed1a9a693bd47
    Author: Miklos Vajna <vmiklos@collabora.co.uk>
    Date:   Wed Jul 8 04:47:17 2015 +0200

        2015-07-08: source-hash-ff669d1c7f692052534d1136d1ff4220433f8542

    :100644 100644 4f0357bce19802b8714a10e25482be00144e3210 eec062d0a886ebc30324db6809bbe2b26251616c M	build-info.txt
    :040000 040000 d201531589b6310dc15010565167145134cde463 54f63208743b2615b8106ac47ca9840016362802 M	opt

and from `git bisect log` ...

    # bad: [ae880b1d536e77c0604e2e05e496d3113a5709e7] 2015-07-15: source-hash-a3050f632517137f809d76662170726b518f043a
    # good: [2b392af9c8f54629e3a3a98a8c92fa5af1c6722f] 2015-05-20: source-hash-90e2dabb8d0bb5382234be776c2ad0e2d5d9e224
    git bisect start 'ae880b' 'oldest'
    # good: [ea66e33d42004c5689162daabde2f6feef90bf8a] 2015-06-17: source-hash-ffc1ffed11dc63a69fc2db04f12b3ea266b580fe
    git bisect good ea66e33d42004c5689162daabde2f6feef90bf8a
    # good: [fb3404d2eeab9aa6fd69fedbe4f41e8581b2efd6] 2015-07-01: source-hash-9394362e10de6fe30e673efcdbe56d43579447b1
    git bisect good fb3404d2eeab9aa6fd69fedbe4f41e8581b2efd6
    # bad: [43d971d013fc757bfbe0fdec122ed1a9a693bd47] 2015-07-08: source-hash-ff669d1c7f692052534d1136d1ff4220433f8542
    git bisect bad 43d971d013fc757bfbe0fdec122ed1a9a693bd47
    # good: [377c024a5d2e365167cea5fa34d015f6a6f1f688] 2015-07-04: source-hash-3c45bfb0cabf206f6217f1de9eb5cfa12b78e46f
    git bisect good 377c024a5d2e365167cea5fa34d015f6a6f1f688
    # good: [c9abefa2facd9d5f2989bbc2138e55970e60c4cd] 2015-07-06: source-hash-64385c7555c6bbb089f3ab8b2a5b623cadd6ee7d
    git bisect good c9abefa2facd9d5f2989bbc2138e55970e60c4cd
    # good: [136b8f86a09839b55e7c25e4cf82e439c496f3ce] 2015-07-07: source-hash-0251e61640b94094918406b33ee7b05564409feb
    git bisect good 136b8f86a09839b55e7c25e4cf82e439c496f3ce
    # first bad commit: [43d971d013fc757bfbe0fdec122ed1a9a693bd47] 2015-07-08: source-hash-ff669d1c7f692052534d1136d1ff4220433f8542
Comment 1 Terrence Enger 2015-07-16 00:46:20 UTC
Created attachment 117271 [details]
log from WinDbg
Comment 2 Terrence Enger 2015-07-16 00:51:42 UTC
Setting O/S, whiteboard, and keyword.
Comment 3 Julien Nabet 2015-07-16 08:25:07 UTC
Terrence: I don't know how you can have save dialog from wizard step 2 but the bt is quite identical to tdf#92706.

It should be fixed now with http://cgit.freedesktop.org/libreoffice/core/commit/?id=9e2e8bb5e6c5a7df376f6ada90703f59c95f19d6
I don't know why the 5.0.0 patch was pushed not 5.0 (https://gerrit.libreoffice.org/#/c/17038/1) and master (https://gerrit.libreoffice.org/#/c/17037/), so I pushed the last one.

It could be interesting you try again with the quoted patch.
Comment 4 ribotb 2015-07-18 08:32:45 UTC
(In reply to Terrence Enger from comment #0)

> (1) Run soffice with command line parameter --base.  Program presents
>     "Database Wizard", Step 1.
> 
> (2) Type "<Enter>".  Program presents "Database Wizard" Step 2.
> 
> (3) Type "<alt>+O <alt>+F".  Program presents dialog "Save".
> 
> (4) In filename field type "\tmp\a1<Enter>"
>     Expected : The program presents database window.
>     Observed : SIGSEGV.
> 

With Windows it is not possible to type \tmp\a1 in filename field ("path does not exist")

If I type only a1 for example to give a name to the odb file, LO crashes (without message) and restarts automatically.
The a1.odb file is however created.

Version: 5.1.0.0.alpha1+
Build ID: 122a15f4a6c09d35db58fe3a7b943b5ea79cbe65
TinderBox: Win-x86@39, Branch:master, Time: 2015-07-09_23:27:20
Locale: fr-FR (fr_FR)

Bernard
Comment 5 ribotb 2015-07-18 08:48:04 UTC
(In reply to Terrence Enger from comment #0)
> 
> (3) Type "<alt>+O <alt>+F".  Program presents dialog "Save".

Does not work with LO 4.4.5.1 and LO 4.0.0.3

Bernard

Win7/x86
Comment 6 ribotb 2015-07-18 09:37:29 UTC
(In reply to Terrence Enger from comment #0)

> I also see a crash on Windows Vista with daily build from 2015-07-09
> when I try to create a .odb linked to Microsoft Access database.
> 
Also crash on Win7.
The crash occurs when I press "Save" on dialog "Save".
No message and automatic restart.
However odb file is created.

Bernard
Comment 7 Terrence Enger 2015-07-19 12:52:18 UTC
The crash is indeed gone with daily dbgutil bibisect version
2015-07-18.  I am setting bug status RESO DUP 92706.

*** This bug has been marked as a duplicate of bug 92706 ***
Comment 8 Terrence Enger 2015-07-21 20:31:47 UTC
And on Windows Vista, LibreOffice ...
    Version: 5.1.0.0.alpha1+
    Build ID: ab777c9cecc7377a7bdb0cda2eb26412021c7a73
    TinderBox: Win-x86@39, Branch:master, Time: 2015-07-21_00:37:55
    Locale: en-CA (en_CA)
I can once again create a database file.
Comment 9 Robinson Tryon (qubit) 2015-12-17 09:25:56 UTC
Migrating Whiteboard tags to Keywords: (bibisected)
[NinjaEdit]