Bug 92787 - Calc crashes when sorting a column
Summary: Calc crashes when sorting a column
Status: RESOLVED DUPLICATE of bug 93098
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.4.5.2 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: haveBacktrace
Depends on:
Blocks:
 
Reported: 2015-07-16 17:19 UTC by Francisco
Modified: 2015-08-20 13:36 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
backtrace 1 (74.77 KB, text/x-log)
2015-07-16 17:19 UTC, Francisco
Details
file (311.02 KB, application/vnd.oasis.opendocument.spreadsheet)
2015-07-16 17:30 UTC, Francisco
Details
Reproducible example spreadsheet (9.20 KB, application/vnd.oasis.opendocument.spreadsheet)
2015-08-19 15:16 UTC, tmacalp
Details
backtrace obtained with attached spreadsheet (18.31 KB, text/x-log)
2015-08-19 15:24 UTC, Francisco
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Francisco 2015-07-16 17:19:24 UTC
Created attachment 117284 [details]
backtrace 1

Calc crashes frequently, though randomly, when sorting tables by row. The problem is to find exact steps to reproduce, because it crashes _sometimes_ sorting the same data, and _sometimes_ not.

Versión: 5.0.0.3
Id. de compilación: f79b5ba13f5e6cbad23f8038060e556217e66632
Configuración regional: en-US (es_AR.UTF-8)
Kubuntu 14.04 x64

I'm attaching a backtrace
Comment 1 Francisco 2015-07-16 17:30:34 UTC
Created attachment 117285 [details]
file

I'm attaching also the ODS with which I have had problems. However, since I haven't been able to reproduce it with defined steps I'm not sure if it will help :-(
Comment 2 Julien Nabet 2015-07-16 18:39:34 UTC
Except a function name so a code pointer (http://opengrok.libreoffice.org/xref/core/sc/source/core/data/table3.cxx#1036), it indeed would be useful you find a way to reproduce this.
Comment 3 tmacalp 2015-08-19 15:16:58 UTC
Created attachment 118024 [details]
Reproducible example spreadsheet

I'm not sure if this is exactly the same issue you're experiencing, but I have a very simple spreadsheet with simple reproducible steps to cause a crash by sorting.

Steps to reproduce using my example spreadsheet:
1. Open example spreadsheet
2. Select range A2:E4
3. Data -> Sort
4. Click OK to sort by column A
5. LO crashes

I was able to reproduce it using LO 4.4.5.2, but not in 4.3.7.2.
Comment 4 Francisco 2015-08-19 15:21:57 UTC
(In reply to tmacalp from comment #3)
> Created attachment 118024 [details]
> Reproducible example spreadsheet
> 
> I'm not sure if this is exactly the same issue you're experiencing, but I
> have a very simple spreadsheet with simple reproducible steps to cause a
> crash by sorting.
> 
> Steps to reproduce using my example spreadsheet:
> 1. Open example spreadsheet
> 2. Select range A2:E4
> 3. Data -> Sort
> 4. Click OK to sort by column A
> 5. LO crashes
> 
> I was able to reproduce it using LO 4.4.5.2, but not in 4.3.7.2.

Indeed, I haven't reproduce _my_ crash since RC4, though I'm perfectly able to reproduce this one using LibO 5.0.0.5.

Attaching a backtrace
Comment 5 Francisco 2015-08-19 15:24:13 UTC
Created attachment 118025 [details]
backtrace obtained with attached spreadsheet

Backtrace obtained when following steps in comment 3.

I'm also able to reproduce the bug without the need of the sort dialog: only pressing the sort ascending button.
Comment 6 Francisco 2015-08-19 15:28:34 UTC
I'm able to reproduce this bug under LibO 4.4.5, but not in LibO 4.3.7 nor 3.5.7.
Comment 7 raal 2015-08-20 09:52:05 UTC
(In reply to tmacalp from comment #3)
> Created attachment 118024 [details]
> Reproducible example spreadsheet
> 
> I'm not sure if this is exactly the same issue you're experiencing, but I
> have a very simple spreadsheet with simple reproducible steps to cause a
> crash by sorting.
> 
> Steps to reproduce using my example spreadsheet:
> 1. Open example spreadsheet
> 2. Select range A2:E4
> 3. Data -> Sort
> 4. Click OK to sort by column A
> 5. LO crashes
> 
> I was able to reproduce it using LO 4.4.5.2, but not in 4.3.7.2.

No crash with Version: 5.1.0.0.alpha1+
Build ID: 6b7354ae66db40246a09e00aa876443057655a43
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2015-08-19_01:05:16

Setting as duplicate of bug 93098. Please, could you retest with dev build? Thank you

*** This bug has been marked as a duplicate of bug 93098 ***
Comment 8 tmacalp 2015-08-20 13:36:28 UTC
(In reply to raal from comment #7)
> No crash with Version: 5.1.0.0.alpha1+
> Build ID: 6b7354ae66db40246a09e00aa876443057655a43
> TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time:
> 2015-08-19_01:05:16
> 
> Setting as duplicate of bug 93098. Please, could you retest with dev build?
> Thank you
> 
> *** This bug has been marked as a duplicate of bug 93098 ***

I was not able to reproduce the crash with last night's dev build, so this does appear to have been fixed.

Also, sorry for hijacking the original report with what now appears to have been a completely different bug.  Hopefully that original bug was squashed somewhere after RC4.