Bug 92797 - Calc: "bad allocation" crash when copy cells, click top left corner selector, paste
Summary: Calc: "bad allocation" crash when copy cells, click top left corner selector,...
Status: RESOLVED DUPLICATE of bug 60021
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.4.2.2 release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 93180 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-07-17 02:43 UTC by Doug
Modified: 2016-09-23 13:50 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
OS message about not enough memory (18.70 KB, image/png)
2015-07-17 23:39 UTC, m.a.riosv
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Doug 2015-07-17 02:43:23 UTC
See Bug 82404 Comment #3.  

1.  enter info into a a few cells in column in Calc spreadsheet
2.  select and copy cells
3.  click top left corner record selector
4.  Fatal error, crash, "bad allocation"

LO 5.0.0.3 Windows 7 64-bit, but similar problem 4.2 previously.
Comment 1 Doug 2015-07-17 02:44:15 UTC
Meant to say fatal error after clicking record selector in corner, then ctrl-v paste.  Error occurs after paste.
Comment 2 m.a.riosv 2015-07-17 23:39:01 UTC
Created attachment 117308 [details]
OS message about not enough memory

Hi @Doug, thanks for reporting.

reproducible with:
Win7x64
Version: 4.4.5.0.0+ Build ID: 1ce188a6f3afc69bf2bfeb11d62e287101398884
TinderBox: Win-x86@51-TDF, Branch:libreoffice-4-4, Time: 2015-07-04_00:02:20
Version: 5.0.0.1.0+ (x64) Build ID: df06ddf79cf0b5aca037630504a07dd8b2341a43
TinderBox: Win-x86_64@62-TDF, Branch:libreoffice-5-0, Time: 2015-07-17_18:17:03


In any case remember that doing so, you are copying into:

1024 cols x 1.048.576 rows = 1.073.741.824 cells

so is normal not enough memory, but is a bug not being captured the error, what can leads to data loss.

Maybe must not be allowed paste on the whole cells.
Comment 3 raal 2015-08-06 10:55:59 UTC
*** Bug 93180 has been marked as a duplicate of this bug. ***
Comment 4 walkerkorea 2016-05-12 04:57:07 UTC
Intermittently reproduced.

First test: Copied date. Select entire SS using box to left of A and above 1. Ctrl-V. Result: small popup briefly saying "bad alloc" or "bad allocation" (unsure), then LO crashes.

Second test: Bring it back up, and 3 SSs recovered. Repeat above test, but this time copy number instead of date. No popup. Spinning wheel for several minutes. LO using 22.2 - 23.9% of CPU, and 1,379.8 - 1,426.0 MB of RAM. (Everything together -- Chrome, LO, AV, AMalware, utils, etc. -- using 34% CPU and 68% of RAM)

Version: 5.1.1.3
Build ID: 89f508ef3ecebd2cfb8e1def0f0ba9a803b88a6d
CPU Threads: 4; OS Version: Windows 6.2; UI Render: default; 
Locale: en-US (en_US)

Windows 10.0.10586 x64
AMD A10-7800 APU
12 GB RAM (physical) + 18.4 GB virtual
Comment 5 walkerkorea 2016-05-12 05:00:01 UTC
OK, after 7-10 minutes of the spinning turquoise wheel, LO Calc flashed the "bad alloc" and crashed (i.e., closed itself).
Comment 6 Caolán McNamara 2016-09-21 20:16:15 UTC
caolanm->erack: is this now one of the cases caught by the all-spreadsheet-selected new protector ?
Comment 7 Caolán McNamara 2016-09-23 13:50:46 UTC

*** This bug has been marked as a duplicate of bug 60021 ***