Bug 92850 - Autocorrection of single quotation marks is disabled by default
Summary: Autocorrection of single quotation marks is disabled by default
Status: RESOLVED DUPLICATE of bug 38395
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.4.0.3 release
Hardware: All All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-07-21 06:02 UTC by Adolfo Jayme
Modified: 2015-11-16 00:28 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot (54.93 KB, image/png)
2015-07-21 06:02 UTC, Adolfo Jayme
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Adolfo Jayme 2015-07-21 06:02:38 UTC
Created attachment 117352 [details]
Screenshot

What it says on the tin (and the screenshot).
Comment 1 tommy27 2015-07-22 18:07:04 UTC
I confirm that under Win8.1 x64
in LibO 4.3.5 that option was enabled while in 4.4.0.4 and following releases (including recent 5.1.0 daily builds) that option is disabled

I don't know if that was done on purpose or not.

should we call it a regression?
Comment 2 Adolfo Jayme 2015-07-24 11:12:33 UTC
Sure – thanks for testing, Tommy.
Comment 3 Julien Nabet 2015-08-01 22:10:00 UTC
With this patch + make postprocess + brand new profile, it works:
diff --git a/officecfg/registry/schema/org/openoffice/Office/Common.xcs b/officecfg/registry/schema/org/openoffice/Office/Common.xcs
index 7e722ca..f0b3c04 100644
--- a/officecfg/registry/schema/org/openoffice/Office/Common.xcs
+++ b/officecfg/registry/schema/org/openoffice/Office/Common.xcs
@@ -1347,7 +1347,7 @@
           <desc>Specifies if single quotes should be replaced.</desc>
           <label>Single quotes - Replace</label>
         </info>
-        <value>false</value>
+        <value>true</value>
       </prop>
       <prop oor:name="SingleQuoteAtStart" oor:type="xs:int">
         <!-- OldPath: AutoCorrect/Options/All -->

The problem is I don't see in the historic of the file why it was working before 4.4.0

Perhaps I'm on a wrong lead.
Comment 4 Adolfo Jayme 2015-08-03 22:20:46 UTC
Julien, that patch looks okay to me.
Comment 5 Julien Nabet 2015-08-04 05:32:23 UTC
Pending review for master sources:
https://gerrit.libreoffice.org/17498
Comment 6 Eike Rathke 2015-08-04 09:31:14 UTC
(In reply to tommy27 from comment #1)
> in LibO 4.3.5 that option was enabled

This is not true. The default option for single quotes has always been disabled since the year 2002, which can easily be seen with git annotate. If you experienced differently it is because of a local configuration.

I suspect there is some reason the single quote replacement is disabled while the double quote replacement is not, but I don't know which, maybe related to apostrophe uses.

I suggest to resolve this as NOTABUG.
Comment 7 Regina Henschel 2015-08-04 10:33:16 UTC
Yes it was disabled in OpenOffice because of problems, including Apostrophe. There had been discussions on mailing lists. Read issues https://bz.apache.org/ooo/show_bug.cgi?id=5839 and https://bz.apache.org/ooo/show_bug.cgi?id=22271 and its duplicates.

I support NOTABUG.
Comment 8 Julien Nabet 2015-08-04 12:10:14 UTC
Just for the record, I abandonned the patch.

I had found an interesting location too http://opengrok.libreoffice.org/xref/core/editeng/source/misc/svxacorr.cxx#241 but since I had found the location of the patch, I hadn't dig more.
Comment 9 Adolfo Jayme 2015-11-16 00:28:53 UTC

*** This bug has been marked as a duplicate of bug 38395 ***