Bug 92878 - Opening Word Perfect File Destroys formatting & loses text
Summary: Opening Word Perfect File Destroys formatting & loses text
Status: RESOLVED DUPLICATE of bug 98989
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: filters and storage (show other bugs)
Version:
(earliest affected)
4.4.4.3 release
Hardware: x86 (IA32) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: filter:wpd
Keywords:
Depends on:
Blocks:
 
Reported: 2015-07-22 19:29 UTC by Fred Owens
Modified: 2016-05-30 12:52 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
sample wordperfect file (7.95 KB, application/vnd.wordperfect)
2015-07-22 19:29 UTC, Fred Owens
Details
file converted with wpd2odt (19.98 KB, application/vnd.oasis.opendocument.text)
2015-07-24 08:21 UTC, osnola
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Fred Owens 2015-07-22 19:29:00 UTC
Created attachment 117382 [details]
sample wordperfect file

When opening a wordperfect document the document is blank except for a a word or two in the footer and in some cases a page number or a word in the header.
The Word count and character count are correctly shown in the status bar but the words are not visible. 
The page shows 1 of 1 and the margins are set within the page area so the words should be visible. 
There are no graphics on the page just some tabs and text.
It works fine with Microsoft Word files formatted like these but the WPD files blow up. I've attached a sample file for your use.
Comment 1 V Stuart Foote 2015-07-22 22:15:23 UTC
On Windows, confirming corrupted rendering 4.4.4.3 and current 5.1.0alpha+ master.

A problem with connecting to the libwpd/librevenge import filter? 

Or some formatting issue with this .wpd document, looks like a fielded template.
Comment 2 osnola 2015-07-24 08:21:41 UTC
Created attachment 117412 [details]
file converted with wpd2odt

I can not reproduce this problem on OSX. 

Normally on OSX, "Courier" is used to display most of the text while "Courier New" is almost only used to display the footer's text "OPERATIVE REPORT". So if you see "OPERATIVE REPORT" and not the other text, this may indicate a problem with the font "Courier" on Windows.

Note: 
- I convert test.wpd with wpd2odt on OSX and attach the result, just in case...
Comment 3 Daniel Collins 2016-05-30 04:43:29 UTC
I can confirm that I also have this problem on Windows 7. Both of the two attachments are viewed mangled just as the original report describes.

And user osnola above is exactly correct that this a font issue. Windows does not come supplied with a "Courier" font, although it does have a "Courier New" font (so, as osnola describes, the sample footer is visible but the rest of the attached example documents are not). Once I install an actual Courier font on my system, the document is fully rendered as expected. 

Is it possible to make the converted text font Courier New, granted that Windows system have not (apparently ever) had a normal Courier font supplied?

(Note that Courier is missing from the following lists of Windows fonts.)
https://en.wikipedia.org/wiki/List_of_typefaces_included_with_Microsoft_Windows
http://www.microsoft.com/typography/Fonts/product.aspx?PID=161
http://www.microsoft.com/typography/fonts/product.aspx?PID=164
Comment 4 osnola 2016-05-30 08:14:44 UTC
Hello,
as it is possible on OSX, ... to create document on OSX that uses "Courier" as main font, (even if this is possible), modifying the converter to replace "Courier" by "Courier New" does not seem a such good idea ; i.e. on systems which support the "Courier" font the result will be degraded and on systems which does not support this font, it is probably much better to detect this problem in the core rendering...
Comment 5 V Stuart Foote 2016-05-30 12:49:04 UTC
Now opens correctly. Opened in Writer the Courier font shows as not available (font name in italic in font list) but document get rendered with replacement (presumably Courier New).

On Windows 10 Pro 64-bit en-US with
Version: 5.1.3.2 (x64)
Build ID: 644e4637d1d8544fd9f56425bd6cec110e49301b
CPU Threads: 8; OS Version: Windows 6.19; UI Render: default; 
Locale: en-US (en_US)

Fall back font Courier -> Courier New was repaired for bug 98989

https://cgit.freedesktop.org/libreoffice/core/commit/?id=2f89245fb7e1c94bed49dde10b08ab1cf41b597b

Please retest with current builds.
Comment 6 V Stuart Foote 2016-05-30 12:52:07 UTC
Issue was with Courier font fallback replacement as in bug 98989 -- resolving as duplicate.

*** This bug has been marked as a duplicate of bug 98989 ***