Download it now!
Bug 92882 - Cannot substitute quotes in Writer documents created by right clicking wherever you want
Summary: Cannot substitute quotes in Writer documents created by right clicking wherev...
Status: RESOLVED DUPLICATE of bug 90286
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4.4.3 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-07-22 20:30 UTC by Leopoldo Saggin
Modified: 2015-07-22 23:50 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
screen clip of LO 5.0.0rc3 session with single quote and double quotes replaced by autocorrect (119.29 KB, image/png)
2015-07-22 22:39 UTC, V Stuart Foote
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Leopoldo Saggin 2015-07-22 20:30:50 UTC
Prerequisite:
In LibreOffice set
Tools -> Autocorrect Options -> Localized Options -> Single & Double quotes => substitute standard quotes with special ones

Then:
1. Create a new .odt file by right clicking on the desktop or whatever you want.
2. Double click on this new file to open it: in these conditions the standard font is Times New Roman 12 instead of Liberation Serif.
3. Start to write something inside the document and quote it.
4. In these conditions the standard single/double quotes are used, and no substitution with the special ones happens.

On the contrary, if you:
1. Run Libre Office
2. Create a new .odt file from inside Libre Office
then this file uses the correct default font (ie Liberation Serif) and the substitution of the normal single/double quotes with the special ones is ok.

No idea of what happens in previous versions of Libre Office.
Comment 1 V Stuart Foote 2015-07-22 22:39:13 UTC
Created attachment 117384 [details]
screen clip of LO 5.0.0rc3 session with single quote and double quotes replaced by autocorrect

This works correctly for me.  4.3.7 -> 5.1.0 -- attached clip from 5.0.0rc3

Might verify the replacement quotes are recorded in the dialog, and start with a clean user profile.
Comment 2 Gordo 2015-07-22 23:50:15 UTC

*** This bug has been marked as a duplicate of bug 90286 ***