Bug 92892 - Problems with october dates
Summary: Problems with october dates
Status: RESOLVED DUPLICATE of bug 92503
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.0.0.3 rc
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-07-23 15:13 UTC by Rafael Strozi
Modified: 2015-07-24 14:22 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Video showing the bug (738.51 KB, application/x-7z-compressed)
2015-07-23 15:13 UTC, Rafael Strozi
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rafael Strozi 2015-07-23 15:13:49 UTC
Created attachment 117392 [details]
Video showing the bug

When the following dates are used on LO 5.0.0.3, the cells keep text format:

15/10/2017
16/10/2016
18/10/2015
19/10/2014
20/10/2013
21/10/2012

It should happen with 2011, but it doesn't.


To use as date, it's you need to follow these steps:

_clear the direct format
_it will include an ' in front of the value
_delete the ' in front of value
_now it's formatted as date

Please see attached video
Comment 1 Rafael Strozi 2015-07-23 17:34:06 UTC
On LO 4.4.1.2 it works ok.
Comment 2 Rafael Strozi 2015-07-23 21:31:13 UTC
The problem occurs between 2011 and 2019, on dates when the daylight savings starts in Brazil:

20/10/2019
21/10/2018
15/10/2017
16/10/2016
18/10/2015
19/10/2014
20/10/2013
21/10/2012
16/10/2011

Found the pattern here:

http://www.brazil-help.com/start_stop.htm
Comment 3 Jacques Guilleron 2015-07-23 23:26:01 UTC
Hi Rafael,

In your video, you are using a scv file. If you select "detect special numbers", LO will format dates as you expect it. This works too for hours or scientific notation.
Comment 4 Rafael Strozi 2015-07-24 11:50:27 UTC
You are right Jacques! But why this happens with these dates? :)
Comment 5 m.a.riosv 2015-07-24 14:22:51 UTC
I think this is a duplicate, please if you are not agree, reopen it.

*** This bug has been marked as a duplicate of bug 92503 ***