Bug 92919 - MS .PPS slideshow does not advance slides (Linux-only)
Summary: MS .PPS slideshow does not advance slides (Linux-only)
Status: RESOLVED DUPLICATE of bug 125949
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
4.4.2.2 release
Hardware: x86-64 (AMD64) Linux (All)
: high major
Assignee: Not Assigned
URL:
Whiteboard: interoperability noRepro:Windows7sp1:...
Keywords: filter:ppt
Depends on:
Blocks: PPT
  Show dependency treegraph
 
Reported: 2015-07-24 23:43 UTC by Joseph Conner
Modified: 2020-10-05 13:34 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Slideshow with Music and Graphics (2.49 MB, application/vnd.ms-powerpoint)
2015-07-24 23:43 UTC, Joseph Conner
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Joseph Conner 2015-07-24 23:43:16 UTC
Created attachment 117429 [details]
Slideshow with Music and Graphics

File grabs focus on first slide to full screen but will not advance slides, not automaticly nor manually.
Comment 1 V Stuart Foote 2015-07-25 01:35:33 UTC
On Windows 7 sp1, 64-bit en-US

The .PPS packaged slide show displays correctly with current master

Version: 5.1.0.0.alpha1+
Build ID: 8cfdd81b70ef37927b40497ffd10034f28335034
TinderBox: Win-x86@39, Branch:master, Time: 2015-07-24_02:47:18
Locale: en-US (en_US)
Comment 2 V Stuart Foote 2015-07-25 01:51:22 UTC
On Windows 7 sp1, 64-bit could not reproduce with install on hand of 

Version: 4.4.1.2
Build ID: 45e2de17089c24a1fa810c8f975a7171ba4cd432
Locale: en_US

nor of

Version: 4.4.2.2
Build ID: c4c7d32d0d49397cad38d62472b0bc8acff48dd6
Locale: en_US

nor of

Version: 5.0.0.3 (x64)
Build ID: f79b5ba13f5e6cbad23f8038060e556217e66632
Locale: en-US (en_US)
Comment 3 Joseph Conner 2015-07-25 07:47:32 UTC
My machine: Ubuntu 15.04, Memory 15.6GB Intel core i7-2600 CPU@3.40GHz *8; Graphics Intel Sandybridge Desktop. OS type 64-bit Disk 2TB. This LibreOffice was installed unchanged from the Ubuntu 15.04 upgrade from 14.10.


Version: 4.4.2.2 Build ID: 40m0(Build:2) Locale: en_US

Windoze is not involved with the failure to advance slides.

Blessings, Joe Conner, Poulsbo, WA USA
Comment 4 ribotb 2015-07-25 09:59:50 UTC
No problem with LO 4.4.5.1 and LO 5.0.0.3

Win7/x86

Bernard
Comment 5 tommy27 2015-07-26 07:02:13 UTC Comment hidden (obsolete)
Comment 6 Joseph Conner 2015-07-26 23:16:12 UTC Comment hidden (obsolete)
Comment 7 tommy27 2015-07-30 12:36:13 UTC Comment hidden (obsolete)
Comment 8 Joseph Conner 2015-07-30 18:44:13 UTC Comment hidden (obsolete)
Comment 9 Joseph Conner 2015-07-30 19:49:43 UTC
After using Synaptic package manager to completely remove all traces of LibreOffice I installed Version: 4.4.5.2 Build ID: a22f674fd25a3b6f45bdebf25400ed2adff0ff99 Locale: en_US.UTF-8. The behaviour of the presentation is only very slightly different. Upon double clicking the file to initiate the presentation, I initially get a splash screen showing the slides in command mode, but it a fraction of a second later launches the slide show. 
1. The slides do not automatically advance.
2. Left/right arrow keys are ignored. Down arrow does trigger second slide once only. Up arrow will restart the music from the beginning but nothing else.
3. Space will advance one time only. Subsequent space bar are ignored.
4. END key will advance to the last slide, but it does not autoterminate.
5. ESC will terminate the presentation.

Thank you. Joe Conner, Poulsbo, WA USA 98370
Comment 10 Joseph Conner 2015-07-30 21:44:12 UTC Comment hidden (obsolete)
Comment 11 Joseph Conner 2015-07-30 22:26:22 UTC Comment hidden (obsolete)
Comment 12 Joel Madero 2015-08-01 16:28:07 UTC
I can confirm this issue:

Ubuntu 15.04 x64
LibreOffice 4.4.4.2 & 5.0.0.4

There seems to be a few issues with it but sticking to the issue at hand - I can advance once (by frantically pushing space bar) and then it never advances again. Music continues to play but I can get no advancing.

Setting this to:
Major - inability to advance slides is a major (perhaps the most major) part of Impress. Despite usually holding off Major for crashes only I think that this qualifies under the guidelines;
High - default for major
Comment 13 QA Administrators 2016-09-20 10:21:46 UTC Comment hidden (obsolete)
Comment 14 Joseph Conner 2016-09-20 18:34:06 UTC
The behaviour persists still, with slight modification only.

Now I have Version: 5.2.0.4
Build ID: 066b007f5ebcc236395c7d282ba488bca6720265
CPU Threads: 8; OS Version: Linux 4.4; UI Render: default; 
Locale: en-US (en_US.UTF-8)
On Ubuntu 16.04 LTS 64bit now.

After advancing to the first slide, attempts to advance to the second slide results in a totally blank white screen. The escape key crashes LibreOffice.
Comment 15 Joseph Conner 2017-09-24 22:53:01 UTC Comment hidden (obsolete)
Comment 16 QA Administrators 2018-09-25 02:51:37 UTC Comment hidden (obsolete)
Comment 17 Joseph Conner 2018-09-25 17:20:43 UTC
Now using Ubuntu 18.04, LibreOffice 6.1.1.2.The first time I tested it the behavior was unchanged. Restarting LO a second time the behavior was unchanged.

BUT

The third time I relaunched the slide show it behaved as it was supposed to.

Go figure. I do not know if the problem is fixed or not, but I think any problem remaining must be in the initialization of the slide show.

Joe Conner (Now moved to Emmett, Idaho)
Comment 18 Buovjaga 2019-09-22 13:57:11 UTC
Still not advancing on Linux

Arch Linux 64-bit
Version: 6.4.0.0.alpha0+
Build ID: b9a776837462eeb6d50d0decc42604c0c3008eb1
CPU threads: 8; OS: Linux 5.2; UI render: default; VCL: kf5; 
Locale: fi-FI (fi_FI.UTF-8); UI-Language: en-US
Calc: threaded
Built on 11 August 2019
Comment 19 Timur 2020-10-05 13:34:29 UTC
Looks fixed in 6.4. 

commit 9ba72d0ca0bf190471e147077bd57d76fcb9162a
Date:   Tue Dec 17 15:25:59 2019 +0100
    source sha:0741ab9d642f63f8c19720cc14335bf72f366b38
    previous source sha:089b409a618491c2881d2380ccd1dc4f57272445

commit	0741ab9d642f63f8c19720cc14335bf72f366b38	[log]
author	Gülşah Köse <gulsah.kose@collabora.com>	Mon Dec 16 11:31:49 2019 +0300
committer	Gülşah Köse <gulsah.kose@collabora.com>	Tue Dec 17 10:04:05 2019 +0100
tree	20a9465b3d9d1c886ec797327ec340b9761ad08e
parent	089b409a618491c2881d2380ccd1dc4f57272445 [diff]

tdf#125949 Allow the slide to continue with freezing animation.

Entrance (Zoom in, Spiral in, Sviwel, Stretchy) animations with
shapes freezes the presentation when OpenGL is enabled. As a
workaround, avoid playing these animations.

Actually, 125949 was a duplicate of this one, but important it's fixed.

*** This bug has been marked as a duplicate of bug 125949 ***