Bug Hunting Session
Bug 92933 - Poor quality of inserted images
Summary: Poor quality of inserted images
Status: RESOLVED DUPLICATE of bug 86675
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4.4.3 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-07-25 21:27 UTC by menulio.svytuokle
Modified: 2015-07-30 22:20 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Ilustration for poor image quality in Writer (129.56 KB, image/jpeg)
2015-07-25 21:27 UTC, menulio.svytuokle
Details
Test document with a test picture (2.02 MB, application/vnd.oasis.opendocument.text)
2015-07-27 18:09 UTC, menulio.svytuokle
Details
Test picture (2.01 MB, image/png)
2015-07-27 18:10 UTC, menulio.svytuokle
Details
Another picture with bigger DPI and size. (7.84 MB, image/png)
2015-07-28 05:24 UTC, menulio.svytuokle
Details
Print screen of LO Writer and WPS Writer (119.84 KB, image/jpeg)
2015-07-28 05:25 UTC, menulio.svytuokle
Details

Note You need to log in before you can comment on or make changes to this bug.
Description menulio.svytuokle 2015-07-25 21:27:17 UTC
Created attachment 117437 [details]
Ilustration for poor image quality in Writer

Very poor quality of inserted images in Writer - see attachment. Left side shows  picture in WPS Writer, Right side shows same picture in LibreOffice Writer, and You easily can see image distortion in LO Writer.
Comment 1 m.a.riosv 2015-07-26 01:33:36 UTC
Hi @menulio, thanks for reporting.

Have you activated the option:
Menu/Tools/Options/LibreOffice/View - Graphics output
to use hardware acceleration and anti-aliasing.
Comment 2 menulio.svytuokle 2015-07-26 19:35:35 UTC
Under Graphics output two options of four are checked:
[checked] Use hardware acceleration
[checked] Use anti-aliasing
[not checked] Use OpenGL for all rendering
[not checked] Force OpenGL ....
Comment 3 V Stuart Foote 2015-07-27 16:23:02 UTC
Each image type for both raster and vector images has to be rendered by filter into native bitmap for display on the document canvas. And additional filter processing for export or printing.

Specific filters require additional "helper" files to render the images.

Please identify the image type and origin that you are having rendering issues with. Also, would be best to attach both the source image, and a test document.
Comment 4 menulio.svytuokle 2015-07-27 18:09:07 UTC
Created attachment 117479 [details]
Test document with a test picture
Comment 5 menulio.svytuokle 2015-07-27 18:10:03 UTC
Created attachment 117480 [details]
Test picture
Comment 6 V Stuart Foote 2015-07-27 19:22:41 UTC
The .PNG raster image is only 800x656 pixels at 192ppi in the document. Or at 75dpi on ~A4 paper. That is not a very high resolution image to start with. 

Its rendering as bitmap on the document canvas appears correct.

Is there a different original of the graph being used in the WPS document? In EPS or EMF/WMF perhaps?
Comment 7 menulio.svytuokle 2015-07-28 05:24:03 UTC
Created attachment 117485 [details]
Another picture with bigger DPI and size.
Comment 8 menulio.svytuokle 2015-07-28 05:25:46 UTC
Created attachment 117486 [details]
Print screen of LO Writer and WPS Writer

A bug still exists in LO Writer even I use PNG images with bigger resolution / DPI.
Left side - WPS Writer, right side - LO Writer.
Comment 9 Cor Nouws 2015-07-30 21:39:21 UTC
Hi all,

Isn't this the same as 
 https://bugs.documentfoundation.org/show_bug.cgi?id=86675
?
Ciao - Cor
Comment 10 V Stuart Foote 2015-07-30 22:20:02 UTC
Yep, lets set as duplicate of bug 86675

*** This bug has been marked as a duplicate of bug 86675 ***