Download it now!
Bug 92935 - Impress Master slides view stuck. Can't close program.
Summary: Impress Master slides view stuck. Can't close program.
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
5.0.0.4 rc
Hardware: x86-64 (AMD64) Windows (All)
: highest major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-07-26 05:21 UTC by John
Modified: 2015-09-20 18:01 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
master pages panel screenshot (79.57 KB, image/png)
2015-07-26 05:55 UTC, tommy27
Details
Impress master slides stuck. Dropdown box empty (61.85 KB, image/png)
2015-07-26 15:34 UTC, John
Details
Can't close Impress normally with master slide viewer stuck (68.29 KB, image/png)
2015-07-26 15:35 UTC, John
Details

Note You need to log in before you can comment on or make changes to this bug.
Description John 2015-07-26 05:21:35 UTC
5.0.0.4 x64 under Win 8.1x64.

Installs fine. Open Impress, open Master Slide View panel, wait for available master slides to appear. Slides don't appear after a 10 or 15 minute wait - during this time all menu dropdown panels are blank so any attempt to close Impress normally fails and I have to close via Task Manager. 

Uninstalled and re-installed cleanly. Same problem that renders Impress unusable.

Looks very similar to bug 91635 which is labelled Resolved but not in my case.
Comment 1 tommy27 2015-07-26 05:55:54 UTC
Created attachment 117438 [details]
master pages panel screenshot

retested under Win8.1 x64 using LibO 5.0.0.4 (x64)
Build ID: cf112dc905650fb985306a7a03d2fe3fcc6c978f
Versione locale: en-US (it_IT)

now I understand better what the bug is about though I'm not still reproducing it 100%.

the master page panel thumbnails do not load immediately and I see a "loading preview" text instead of them... this is a regression towards the 4.4.x branch.

the thumbs do not generate event after waiting some minutes but I've found a workaround... just click on another panel, then move back to the master pages panel and you'll see all the thumbnails.

see my attached screenshot.

what I still don't see is the issue of the dropdown menu panels? would you please upload a screenshot so I can exactly see what you mean?
Comment 2 tommy27 2015-07-26 06:11:26 UTC
my PC has an AMD A8 processor, AMD Radeon R5 graphic card, 8 GB RAM and Samsung SSD 840 EVO 500G Disk.

would you please tell your system's specification?

I also can close Impress immediately even when the thumbs are still not loaded yet.
Comment 3 John 2015-07-26 15:34:39 UTC
Created attachment 117450 [details]
Impress master slides stuck. Dropdown box empty
Comment 4 John 2015-07-26 15:35:21 UTC
Created attachment 117451 [details]
Can't close Impress normally with master slide viewer stuck
Comment 5 tommy27 2015-07-27 05:40:11 UTC
thanks for screenshots. I confirm I don't see those issues on my PC.

did you try resetting the user profile?
see instructions here: https://wiki.documentfoundation.org/UserProfile

I see something strange with the first icons of the toolbar which don't match the Breeze theme (which is not the default theme on Windows) so I suspect that the old profile was not purged after uninstalling and reinstalling

and please, tell your system specs as asked in comment 2.

you can use Speccy to do that:
https://www.piriform.com/speccy
Comment 6 Buovjaga 2015-08-01 13:34:47 UTC
It crashes for me when I try to close LibO. Unknown exception. I'm not sure, how to get a backtrace..

Something is not right, so setting to NEW.

Win 7 Pro 64-bit Version: 5.1.0.0.alpha1+
Build ID: 902255645328efde34ddf62227c8278e8dd61ff0
TinderBox: Win-x86@39, Branch:master, Time: 2015-07-30_03:52:07
Locale: en-US (fi_FI)
Comment 7 Buovjaga 2015-09-20 18:01:51 UTC
Seems to work now. We can always change back to NEW, if it happens again.

This seems to be related: bug 94370