Bug 92996 - Function Wizard Structure view empty if invoked on existing formula cell
Summary: Function Wizard Structure view empty if invoked on existing formula cell
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.1.0.0.alpha0+ Master
Hardware: Other All
: medium normal
Assignee: Markus Mohrhard
URL:
Whiteboard: target:5.1.0 target:5.0.1
Keywords:
Depends on:
Blocks:
 
Reported: 2015-07-29 09:59 UTC by Eike Rathke
Modified: 2016-10-25 19:24 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Eike Rathke 2015-07-29 09:59:41 UTC
Enter a formula in A1, e.g. =1+SUM(2,3)
On cell A1 press Ctrl+F2 to invoke the Function Wizard.
The Structure view is empty instead of displaying the formula structure.
Comment 1 m.a.riosv 2015-07-29 22:37:05 UTC
Hi @Eike,

I can't reproduce.
Win7x64Ultimate
Version: 5.1.0.0.alpha1+ (x64) Build ID: e92a8b92072284fd7c37d7bb3e1e8fe72a185f35
TinderBox: Win-x86_64@62-TDF, Branch:MASTER, Time: 2015-07-22_21:46:26
Comment 2 Markus Mohrhard 2015-07-30 04:07:14 UTC
Surprisingly this does not look like a regression related to Ben's work. It looks more related to either the idle work or the vclptr.

The problem is the !Application::AnyInput( VclInputFlags::KEYBOARD ) in FormulaDlg_Impl::CalcStructure. That is also the reason that this works if you don't use the shortcut. Apparently the event is not cleared from the gtk event queue when we reach that place in the code.
Comment 3 Markus Mohrhard 2015-07-30 14:47:13 UTC
Actually it was just the gtk3 backend which behaved differently to the other backends. So it was not even a regression it was just a small issue in the new backend code.
Comment 4 Commit Notification 2015-08-05 19:22:54 UTC
Markus Mohrhard committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=a2eaa1bb9354c3e175d8b8de4f242bed89db4664

don't map GDK_KEY_RELEASE to keyboard events, tdf#92996

It will be available in 5.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 5 Commit Notification 2015-08-05 19:31:40 UTC
Markus Mohrhard committed a patch related to this issue.
It has been pushed to "libreoffice-5-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=2ca44dd59dc1833526e45f2a750ef8bb2888a60e&h=libreoffice-5-0

don't map GDK_KEY_RELEASE to keyboard events, tdf#92996

It will be available in 5.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.