Bug 93007 - Splash screen text needs to be moved upwards
Summary: Splash screen text needs to be moved upwards
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.0.0.4 rc
Hardware: Other Windows (All)
: medium normal
Assignee: Christian Lohmaier
URL:
Whiteboard: target:5.0.1 target:5.0.0
Keywords:
: 92926 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-07-29 18:28 UTC by Yousuf Philips (jay) (retired)
Modified: 2015-10-24 12:12 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
splash screen (38.70 KB, image/png)
2015-07-29 18:28 UTC, Yousuf Philips (jay) (retired)
Details
Splash screen Linux/KDE (34.30 KB, image/png)
2015-07-29 21:12 UTC, Heiko Tietze
Details
Splash screen with cut text (187.83 KB, image/png)
2015-08-01 14:08 UTC, Martin Srebotnjak
Details
Splash screen with some strange artefacts (117.56 KB, image/png)
2015-08-01 14:09 UTC, Martin Srebotnjak
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2015-07-29 18:28:40 UTC
Created attachment 117521 [details]
splash screen

When opening 5.0 on Windows 7 x64 bit, the text that appears in the splash screen is touching the bottom.

On a different note, wasnt there supposed to be a progress bar as well?

Version: 5.0.0.4
Build ID: cf112dc905650fb985306a7a03d2fe3fcc6c978f
Locale: en-US (en_US)
Comment 1 tommy27 2015-07-29 19:45:49 UTC
confirmed under Win8.1 x64 with LibO 5.1.0.0.alpha1+
Build ID: 62e2fae93e8894f73560a30ae1e752cbd4c001ad
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2015-07-29_04:40:44
Locale: en-US (it_IT)
Comment 2 Heiko Tietze 2015-07-29 21:12:24 UTC
Created attachment 117523 [details]
Splash screen Linux/KDE

Cannot confirm the text position issue under Linux/KDE - because there is no text at all ;-). But I'm sure that there is no progress bar.

Version: 5.1.0.0.alpha1+
Build ID: 74d4168f8830f7bbec6b784c3fb774296d9adafa
TinderBox: Linux-rpm_deb-x86_64@46-TDF, Branch:master, Time: 2015-07-22_06:14:00
Locale: de-DE (de_DE.UTF-8)
Comment 3 Adolfo Jayme 2015-07-29 21:35:29 UTC
Please use Bugzilla’s many search fields.

*** This bug has been marked as a duplicate of bug 92926 ***
Comment 4 Jan Holesovsky 2015-07-30 05:46:22 UTC
Let's duplicate it the other way around; this bugreport is better because it has a screenshot :-)
Comment 5 Jan Holesovsky 2015-07-30 05:47:35 UTC
*** Bug 92926 has been marked as a duplicate of this bug. ***
Comment 6 Jan Holesovsky 2015-07-30 09:17:08 UTC
Ah fun; so the change was there, but apparently the TDF builds are being built incrementally, and there were missing build dependencies.

Fixed now with:

http://cgit.freedesktop.org/libreoffice/core/commit/?id=86d2cddad3d4529cd877debaf258256cb07f5631

Cherry-pick requests for 5.0 and 5.0.0 pending in gerrit.
Comment 7 Commit Notification 2015-07-30 10:44:16 UTC
Jan Holesovsky committed a patch related to this issue.
It has been pushed to "libreoffice-5-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=a706a635eb2b03c7307dca91a47d77b2fbcc1a93&h=libreoffice-5-0

tdf#93007: Add missing build dependencies for *rc files.

It will be available in 5.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 8 Commit Notification 2015-07-31 00:25:40 UTC
Jan Holesovsky committed a patch related to this issue.
It has been pushed to "libreoffice-5-0-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=d450ac90bf83ae3404f9e62e9354211a18ac3192&h=libreoffice-5-0-0

tdf#93007: Add missing build dependencies for *rc files.

It will be available in 5.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 9 Martin Srebotnjak 2015-07-31 11:46:08 UTC
Just tried 5.0.0.5 (aka RC5 aka final 5.0 release) and on first load on OSX 10.10.4 it seems it is not properly fixed.

There are two phases of starting LO that have those messages written out.

On the first run after installation (and maybe sometime later as well) there is a phase of unpacking/installing bundled extensions and that text is still cut-off at the bottom (or really put to the bottom line).

There is then the next phase of loading LO which happens every time one loads LO and in that phase maybe the correction of written messages was corrected by the fix.

But the first "phase" still needs a fix. And that is something that greets the user after installing (maybe for the first time) LO. And the text is visible longer than in the second phase.
Comment 10 Jan Holesovsky 2015-07-31 12:05:49 UTC
I have no way of testing it - no OS X here :-(

Cloph: Can you please have a look?  Thank you!
Comment 11 Yousuf Philips (jay) (retired) 2015-07-31 13:57:49 UTC
Adding our mac team to test if this is fixed.
Comment 12 steve -_- 2015-08-01 08:01:27 UTC
tested with Version: 5.1.0.0.alpha1+
Build ID: 512b782cf466a19ed77d818fa660e1a0dc74fc35
TinderBox: MacOSX-x86_64@49-TDF, Branch:master, Time: 2015-08-01_00:25:31
Locale: de-DE (de.UTF-8)

text on first load after install is still too low and cut off.
Comment 13 Martin Srebotnjak 2015-08-01 08:25:11 UTC
So OSX is confirmed.
Does this happen on other OS's as well (the first load after install only)?

I guess the OS field needs to be changed, so this is why I am asking.
Comment 14 Yousuf Philips (jay) (retired) 2015-08-01 13:09:29 UTC
(In reply to steve -_- from comment #12)
> tested with Version: 5.1.0.0.alpha1+
> Build ID: 512b782cf466a19ed77d818fa660e1a0dc74fc35
> TinderBox: MacOSX-x86_64@49-TDF, Branch:master, Time: 2015-08-01_00:25:31
> Locale: de-DE (de.UTF-8)
> 
> text on first load after install is still too low and cut off.

Can we get a screenshot please. :D
Comment 15 Martin Srebotnjak 2015-08-01 14:08:05 UTC
OK, I guess the description must be updated.
I cannot reproduce solely on the en-US dmg install, but on the first run after also the Slovenian (sl) or probably any other language pack for OSX is installed.

I have tried running it for 20 times until I got the text in the screenshot as it moves quite fast.

After the first text is seen (in Slovenian it says that it is "synching with the extension repository shared") there is also some artifacts (or, another possiblity, there is another text, just positioned even lower so it is cut off as much as only the higher lines of it can be seen) - so I am attaching also the second screenshot appearing the next second.

So now everyone might believe me.
Comment 16 Martin Srebotnjak 2015-08-01 14:08:40 UTC
Created attachment 117578 [details]
Splash screen with cut text
Comment 17 Martin Srebotnjak 2015-08-01 14:09:09 UTC
Created attachment 117579 [details]
Splash screen with some strange artefacts
Comment 18 Martin Srebotnjak 2015-08-01 15:14:36 UTC
The actual displayed message is this from
/desktop/source/deployment/manager.po

#. E6TZo
#: dp_manager.src
msgctxt ""
"dp_manager.src\n"
"RID_STR_SYNCHRONIZING_REPOSITORY\n"
"string.text"
msgid "Synchronizing repository for %NAME extensions"
msgstr "Usklajevanje s skladiščem razširitev %NAME"
Comment 19 tommy27 2015-10-04 09:52:22 UTC
did anybody retest with 5.0.2.2 and call tell if this REOPENED bug is really fixed or unfixed?
Comment 20 Christian Lohmaier 2015-10-24 12:12:04 UTC
the changes to fix the position in the installation packages only has been pushed to master, but the 5-0 branch was forgotten - fixed that now with http://cgit.freedesktop.org/libreoffice/core/commit/?h=libreoffice-5-0&id=f73c3b7d7dc68bd1b44749fdc755a9bca1bb6ce8 and http://cgit.freedesktop.org/libreoffice/core/commit/?h=libreoffice-5-0-3&id=ce5407549cb76d2792236f2b44a22ff596e35ca2