Bug Hunting Session
Bug 93021 - CSV file has Chinese characters when opened in Calc
Summary: CSV file has Chinese characters when opened in Calc
Status: RESOLVED DUPLICATE of bug 82418
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.4.4.3 release
Hardware: x86-64 (AMD64) Linux (All)
: medium blocker
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-07-30 05:32 UTC by miltonh26
Modified: 2015-07-30 11:50 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments
Corrupted CSV file (28 bytes, text/csv)
2015-07-30 05:32 UTC, miltonh26
Details
Screenshot of Chinese chars upon csv file import (54.56 KB, image/png)
2015-07-30 05:32 UTC, miltonh26
Details

Note You need to log in before you can comment on or make changes to this bug.
Description miltonh26 2015-07-30 05:32:02 UTC
Created attachment 117526 [details]
Corrupted CSV file

Create a new spreadsheet in Calc and save it out as a CSV file. 
Open the CSV file in Calc
Notice the Chinese characters in the import dialog 

Ubuntu 14.04 x64

LO installed with the LO website download (not the built-in Ubuntu LO)
Comment 1 miltonh26 2015-07-30 05:32:50 UTC
Created attachment 117527 [details]
Screenshot of Chinese chars upon csv file import
Comment 2 Maxim Monastirsky 2015-07-30 11:50:46 UTC
That's because UTF-16 is selected in "Character Set". You should choose there the right encoding.

*** This bug has been marked as a duplicate of bug 82418 ***