Bug Hunting Session
Bug 93088 - Add easy way to attach a colour palette in to document
Summary: Add easy way to attach a colour palette in to document
Status: RESOLVED DUPLICATE of bug 63898
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: ux-advise (show other bugs)
Version:
(earliest affected)
5.0.0.4 rc
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-08-03 02:34 UTC by Bastián Díaz
Modified: 2015-09-19 05:20 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Bastián Díaz 2015-08-03 02:34:09 UTC
Description of problem/improve:
The ability to embed a customized list of colors in a document is already available in Impress and Draw. Unfortunately, this feature is somewhat hidden (Format|Area|Colors|Embed). Despite being a specific option (Area), the list of custom colors is set to "default  palette" for the entire document.

The problem is that this option is not intuitive for the user and is only available for Impress and Draw (can be included in Writer and Calc).
color
Improvement proposal:
A good idea would be to generalize this option and make it more visible to the user. It would be very intuitive to add this option as a new style for the document:

A) New section:

Color Styles
  + Document
  + Chart

Color styles for the document, establish one or more lists of custom colors embedded in the document.
The chart styles, establish a list of 12 or more colors to the data series. With the above, when you insert a new chart, this will have colors according to the layout of the document/template.

B) Add the style to the currently available sections:

Graphic styles (can be included in Writer, Calc and Draw)
  + ...
  + Chart (for colors or other general options)

Presentation styles (including a counterpart for Writer, Calc and Draw)
  + ...
  + Colors (if preferred, in this style can include options for color document and chart).

C) As an option for "color bar"
Thanks

* In general, this will help create more professional documents and templates for LibreOffice
Comment 1 Buovjaga 2015-08-03 11:54:00 UTC
Let's throw this over the fence to design team.
Comment 2 Bastián Díaz 2015-09-18 16:27:48 UTC
Change summary:

Previous title: Add function to embed custom color list as a style

New title: Add easy way to attach a colour palette in to document

The focus of the report is changed to prevent confusion with the new proposed functionalitydocument themes.
The aim of this report is able to easily add a custom color palette in the document.

Cheers
Comment 3 Francisco 2015-09-19 05:20:42 UTC

*** This bug has been marked as a duplicate of bug 63898 ***