Download it now!
Bug 93132 - Brother HL-1110 refuses to print through CUPS
Summary: Brother HL-1110 refuses to print through CUPS
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
4.4.4.3 release
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Printer-Settings
  Show dependency treegraph
 
Reported: 2015-08-05 08:41 UTC by Stefan Champailler
Modified: 2019-01-17 11:36 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
A document my Brother HL 1110 won't print (384.06 KB, application/pdf)
2015-08-05 08:41 UTC, Stefan Champailler
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Stefan Champailler 2015-08-05 08:41:29 UTC
Created attachment 117662 [details]
A document my Brother HL 1110 won't print

Hello LO,


when trying to to print to my BROTHER HL-1110 it occurs now and then that I can't print at all. The problem seems linked to the fact that I embed some images in the document. Usually a simple document with just one picture fails to print.

I though it was the picture resolution or picture size that prevented printing but it doesn't seem to be that. I'd say this bug is related to the complexity of the picture, but again, I've not much confidence in that.

LibreOffice does the printing fine (it sends the document to CUPS) and then, I think, CUPS fails to print it. So one might think that CUPS is the cuplrit. 
CUPS seems to send the document to the printer correctly as well (no problem reported on the regular user interface; job marked as completed).

However, if I ask LO to export my document to a PDF, then I can print the PDF (with the very basic xpdf). So I guess there's something wrong in the way LO prepares the document for printing.

I've been experiencing that kind of trouble for more than a year, which spans several versions of LO. So I definitely can live with it, but it gives bad reputation to LO in my family :-)

I've attached a document which fails to print. The first page prints well, the second doesn't.You'll notice that the complexity of the second image is higher : more roads, more stuff.

Running LO on a fairly recent (about 3 months old for most of the packages) Debian testing.
CUPS version is : 1.5.3 (older than 3 month, but since installing the Brother's driver was a bit tough, I fear to update CUPS :-))
The printer drivers are rather old (installed when I installed the printer  about a year ago)
Comment 1 Stefan Champailler 2015-08-05 12:52:13 UTC
For some reason, CUPS report a strange version number, the actual version is 1.7.5
Comment 2 Stefan Champailler 2015-08-05 12:54:51 UTC
I've looked somem ore and my driver for HL 1110 is the official one, version 3.0.1 which is the latest one...
Comment 3 Stefan Champailler 2015-08-05 13:06:42 UTC
Hmmm...


Found out this :

http://www.openprinting.org/printer/Brother/Brother-HL-1110

which says :

Comments

This printer does work in Linux using the proprietary driver supplied by Brother, however there are some issues, namely the fact that I had an "out of memory" error (many PDF files do not print in standard resolution with this printer, which has a very limited amount of memory), and in Linux it never explained what the error was. It simply activated the flashing red LED and refused to print, while in Windows it displayed the actual error message.
Comment 4 Stefan Champailler 2015-08-05 13:14:08 UTC
argh , the attachment is wrong, I gave the PDF which prints correctly, not the original document... We'll try to recover it
Comment 5 tommy27 2015-08-13 15:18:18 UTC
just to tell that there are multiple bug reports with Brother printers and LibO.
there are several issues with this specific brand.
Comment 6 Buovjaga 2016-05-02 15:45:45 UTC
Any update? Did you check our other Brother reports in case this is already reported?

Set to NEEDINFO.
Change back to UNCONFIRMED, if the problem persists and is unique to the bug tracker. Change to RESOLVED DUPLICATE, if you found some older report.
Comment 7 QA Administrators 2016-11-08 12:33:12 UTC Comment hidden (obsolete)
Comment 8 QA Administrators 2016-12-07 12:35:17 UTC Comment hidden (obsolete)
Comment 9 Poppz 2018-05-16 10:56:16 UTC
Yeah I have had this problem for a long time. 

The Brother drivers are inadequate in their control of the printer settings and print density - but that is one thing. 

The real issue is that Libre Office will not print anything, through this printer and drivers, BUT:

If I reverted to Open Office, and opened the Libre Office document in that, then it would print.

If I converted the Libre Office document to PDF, then it would print.

I do not like Microsoft - and it's basically open warfare on that subject, but one of the issues with the Open Source software is that sometimes it ought to be classified as Open Sores, as the large range of technical problems that can come with using it, which render the tiring of the mind and waste of resources, in getting things to work.

This problem with Libre Office is NOT resolved... 

And dear moderator, instead of using the generic copy paste god mode command to declare that it is, try to work on this to get it resolved.

All other programs that interface with this printer work just fine, including the old Open Office. Libre Office does not. Why? And how do we go about fixing it?
Comment 10 Buovjaga 2018-05-16 11:16:53 UTC
Poppz: Please copy and paste here the contents of your Help - About. This allows us to know more about your system.

What is your printer model?
The original report by Stefan was about an intermittent problem, usually involving images in a document. Are you seeing the problem with any, even empty documents?
Comment 11 Poppz 2018-05-16 12:26:14 UTC
I use Xubuntu - latest LTS, and (In reply to Buovjaga from comment #10)
> Poppz: Please copy and paste here the contents of your Help - About. This
> allows us to know more about your system.
> 
> What is your printer model?
> The original report by Stefan was about an intermittent problem, usually
> involving images in a document. Are you seeing the problem with any, even
> empty documents?

I use Xubuntu - latest LTS, Xubuntu 16.04 

And the CUPS printer driver and the Brother HL1110 CUPS printer files....

hl1110cupswrapper-GPL_src-3.0.1-1

This problem with Libre Office not driving the printer or the printer driver has been going on for about 3 or 4 years now....

The work arounds are to convert to PDF and that will print. Or to open it under Open Office - and that will print.

Abiword prints.

Mousepad prints.

Kate (text editor) also hangs.....

The printer symbol that pops up in the task bar when printing is active, also shows the documents to be printed as being "held".

In the "Document Print Status" of the symbol, JOB ATTRIBUTES [name] job-hold-until [value] no-hold 

I can tunnel in way more to any file or location or process... but it's late, I am tired and I have been working on this old issue most of the day.


I could do with some help on some things.

With a Libre Office ODT document, what programs initiate when "print" is run, is there a converter that recompiles it into printer speak, and then to the driver? or does the program send directly to the printer drivers,

What is the location and name or names of this file/s?

Can the document - now converted to a data stream, to the printer be captured and examined?

And what format or encoding is it in... Because I can generate 2 basic text files in a text file editor and in libreoffice, and then do a comparison of what gets to the printer, and why the LO file gets held and the text editor file gets printed, by reading the differences.

but I'd like some help with this.
Comment 12 Buovjaga 2018-05-16 12:38:14 UTC
Thanks, let's set to NEW.

I am not a developer, but I believe this is the directory for the relevant bits in the source code: https://opengrok.libreoffice.org/xref/core/vcl/unx/generic/printer/
Comment 13 Poppz 2019-01-05 13:26:37 UTC Comment hidden (obsolete)
Comment 14 Poppz 2019-01-05 13:36:30 UTC
The previous link was (I am tired).... 

Here are the linux and other OS drivers to download link.


https://support.brother.com/g/b/downloadtop.aspx?c=eu_ot&lang=en&prod=hl1110_us_eu_as

https://support.brother.com/g/b/downloadlist.aspx?c=eu_ot&lang=en&prod=hl1110_us_eu_as&os=128
Comment 15 Buovjaga 2019-01-05 13:38:57 UTC
(In reply to Poppz from comment #13)
> 7. I recall that the people at Brother in Japan did make a straight Linux
> driver that is downloadable (at least from the command line), and thanks to
> me, they also included the instructions for the different Linux OS's.
> 
> https://support.brother.com/g/s/id/linux/en/before.
> html?c=us_ot&lang=en&comple=on&redirect=on
> 
> The Libreoffice now prints NICE black laser printer type text, and the PDF's
> print, and the machine spits them out, almost immediately after pressing
> "print".
> 
> I can't speak for everyone - but for me, I and many others in my case, have
> solved the problem... 

This sounds fantastic, thanks for putting in the effort.

The original reporter has not been responsive, so let's close this as NOTOURBUG as it was solved from Brother's side.