Bug 93151 - "Expand references when new columns/rows are inserted" broken for named ranges
Summary: "Expand references when new columns/rows are inserted" broken for named ranges
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.2 all versions
Hardware: All All
: medium critical
Assignee: Eike Rathke
URL:
Whiteboard: target:5.2.0 target:5.1.0 target:5.0....
Keywords: regression
Depends on:
Blocks:
 
Reported: 2015-08-05 16:41 UTC by Oliver Brinzing
Modified: 2017-03-19 21:09 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Expand references when new columns/rows are inserted (8.89 KB, application/vnd.oasis.opendocument.spreadsheet)
2015-08-05 16:41 UTC, Oliver Brinzing
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Oliver Brinzing 2015-08-05 16:41:05 UTC
Created attachment 117680 [details]
Expand references when new columns/rows are inserted

steps to reproduce:

- open attached sample spreadsheet

- enable "Expand references when new columns/rows are inserted"
  in Tools - Options... - LibreOffice Calc - General

- insert new column at column "C"

- sum formula in cell B3 will expand to A1:C1 but sum formula in B5 with 
  named range "Test" ($Sheet1.$A$1:$B$1) will not expand to $Sheet1.$A$1:$C$1

btw: this behaviour is different from aoo
Comment 1 Oliver Brinzing 2015-08-05 17:02:53 UTC
i have to be a bit more precise:

i one enters a value in cell "C1" after insterting the column 
both formula's will calculate the new value!

but the named range will still show the old range:
check with (Strg)+F3 or save and relaod the spreadsheet
Comment 2 m.a.riosv 2015-08-05 18:57:23 UTC
Hi brinzing, thanks for reporting.

Reproducible.
Win7x64Ultimate
Version: 5.0.0.5 (x64) Build ID: 1b1a90865e348b492231e1c451437d7a15bb262b
Version: 5.1.0.0.alpha1+ (x64) Build ID: cd6c9aef7468120dd5ea5c747f35c98baf214613
         TinderBox: Win-x86_64@62-TDF, Branch:MASTER, Time: 2015-08-03_22:17:26

What it's really strange is that "Test" shows a bad address but does fine the calculation even with hard recalc, but wrong address is saved, so after reopen the calculation is as if the columns wasn't inserted.


Regression since:
Version: 4.4.5.2 Build ID: a22f674fd25a3b6f45bdebf25400ed2adff0ff99
Comment 3 raal 2015-09-24 08:44:30 UTC
bibisect-win32-5.0, oldest version contains bug too, so bug is younger
git checkout oldest: Version: 4.5.0.0.alpha0+
Build ID: 57d6b92b69a31260dea0d84fcd1fc5866ada7adb
Comment 4 Eike Rathke 2016-01-26 11:35:19 UTC
Already at least in 4.2.x, just that whether the formula that uses the name includes the inserted column in calculation changed somewhen in between.

I'm investigating.
Comment 5 Commit Notification 2016-01-26 15:15:53 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=02e69f0c3acec2c2e81692bc53c4356591a84ba5

Resolves: tdf#93151 handle ExpandRefs and mnColDelta the same as mnRowDelta

It will be available in 5.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Eike Rathke 2016-01-26 15:36:34 UTC
Pending review
https://gerrit.libreoffice.org/21812 for 5-1
https://gerrit.libreoffice.org/21813 for 5-1-0
Comment 7 Eike Rathke 2016-01-26 19:35:33 UTC
https://gerrit.libreoffice.org/21821 for 5-0
https://gerrit.libreoffice.org/21822 for 5-0-5
Comment 8 Commit Notification 2016-02-02 12:25:47 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "libreoffice-5-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=7bf650756eaaaaec0213d72515c407e8ea998241&h=libreoffice-5-1

Resolves: tdf#93151 handle ExpandRefs and mnColDelta the same as mnRowDelta

It will be available in 5.1.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Commit Notification 2016-02-02 12:25:58 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "libreoffice-5-1-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=0c128d84fa2a59b5e76ad844e2feeedd281fdbc2&h=libreoffice-5-1-0

Resolves: tdf#93151 handle ExpandRefs and mnColDelta the same as mnRowDelta

It will be available in 5.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Commit Notification 2016-02-02 12:28:15 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "libreoffice-5-0-5":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=a2b336c89baba81421c7fdc1fef0997b36f4377b&h=libreoffice-5-0-5

Resolves: tdf#93151 handle ExpandRefs and mnColDelta the same as mnRowDelta

It will be available in 5.0.5.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Commit Notification 2016-02-02 17:23:18 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "libreoffice-5-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=406fdc37081a2bdbb4f15f80605f881105c15da0&h=libreoffice-5-0

Resolves: tdf#93151 handle ExpandRefs and mnColDelta the same as mnRowDelta

It will be available in 5.0.6.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Oliver Brinzing 2016-02-06 14:18:23 UTC
> Affected users are encouraged to test the fix and report feedback.

just did a quick check with lo 5.0.5.2 - seems to be fixed :-)
Comment 13 Commit Notification 2017-03-19 21:09:41 UTC
Markus Mohrhard committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=47d4f6252df2ec3cc9f7363ce37e043dcec20f2e

add test for tdf#93151

It will be available in 5.4.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.