Download it now!
Bug 93203 - Reduce duplicate items in LO interface
Summary: Reduce duplicate items in LO interface
Status: RESOLVED DUPLICATE of bug 33223
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.1.0.4 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-08-06 15:55 UTC by Rodrigo Zimmermann
Modified: 2015-08-08 21:12 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rodrigo Zimmermann 2015-08-06 15:55:31 UTC
Currently, LibreOffice's interface is very confused, with a sidebar and the old toolbars polluting the interface. It happens that many items listed in the toolbars are also in the sidebar.

The solution is to improve the sidebar so that it responds to the context of what the user is doing, allowing remove the interface toolbars.

It may be implementing an enable / disable toolbars to suit users who dislike the sidebar.
Comment 1 V Stuart Foote 2015-08-06 19:05:48 UTC

*** This bug has been marked as a duplicate of bug 33223 ***
Comment 2 Yousuf Philips (jay) (retired) 2015-08-06 22:29:51 UTC
Hi Rodrigo,

Currently the sidebar is an optional interface for users to use, so users who prefer using toolbars can easily hide the sidebar. For people who prefer to use the sidebar, which has a contextual properties tab, then can easily hide the contextual toolbars in the View > Toolbars menu.
Comment 3 Rodrigo Zimmermann 2015-08-07 15:56:28 UTC
Sorry to disagree with the previous review, but the sidebar will always appear, even for those who prefer to only use the tool bars (my case).

Just open the clip-art gallery, the sidebar is called, also just open the Styles and Formatting tool that the sidebar is called.

The problem is not the sidebar is called, but it offer many items in duplicate (for what formatting toolbar at the top of the window and the same constant commands in a sidebar?)

I wish I could use LibreOffice only the sidebar or the toolbars, but unfortunately this is not possible by the fact that some features make the sidebar always appear. In addition, the sidebar has not all resources contained in the toolbars.
Comment 4 V Stuart Foote 2015-08-07 20:56:07 UTC
Correct, the dialogs have been collapsed into the Sidebar deck. By design <F11> launch of Styles and Formatting is pinned into the Sidebar Deck.

The <F5> Navigator will still launch a separate instance "dialog" detached from the Sidebar Deck, but that was deemed necessary because of Navigator's UI.

There is no way to launch the Clip Art Gallery by accelerator, nor as a detached dialog, it opens by menu action View -> Clip Art Gallery, or Insert -> Media -> Clip Art Gallery. Or from the Sidebar's tab bar.

Work on bug 33223 --  "Sidebar: as container for toolbars, ability to add functions missing from Sidebar", and bug 85905 --  "Allow undocking of Sidebar decks" will eventually correct 

See https://bugs.documentfoundation.org/show_bug.cgi?id=33223#c11 and review the linked issues there for a better understanding of what the Sidebar has potential to evolve into.
Comment 5 Yousuf Philips (jay) (retired) 2015-08-08 21:12:55 UTC
(In reply to Rodrigo Zimmermann from comment #3)
> Just open the clip-art gallery, the sidebar is called, also just open the
> Styles and Formatting tool that the sidebar is called.

Usage of the clip art gallery and styles & formatting tabs of the sidebar are not duplication of items found elsewhere in the interface, which is what this bug report was about.

> The problem is not the sidebar is called, but it offer many items in
> duplicate (for what formatting toolbar at the top of the window and the same
> constant commands in a sidebar?)

These duplicated items are found in the Properties tab and if a toolbar user, which i am one, doesnt wish to use/see that tab and those duplicated items, he doesnt need to. I press F11 to open styles & formatting and then press it again to close it.

> I wish I could use LibreOffice only the sidebar or the toolbars, but
> unfortunately this is not possible by the fact that some features make the
> sidebar always appear. In addition, the sidebar has not all resources
> contained in the toolbars.

I believe once the sidebar has matured enough, having a toolbar mode that only has gallery and styles sidebar entries and a sidebar mode (bug 92220) that only has a single toolbar at the top can be achieved.