Bug 93269 - LibreOffice 5 64 bit cannot show a lot of unicode chars in "insert, special characters" - 32 bit is OK
Summary: LibreOffice 5 64 bit cannot show a lot of unicode chars in "insert, special c...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.0.0.5 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-08-08 10:16 UTC by urly
Modified: 2015-09-15 07:07 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description urly 2015-08-08 10:16:32 UTC
If I open the window "insert, Special Characters" in Writer of LibreOffice 5 64 bit, a lot of mathematical characters (u+21D4, ...) in each font ("Liberation Serif", "Linux Libertine G", "Lucida Sans Unicode", "Cambria Math", ...) are vanished.
But: in LO 5.0.0.5 32 bit this problem is vanished.
Both on: Windows 10 Pro 64 bit
Thanks and best regards
Uli
Comment 1 Yan 2015-08-12 14:00:16 UTC
Same problem Linux 64bit. Btw. choosing a subset (like Extended Greek, e.g.) does not change the display or places the cursor to some questionable place on the same "code page".
Comment 2 Maxim Monastirsky 2015-08-12 14:30:49 UTC
Hi,

Could you please have a look at Bug 93114? Is it the same issue you're experiencing?
Comment 3 Yan 2015-08-12 15:21:53 UTC
To me, Bug 93114 is different since the displayed characters seem to be in order, but only the wrong "code page".

I have now tried to check the behaviour and need to tell that I cannot reproduce the bug anymore (I have opened a new session meanwhile).
Comment 4 urly 2015-08-16 06:34:51 UTC
With LO 5.0.1.1 64 bit the same problem: some not-shown special characters and some wrong code page.

For example: the Unicode characters
0x21D4 <=>
0x21C4 arrow left and right above.
If I mouseclick the crossed field, the correct char. is shown in the textfield.
Comment 5 Buovjaga 2015-09-11 19:20:40 UTC
(In reply to urly from comment #4)
> With LO 5.0.1.1 64 bit the same problem: some not-shown special characters
> and some wrong code page.
> 
> For example: the Unicode characters
> 0x21D4 <=>
> 0x21C4 arrow left and right above.
> If I mouseclick the crossed field, the correct char. is shown in the
> textfield.

Can you include a screenshot? I could not find U+21D4 or 21C4 at all, no crossed field.

Win 7 Pro 64-bit, Version: 5.0.1.2 (32-bit)
Build ID: 81898c9f5c0d43f3473ba111d7b351050be20261
Locale: fi-FI (fi_FI)
Comment 6 urly 2015-09-15 06:40:02 UTC
Thanks,
in LO 5.0.1.2 64 bit the bug is fixed.
Comment 7 Adolfo Jayme 2015-09-15 07:07:52 UTC
The FIXED status is reserved for issues closed by an explicit commit to the Git repository.