Bug Hunting Session
Bug 93304 - Font files are left in the Windows font directory after uninstallation -- redux
Summary: Font files are left in the Windows font directory after uninstallation -- redux
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Installation (show other bugs)
Version:
(earliest affected)
5.0.0.5 release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Installer-Windows
  Show dependency treegraph
 
Reported: 2015-08-09 17:09 UTC by V Stuart Foote
Modified: 2018-09-15 17:23 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
LO 5.0.0.5 msiexec verbose install log (1.88 MB, application/zip)
2015-08-09 17:10 UTC, V Stuart Foote
Details
LO 5.0.0.5 msiexec verbose Uninstall log (770.99 KB, application/zip)
2015-08-09 17:11 UTC, V Stuart Foote
Details

Note You need to log in before you can comment on or make changes to this bug.
Description V Stuart Foote 2015-08-09 17:09:09 UTC
So poking at this for bug 76239, which lead me around to bug 68194

I'm not sure we have things correct on the Windows installer.

I manually cleaned Windows 7 sp1 64-bit or all LibreOffice fonts, and verified not winsxs GAC residual.

C:\Windows\Fonts empty of all fonts, no remaining linkages in Windows registry.

Install clean LibreOffice 5.0.0.5, CLI msiexec.exe /i run as administrator, with verbose logging (attached).

full slate of LO external fonts are present.  Launch LO and fonts are present.

Uninstall LibreOffice 5.0.0.5, CLI msiexe.exe /x run as administrator, with verbose logging (attached).

The LibreOffice installed fonts are NOT removed from C:\Windows\Fonts

Uninstall logs seem to suggest there is no action performed against the fonts which are listed as Installed: Local  Action: Null

Don't think the installer is behaving as intended, i.e. regards themsidbComponentAttributesSharedDllRefCount, with the work done for bug 68194.
Comment 1 V Stuart Foote 2015-08-09 17:10:25 UTC
Created attachment 117792 [details]
LO 5.0.0.5 msiexec verbose install log
Comment 2 V Stuart Foote 2015-08-09 17:11:00 UTC
Created attachment 117793 [details]
LO 5.0.0.5 msiexec verbose Uninstall log
Comment 3 V Stuart Foote 2015-08-09 17:13:50 UTC
So, guess the point of all this is that we don't seem to have the logic for handling registration into the C:\Windows\Fonts directory correct for installation (recording details for uninstall) or for doing the uninstall.
Comment 4 QA Administrators 2016-09-20 10:21:27 UTC Comment hidden (obsolete)
Comment 5 V Stuart Foote 2018-09-15 17:23:09 UTC
Will recheck, but believe this is resolved WFM, have not had this issue is some time. Sorry for letting it rot.