Bug Hunting Session
Bug 93400 - Allow for setting of default table format (in addition to existing autoformat)
Summary: Allow for setting of default table format (in addition to existing autoformat)
Status: RESOLVED DUPLICATE of bug 34391
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Table-AutoFormat
  Show dependency treegraph
 
Reported: 2015-08-12 20:54 UTC by Severo Raz
Modified: 2017-10-18 06:45 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Severo Raz 2015-08-12 20:54:20 UTC
Tables are elements whose style or format is currently non-definable in a template. This results in a cumbersome experience if you are working on a document where lots of tables need to be created, like scientific documents.

Only the "Table Format" dialog that is created when one accesses an individual table's properties allows for the customization of all the important attributes of a table (size, alignment, spacing, text flow options, borders and inner spacing) except its aesthetic style, which is only practically set by using the table Autoformat options. It seems unnatural that these two table customization tools are separate.

I think this problem may have different solutions; I will chip in with mine below.

The table Autoformat dialog, upon the creation of a new table format, must adopt all the relevant attributes of the source (selected) table (namely size, alignment, spacing, text flow options, borders and inner spacing, besides the color data which it already saves). (It should also include an "Update" action, but this is out of the scope of this bug.)
It should also allow for a specific table (auto)format to be set as default, so that every new table created adopts this (auto)format automatically.
Additionally, in the Table Format dialog, an Autoformat tab must exist, so that the user can change the table's (auto)format from the said dialog.

Of course, the best solution to this bug will only be revealed after you post your ideas and the best is selected.
Comment 1 Cor Nouws 2015-08-12 21:16:26 UTC
Thanks Severo. Set as new enhancement.
Comment 2 Thomas Lendo 2017-10-17 22:48:53 UTC
Seems to be a duplicate of Bug 34391 "FORMATTING: Implementing Table Styles" due to the AutoFormat is a dying feature.
Comment 3 Yousuf Philips (jay) (retired) 2017-10-18 06:45:45 UTC
This will be resolved with table styles.

*** This bug has been marked as a duplicate of bug 34391 ***