Bug 93437 - Once the Function Wizard has been Displayed, it is not Possible to Select Columns or Rows or to Open the Context Menu of Columns and Rows
Summary: Once the Function Wizard has been Displayed, it is not Possible to Select Col...
Status: CLOSED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.0.0.5 release
Hardware: Other All
: highest blocker
Assignee: Katarina Behrens (CIB)
URL:
Whiteboard: target:5.1.0 target:5.0.2
Keywords: regression
: 93757 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-08-14 21:14 UTC by Harald Koester
Modified: 2016-10-25 19:21 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Harald Koester 2015-08-14 21:14:12 UTC
In order to reproduce the bug:

[1] Open new spreadsheet.
[2] Click Function Wizard. The dialogue is opened.
[3] Cancel dialogue.
[4] Try to select row or column. Columns and can't be selected.
[5] Try to open context menu of a column (A, B,..) or of a row (1,2,3,..). No context menu is opened.

At step [3] you can also insert a function. The result is the same. I tried it with the function TODAY.

Ver. 5.0.0.5 with Win 7 (32 bit).
Comment 1 Harald Koester 2015-08-14 21:50:10 UTC
Additional info: Works for me with version 4.4.4. Hence regression.
Comment 2 m.a.riosv 2015-08-15 01:21:03 UTC
Reproducible.
Win7x64Ultimate
Version: 5.0.1.1 (x64) Build ID: 13f702ca819ea5b9f8605782c852d5bb513b3891
Version: 5.1.0.0.alpha1+ Build ID: 7d3fa6bae9f7a755eb2d0ca24bf1afd5f3646bb7
TinderBox: Win-x86@39, Branch:master, Time: 2015-08-09_08:38:08
Comment 3 Julien Nabet 2015-08-15 13:38:33 UTC
On pc Debian x86-64 with master sources updated yesterday, I could reproduce this.
I only noticed these logs when closing wizard dialog:
warn:legacy.osl:32416:1:include/cppuhelper/interfacecontainer.h:479: object is disposed
warn:legacy.osl:32416:1:include/cppuhelper/interfacecontainer.h:479: object is disposed
warn:legacy.tools:32416:1:vcl/inc/svdata.hxx:389: object deleted while in use !

I noticed too that if I run format cell (from context menu in a cell or from menu) or another kind of function which calls a dialog, it's ok.

Even if it's not a crash and you don't lose data, considering how it's simple to reproduce this and the fact that you can encounter this more than often in Calc, I think it's a blocker (or whatever the new word to name this kind of case)

Eike: thought you might be interested in this one.
Comment 4 Julien Nabet 2015-08-15 14:25:17 UTC
I wonder if it could be due to a wrong fix from me for tdf#91273 (see http://cgit.freedesktop.org/libreoffice/core/commit/?id=844b7287a4ccd8e3d5e458bb1dc6c52e71322b01)
Comment 5 Katarina Behrens (CIB) 2015-08-20 09:10:23 UTC
I'll give this a try ...
Comment 6 Commit Notification 2015-08-20 11:44:55 UTC
Katarina Behrens committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=808063ebe7d410eb7e370be1f5d8047377137dfb

tdf#93437: Re-enable input after closing formula wizard

It will be available in 5.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 7 Commit Notification 2015-08-20 12:21:47 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=f4fb9bec728a5e1ccd8466efa4d60f429478cefa

Revert "tdf#93437: Re-enable input after closing formula wizard"

It will be available in 5.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 8 Commit Notification 2015-08-21 22:35:40 UTC
Katarina Behrens committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=11b8a74d78e018c67217c05d83bd4947869e535a

tdf#93437: Calc RefDialogs were never actually destructed

It will be available in 5.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 9 Commit Notification 2015-08-24 13:06:06 UTC
Katarina Behrens committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=e931b059571c9f0cad4cc5ec6bd75a3ab46fb0d1

tdf#93437: release reference held by ScFormulaReferenceHelper

It will be available in 5.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 10 Commit Notification 2015-08-24 14:10:26 UTC
Katarina Behrens committed a patch related to this issue.
It has been pushed to "libreoffice-5-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=d92c8638a186900711faa88be5bed254b0574712&h=libreoffice-5-0

tdf#93437: release reference held by ScFormulaReferenceHelper

It will be available in 5.0.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 11 Katarina Behrens (CIB) 2015-08-24 14:12:10 UTC
This was a tough one. Let's set it to fixed
Comment 12 Jean-Baptiste Faure 2015-08-24 15:27:46 UTC
Verified on version 5.0.2.0+ build at home under Ubuntu 15.04 x86-64 with GCC 5.1.
Version: 5.0.2.0.0+
Build ID: d92c8638a186900711faa88be5bed254b0574712
Ubuntu_15.04_x86-64
Locale : fr-FR (fr_FR.UTF-8)

Thank you very much.
JBF
Comment 13 Julien Nabet 2015-08-29 07:24:32 UTC
*** Bug 93757 has been marked as a duplicate of this bug. ***
Comment 14 Ari Latvala 2015-08-30 06:10:09 UTC
Same problem now with the latest 5.0.1.2 version on Windows 7 SP1 64-bit. One way to get functionality back is to add / delete row, column, or cell.
Comment 15 Julien Nabet 2015-08-30 07:56:20 UTC
(In reply to Ari Latvala from comment #14)
> Same problem now with the latest 5.0.1.2 version on Windows 7 SP1 64-bit.
> One way to get functionality back is to add / delete row, column, or cell.

It's fixed from 5.0.2 (5.0.2 is after 5.0.1.2)
Comment 16 Harald Koester 2015-09-30 13:54:29 UTC
Fix verified with version 5.0.2.2 (Win 7). Is OK now. Hence bug closed.