Bug 93494 - "Replace image" duplicates AutoCaption
Summary: "Replace image" duplicates AutoCaption
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4.0.0.beta1
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: AutoCaption
  Show dependency treegraph
 
Reported: 2015-08-17 21:35 UTC by Christian Pietzsch
Modified: 2021-06-24 03:46 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
double caption (118.21 KB, image/png)
2015-08-17 21:35 UTC, Christian Pietzsch
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Christian Pietzsch 2015-08-17 21:35:33 UTC
Created attachment 117983 [details]
double caption

Overview:
If you have AutoCaption for Writer images activated and replace an existing image with an AutoCaption the new image gets inserted with an extra caption.

Steps to Reproduce:
1) activate AutoCaption
2) insert image
3) use "replace image"

Actual Results:
Another caption gets added inside the first one. See attachment


Tested on Ubuntu 15.04 Kernel 3.16 and Windows 8
Comment 1 Cor Nouws 2015-09-05 18:58:31 UTC
Thanks for filing the issue Christian.
I confirm the problem in 5.0.1.2 on Ubuntu.

Do you have any idea when this problem fist occurred, are you sure it worked different before?
regards - Cor
Comment 2 Christian Pietzsch 2015-09-06 18:01:54 UTC
Version 5 was the first one I used auto captions. Going to try it with older versions in the following days.
Comment 3 Christian Pietzsch 2015-09-07 10:39:18 UTC
Tested it in the earliest version I could find. The feature was introduced in Version 4.4. The bug was present in version: 4.4.5.2
I also tested earlier versions (4.3.5.2). I could reproduce the behaviour when I deleted an image with auto-captions drag a new one in.
Comment 4 Christian Pietzsch 2015-09-08 08:43:26 UTC
Did another test with LibreOffice 4.4.0.0 beta 1 (first release with change image feature)
The bug is present in this version so it has been their since the introduction of the feature.
Tried to see how it is handled in the code but I wasn't able to understand how work with gerrit. Going to try it later.
Comment 5 QA Administrators 2017-03-06 14:47:27 UTC Comment hidden (obsolete)
Comment 6 Christian Pietzsch 2017-03-09 01:05:54 UTC
I quickly tried in the most recent version I have right now (5.3 Dev alpha 1) and it is still unchanged.
Ubuntu 16.04 64bit
Comment 7 Dawid Motyka 2017-06-28 15:00:29 UTC
I confirm this bug in LibreOffice Version: 5.2.7.2 (installed using deb packages from LO webpage) on Linux Mint 18.2.
Comment 8 Christian Pietzsch 2017-09-01 17:19:10 UTC
Bug still exists in
Version: 5.4.0.3
Build ID: 5.4.0-2
CPU threads: 4; OS: Linux 4.12; UI render: default; VCL: gtk3; 
Locale: de-DE (de_DE.UTF-8); Calc: group
Comment 9 Sergio 2018-06-08 19:41:15 UTC
The bug is still present in LibreOffice 6.0.3.2: 
Version: 6.0.3.2
Build ID: 8f48d515416608e3a835360314dac7e47fd0b821
Comment 10 QA Administrators 2019-06-09 03:01:32 UTC Comment hidden (obsolete)
Comment 11 Christian Pietzsch 2019-06-24 12:31:06 UTC
Bug still present in 
Version: 6.2.4.2.0+
Build ID: 6.2.4-1
CPU threads: 12; OS: Linux 5.1; UI render: default; VCL: gtk2; 
Locale: de-DE (en_US.UTF-8); UI-Language: en-US
Calc: threaded
Comment 12 QA Administrators 2021-06-24 03:46:58 UTC
Dear Christian Pietzsch,

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present with the latest version of LibreOffice from https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the information from Help - About LibreOffice.
 
If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a comment that includes the information from Help - About LibreOffice.

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not 
appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so:
1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3) from https://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug
3. Leave a comment with your results.
4a. If the bug was present with 3.3 - set version to 'inherited from OOo';
4b. If the bug was not present in 3.3 - add 'regression' to keyword


Feel free to come ask questions or to say hello in our QA chat: https://kiwiirc.com/nextclient/irc.freenode.net/#libreoffice-qa

Thank you for helping us make LibreOffice even better for everyone!

Warm Regards,
QA Team

MassPing-UntouchedBug