Bug Hunting Session
Bug 93495 - UX - Increase / decrease indent buttons with heading styles from H2 downwards shift style to subsequent ordered style
Summary: UX - Increase / decrease indent buttons with heading styles from H2 downwards...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Writer-Styles-Paragraph
  Show dependency treegraph
 
Reported: 2015-08-17 22:10 UTC by Steve Beisner
Modified: 2018-10-25 18:30 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Steve Beisner 2015-08-17 22:10:33 UTC
The "increase / decrease indent" works only for non-heading styled paragraphs. If used with a heading style (whether builtin Heading1-Heading10, or user defined with "outline numbering"), the buttons instead cause a change in the style of the paragraph, e.g. applying increase-indent-button to Heading1 changes the style to Heading2!   WTF?
Comment 1 Alex Thurgood 2015-08-18 09:28:00 UTC
@Steve : could you provide us please with a minimal document with instructions how to reproduce this problem ?

Also please state OSX version and whether you are using LibreOffice from AppStore or from the TDF download page, thanks.
Comment 2 Steve Beisner 2015-08-18 11:30:59 UTC
1) open new document.
2) insert several lines/paragraphs.
3) format one of them as a heading/outline style.
4) try to use increase/decrease indent buttons.

Instead of changing the indent, the style is changed
to a different heading style.
Comment 3 Steve Beisner 2015-08-18 11:31:44 UTC
OSX 10.10.5
Libre  Office from download page.
Comment 4 Alex Thurgood 2015-08-18 13:55:41 UTC
I can reproduce this also using the Tab key to indent, however, only with Header2 style and downwards, i.e. from H2 to H10.

Version: 5.0.0.5
Build ID: 1b1a90865e348b492231e1c451437d7a15bb262b
Locale : fr-FR (fr.UTF-8)
OSX 10.10.5

Doesn't seem like normal behaviour to me.
Comment 5 Alex Thurgood 2015-08-18 13:57:23 UTC
More importantly, the indent action doesn't actually produce an indent in some cases, it just changes the Header style, i.e. tabulations are not inserted.
Comment 6 Alex Thurgood 2015-08-18 14:00:38 UTC
Already present in Version: 4.3.5.2
Build ID: 3a87456aaa6a95c63eea1c1b3201acedf0751bd5
Comment 7 Alex Thurgood 2015-08-18 14:03:25 UTC
Already present in 
Version: 4.2.4.2
Build ID: 63150712c6d317d27ce2db16eb94c2f3d7b699f8
Comment 8 Alex Thurgood 2015-08-18 14:06:27 UTC
Also in Version: 4.1.4.2
Build ID: 0a0440ccc0227ad9829de5f46be37cfb6edcf72
Comment 9 QA Administrators 2016-09-20 10:26:14 UTC Comment hidden (obsolete)
Comment 10 Steve Beisner 2016-09-21 13:37:46 UTC
Bug still present. Retested with 5.2.1.2
Comment 11 Xisco Faulí 2017-09-29 08:52:13 UTC Comment hidden (obsolete)
Comment 12 Thomas Lendo 2018-10-15 09:25:19 UTC
Behavior still there in
Version: 6.2.0.0.alpha0+ (x64)
Build ID: 425af6845ebe066c950b0b63f50563e067485f3e
CPU threads: 8; OS: Windows 10.0; UI render: GL; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-10-09_23:30:22

But I doubt this is a bug and it's an intended behavior.
Then this bug report is an enhancement request.

But adding needsUXEval to discuss that.
Comment 13 Cor Nouws 2018-10-24 16:40:21 UTC
(In reply to Steve Beisner from comment #0)
> The "increase / decrease indent" works only for non-heading styled
> paragraphs. If used with a heading style (whether builtin
> Heading1-Heading10, or user defined with "outline numbering"), the buttons
> instead cause a change in the style of the paragraph, e.g. applying
> increase-indent-button to Heading1 changes the style to Heading2!   WTF?

What WTF... behavior is as old as Methuselah :p
And using Tab for changing indent on headings is direct formatting.
Two reasons for me to not support this request. I would say WFM.
Cheers - Cor
Comment 14 Heiko Tietze 2018-10-25 09:57:32 UTC
We talked about this topic in the design meeting and came to the conclusion of WORKSFORME. The decision takes into account that we want to support the use of styles rather than direct formatting, the familiar and well-known behavior, and the fact that lists are working similarly (tab increases the level).
Comment 15 Kenneth Hanson 2018-10-25 17:35:39 UTC
I'm experimenting and having a problem much like that described by Alex Thurgood in comment #4. Sometimes the tab key changes the heading level, other times it indents the text. Furthermore, when it indents it changes the style rather than adding a tab stop or direct formatting, as well as (!) other heading styles. Even this can be inconsistent - it sometimes doesn't happen if you have modified the heading styles from their defaults. Clearly something weird is going on.

However, I don't think the difference is the heading level, but rather, the position in the document. For me, the strange behavior of the tab key does not occur for the first instance of a heading style paragraph, regardless of which it is.
Comment 16 Kenneth Hanson 2018-10-25 17:50:08 UTC
Correction to the last statement of the above. The changes to the paragraph style occur *only* when pressing the tab key at the beginning of the first instance of a heading style paragraph. For other paragraphs, the key behaves like the toolbar button.
Comment 17 Kenneth Hanson 2018-10-25 18:00:21 UTC
I've submitted a new bug, Bug 120917.