Bug 93554 - Not possible to adjust row and column sizes when rulers are hidden
Summary: Not possible to adjust row and column sizes when rulers are hidden
Status: RESOLVED DUPLICATE of bug 92145
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.0.0.5 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
: 92413 (view as bug list)
Depends on:
Blocks: RenderContext
  Show dependency treegraph
 
Reported: 2015-08-21 02:49 UTC by Yousuf Philips (jay) (retired)
Modified: 2015-12-15 11:03 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2015-08-21 02:49:09 UTC
Steps:
1) Open Writer
2) Disable rulers with Ctrl+Shift+R or View > Rulers
3) Close Writer
4) Open Writer
5) Insert a table of 3x3
6) Attempt to adjust the column widths and row heights

Regression as this works fine in 4.4. This is quite problematic because the vertical ruler is off by default in 5.0, which means row heights cant be adjusted.

Version: 5.1.0.0.alpha1+
Build ID: 5d6ef74eea5d73b8cd17f313ad87138d56dc76ce
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2015-08-18_01:28:44
Locale: en-US (en_US.UTF-8)
Comment 1 Jacques Guilleron 2015-08-21 21:41:55 UTC
Hi Yousuf,

I reproduce with:
LO 5.1.0.0.alpha1+ Build ID: 56050b75941355285911c0293a3c02fc403d0c89
TinderBox: Win-x86@39, Branch:master, Time: 2015-08-13_05:36:16 
Locale: fr-FR (fr_FR)
LO 5.0.0.0.alpha1+ Build ID: 6664859e1e8b3f8b7db8c931b8d0335510c20ce0
TinderBox: Win-x86@42, Branch:master, Time: 2015-05-16_03:16:31
Locale: es-ES (fr_FR)
Not with:
LO 4.4.5.2 Build ID: a22f674fd25a3b6f45bdebf25400ed2adff0ff99
OS: Windows 7 Home Premium
Comment 2 Yousuf Philips (jay) (retired) 2015-08-22 14:07:31 UTC
Thanks Jacques for setting keywords as regression, but you should also set bibisectRequest in the whiteboard so the regression can be tracked down. :D
Comment 3 Michael Weghorn 2015-08-22 17:16:11 UTC
(bi)bisect result (using the bibisect-50max repository):

There are only 'skip'ped commits left to test.
The first bad commit could be any of: 95b4765fed4f876b3f27dd47ed9ae19cef8ee896 ec504a266d0f1325758deb109159b384127d7ba8
We cannot bisect more!


$ git bisect log
# bad: [dda106fd616b7c0b8dc2370f6f1184501b01a49e] source-hash-0db96caf0fcce09b87621c11b584a6d81cc7df86
# good: [5b9dd620df316345477f0b6e6c9ed8ada7b6c091] source-hash-2851ce5afd0f37764cbbc2c2a9a63c7adc844311
git bisect start 'latest' 'oldest'
# good: [0c30a2c797b249d0cd804cb71554946e2276b557] source-hash-45aaec8206182c16025cbcb20651ddbdf558b95d
git bisect good 0c30a2c797b249d0cd804cb71554946e2276b557
# good: [2ce02b2ce56f12b9fcb9efbd380596975a3a5686] source-hash-17d714eef491bda2512ba8012e5b3067ca19a5be
git bisect good 2ce02b2ce56f12b9fcb9efbd380596975a3a5686
# bad: [40875247f0002056effdf6d2fbe43627691cd86c] source-hash-93f0b14458a618ad575cd446680e5c4aa7d87bdc
git bisect bad 40875247f0002056effdf6d2fbe43627691cd86c
# good: [07e62597be0600b763c4d18204799dcf09d2d3d9] source-hash-b2ead407c70f71974a1eac79df09072ff8bd0cc2
git bisect good 07e62597be0600b763c4d18204799dcf09d2d3d9
# good: [160904095d61878ae1483787bf25f4c4148365e4] source-hash-2049e3ec22db0684683261746188b40428a0d0e2
git bisect good 160904095d61878ae1483787bf25f4c4148365e4
# bad: [957b579081899413657c40feb8b41b5a43a8e55b] source-hash-74706c4057e027898022ac42de210302cdc92d99
git bisect bad 957b579081899413657c40feb8b41b5a43a8e55b
# bad: [4daa0b0b691bfc36e5924f61cc046142845c5d70] source-hash-f6d4cd396803f568ca667ed5e4d7725ade99b5df
git bisect bad 4daa0b0b691bfc36e5924f61cc046142845c5d70
# good: [27de78aa6a89c81519f7882e2201a2fc4b6c5624] source-hash-f016ed2e4f7b8bec79fcaf8e4b566861a7b6ae76
git bisect good 27de78aa6a89c81519f7882e2201a2fc4b6c5624
# bad: [636bb524479df989599ab04dd026e8c0eb018c39] source-hash-6cea2e61cf77bfe5bc53aa6002807c9b38e77499
git bisect bad 636bb524479df989599ab04dd026e8c0eb018c39
# good: [b9e0b0d57f4ab0cadb0cf0538389d5c59c3bef8d] source-hash-2932d2db599c09ecce3faa2d627e9ee4f251183a
git bisect good b9e0b0d57f4ab0cadb0cf0538389d5c59c3bef8d
# good: [2e1aae4586572e8cd47a53dff9574c245eb75b55] source-hash-d36da8c19378f4772c896ca4df94117077e823d6
git bisect good 2e1aae4586572e8cd47a53dff9574c245eb75b55
# bad: [ec504a266d0f1325758deb109159b384127d7ba8] source-hash-9905a8b953953b9ec5e123a17997d5931978acfe
git bisect bad ec504a266d0f1325758deb109159b384127d7ba8
# skip: [95b4765fed4f876b3f27dd47ed9ae19cef8ee896] source-hash-f50fd9692ed7b9632c0f8dad9508f5a207679be4
git bisect skip 95b4765fed4f876b3f27dd47ed9ae19cef8ee896
# only skipped commits left to test
# possible first bad commit: [ec504a266d0f1325758deb109159b384127d7ba8] source-hash-9905a8b953953b9ec5e123a17997d5931978acfe
# possible first bad commit: [95b4765fed4f876b3f27dd47ed9ae19cef8ee896] source-hash-f50fd9692ed7b9632c0f8dad9508f5a207679be4


When starting [95b4765fed4f876b3f27dd47ed9ae19cef8ee896] (source-hash-f50fd9692ed7b9632c0f8dad9508f5a207679be4), the Writer interface can hardly be seen, but I managed to get to the position where the column border is and was not able to move it.
In the skipped commit (95b4765fed4f876b3f27dd47ed9ae19cef8ee896), LO does not start ("ERROR 4 forking").
Comment 4 Michael Weghorn 2015-08-22 17:24:49 UTC
@Tomaž: Could you possibly have a look at this. The following two source commits are in consideration of having caused that behaviour:


commit 9905a8b953953b9ec5e123a17997d5931978acfe
Author: Tomaž Vajngerl <tomaz.vajngerl@collabora.co.uk>
Date:   Tue Apr 28 12:53:27 2015 +0900

    replace Paint calls to Invalidate + fix compilation
    
    Change-Id: Id716c47d56922ab6ce0c3adb3d426ea814980674

commit f50fd9692ed7b9632c0f8dad9508f5a207679be4
Author: Tomaž Vajngerl <tomaz.vajngerl@collabora.co.uk>
Date:   Tue Apr 28 11:00:54 2015 +0900

    mass rewrite Paint(Rect&) to Paint(RenderContext&, Rect&)
    
    Change-Id: Ia1667246064d11827dbd149def15e5bf08b119b8
Comment 5 Maxim Monastirsky 2015-08-24 17:54:27 UTC

*** This bug has been marked as a duplicate of bug 92145 ***
Comment 6 Kevin Suo 2015-09-10 04:13:29 UTC
Set this to NEW, and mark bug 92413 as a duplicate of this one.
There are two different bugs,
See my comment in https://bugs.documentfoundation.org/show_bug.cgi?id=92145#c11 for more information.
Comment 7 Kevin Suo 2015-09-10 04:13:44 UTC
*** Bug 92413 has been marked as a duplicate of this bug. ***
Comment 8 Maxim Monastirsky 2015-09-10 18:28:28 UTC
(In reply to Kevin Suo from comment #6)
> Set this to NEW, and mark bug 92413 as a duplicate of this one.
> There are two different bugs,
> See my comment in
> https://bugs.documentfoundation.org/show_bug.cgi?id=92145#c11 for more
> information.
See my follow-up comment there.

*** This bug has been marked as a duplicate of bug 92145 ***
Comment 9 Robinson Tryon (qubit) 2015-12-15 11:03:21 UTC
Migrating Whiteboard tags to Keywords: (bibisected)
[NinjaEdit]