Bug Hunting Session
Bug 93558 - Preview of Bullets is hard to see with a dark theme
Summary: Preview of Bullets is hard to see with a dark theme
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.0.0.5 release
Hardware: All Linux (All)
: lowest trivial
Assignee: Maxim Monastirsky
URL:
Whiteboard: target:5.1.0 target:5.0.2
Keywords:
Depends on:
Blocks:
 
Reported: 2015-08-21 04:10 UTC by Joel Madero
Modified: 2016-10-25 19:24 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
BulletPreview (135.99 KB, image/png)
2015-08-21 04:10 UTC, Joel Madero
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Joel Madero 2015-08-21 04:10:37 UTC
Created attachment 118058 [details]
BulletPreview

Ubuntu 15.04 x64
LibreOffice 5.0.0.5

Best I can do here is show the picture - when I do the drop down for bullets the preview for the bullet options are missing the related icons making the previous a bit useless.
Comment 1 tommy27 2015-08-21 12:53:32 UTC
I see normal bullet previews under Win8.1 x64 using LibO 5.0.0.4 and a recent 5.1.0.0 alpha daily build

maybe a Linux specific bug.
Comment 2 Adolfo Jayme 2015-08-21 21:54:48 UTC
Joel, most likely you are missing the OpenSymbol font. Can you confirm?
Comment 3 Adolfo Jayme 2015-08-21 21:55:41 UTC
Although, when the font is missing, usually blank squares are displayed. Maybe your GTK+ theme is playing a role here as well?
Comment 4 Joel Madero 2015-08-21 22:04:16 UTC
OpenSymbol is installed. As for themes - just using default "Ambiance" theme.
Comment 5 Yousuf Philips (jay) (retired) 2015-08-24 21:31:33 UTC
CCing Maxim as he'd likely know what questions to ask.

Joel: What desktop environment and theme are you using?
Comment 6 Joel Madero 2015-08-24 21:36:12 UTC
Unity with Ambience theme (I think...that's what Ubuntu tweak tells me at least....)
Comment 7 Joel Madero 2015-08-24 21:45:40 UTC
I just set up a test user (so all theming would be default) and it works as expected...should I close this as NOTABUG? Or at least NOTOURBUG?
Comment 8 Maxim Monastirsky 2015-08-24 22:42:22 UTC
We use the default text color that's reported by GTK to draw those items, and it seems that for some dark themes it's white or light gray. I guess we should just ignore the GTK theme in this case, and always use black text on white background. Jay - what do you think?
Comment 9 Joel Madero 2015-08-24 22:51:33 UTC
@Maxim - wow, thoroughly impressed that you figured this out as it's been giving me issues :) Thanks for the insightful feedback - I'd love to have useful icons even in my dark theme.

It seems like dark themes cause a few UI related issues - see e.g., bug #90214
Comment 10 Yousuf Philips (jay) (retired) 2015-08-25 01:39:54 UTC
(In reply to Maxim Monastirsky from comment #8)
> Jay - what do you think?

If the background is always white, then definitely the text should always be black.
Comment 11 Maxim Monastirsky 2015-08-25 14:01:42 UTC
(In reply to Yousuf (Jay) Philips from comment #10)
> If the background is always white
Right now it's inconsistent. The toolbar dropdowns as well as all the tabs in the dialog except "Outline", are always white. But the "Outline" tab takes the background of the OS theme (so with a dark theme it has a black background with white text).

On the one hand, it makes sense to use white background, because those items are kind of a "preview" of a page, and the default page color is white. But on the other hand, I looked in other dialogs (like Character, Paragraph, Columns), and they all take the background of the OS theme. So I think, we should take a decision here, and enforce it across all dropdowns/dialogs.
Comment 12 Yousuf Philips (jay) (retired) 2015-08-25 19:12:01 UTC
(In reply to Maxim Monastirsky from comment #11)
> Right now it's inconsistent. The toolbar dropdowns as well as all the tabs
> in the dialog except "Outline", are always white. But the "Outline" tab
> takes the background of the OS theme (so with a dark theme it has a black
> background with white text).
> 
> On the one hand, it makes sense to use white background, because those items
> are kind of a "preview" of a page, and the default page color is white. But
> on the other hand, I looked in other dialogs (like Character, Paragraph,
> Columns), and they all take the background of the OS theme. So I think, we
> should take a decision here, and enforce it across all dropdowns/dialogs.

IMHO, it should always be black text on white background when its a preview, its fine for dialogs to be themed by the OS theme, but not previews. This would just reduce theming issues where there shouldnt be. (e.g. bug 86472)
Comment 13 Commit Notification 2015-08-27 18:21:53 UTC
Maxim Monastirsky committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=fa1807ad5457d10f8fa073c209a27547e8922c8c

tdf#93558 Hardcode black text on white background

It will be available in 5.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 14 Maxim Monastirsky 2015-08-27 18:43:24 UTC
Backport to 5-0: https://gerrit.libreoffice.org/18068/
Comment 15 Joel Madero 2015-08-27 19:23:01 UTC
Confirmed. Thanks Maxim.
Comment 16 Commit Notification 2015-08-28 09:15:45 UTC
Maxim Monastirsky committed a patch related to this issue.
It has been pushed to "libreoffice-5-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=4a305d029116793f1e73019fa1242ded5f5236f2&h=libreoffice-5-0

tdf#93558 Hardcode black text on white background

It will be available in 5.0.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 17 Luke 2015-08-29 18:17:41 UTC
I tried to verify that this was fixed, but there's no steps to reproduce. How do you force daily builds to use your desktops theme?
Comment 18 Maxim Monastirsky 2015-08-29 20:40:07 UTC
(In reply to Luke from comment #17)
> How do you force daily builds to use your desktops theme?
You don't need to force anything. If your DE is properly detected, and the build has the plugin for your DE, that's enough.