Bug 93589 - add option similar to PowerPoint Picture Presentation to Impress
Summary: add option similar to PowerPoint Picture Presentation to Impress
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks:
 
Reported: 2015-08-22 07:18 UTC by Roeland
Modified: 2021-08-30 19:18 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Roeland 2015-08-22 07:18:44 UTC
In PowerPoint there's an option to save as "PowerPoint Picture Presentation". Saving your PowerPoint with this option creates a new presentation, wherein all slides have been transformed to pictures.

The presentation contains all the slides and has the pptx extension (note the difference with exporting your presentation as images!).

This is a really usefull feature in interoperability cases, because it's a nice way to keep your presentation as is, without any formating issues if you port it to another computer.

If there would be something similar in libreoffice, this would really be helpfull.
Comment 1 tommy27 2015-08-22 12:46:32 UTC
nice idea. status NEW.
Comment 2 Gerry 2015-08-24 15:46:47 UTC
@Roeland: Thanks for the idea. Is there any advantage compared to the export of a presentation to PDF and present it in the PDF Reader?
Comment 3 Roeland 2015-08-24 16:29:09 UTC
Hi Gerry,

There are several advantages:

It is easier to show a presentation in the Impress/PowerPoint module if you're required to do it for an audience. Using the PDF viewer is not always useable in this situation. 

Sometimes people are required to hand in a presentation at school, to a customer/ client in the ppt(x) format. Sending a Picture Presentation is a really good way to keep all the formatting/text as intended. 

One thing that is lacking in PowerPoint is a warning that you lose all your formatting if you save as Picture Presentation (and by doing that overwriting your original file). Maybe if this option is added, the default behavior should be to create a new file.
Comment 4 Roeland 2015-08-24 18:24:24 UTC
My suggestion would also be to offer a choice to either save as an odp or pptx Picture Presentation every time when the choice is made to save as Picture Presentation.
Comment 5 V Stuart Foote 2021-07-05 17:05:24 UTC
So would this be export only filter, or is there some expectations of a .pptx import filter? None of this is ODF compliant.

And for that, export of Impress presentataion to PDF as a cross platform solution seems sufficient. While currently entire presentations (or selected subset of slides) can be exported to a series of SVG in SMIL 2.0 multi slide stream (bug 117708 to improve awareness). Exactly the "feature" of the MS proprietary PowerPoint Picture Presentation.

Certainly not in core--but maybe the PPTX picture show filter work could go in an extension.
Comment 6 Heiko Tietze 2021-07-07 07:26:37 UTC
Sounds to me like using proprietary solutions at the maximum.

(In reply to Roeland from comment #3)
> It is easier to show a presentation in the Impress/PowerPoint module if
> you're required to do it for an audience. Using the PDF viewer is not always
> useable in this situation. 

Hard to believe, and LibreOffice can open PDF anyway.

> Sometimes people are required to hand in a presentation at school, to a
> customer/ client in the ppt(x) format. Sending a Picture Presentation is a
> really good way to keep all the formatting/text as intended. 

It's not an argument against PDF (or SVG).



Putting all together I also think it doesn't fit into our feature set. Of course, nothing to say against an extension.
Comment 7 Roeland 2021-07-25 18:15:37 UTC
(In reply to Heiko Tietze from comment #6)

> Hard to believe, and LibreOffice can open PDF anyway.
True, PDF can do a lot of work in case of presentations.


> It's not an argument against PDF (or SVG).

It is, as some schools do have strict requirements about the type of extensions pupils  should use. Submitting as pdf is not an option in this scenario. A pptx picture presentation solves this. This is the main problem that is addressed here.
Comment 8 V Stuart Foote 2021-07-25 20:11:50 UTC
LibreOffice can currently exports all selected slides to SVG (as in see also bug 117708) or exports to PDF, rendering a presentation unmodifieable.

So this feature already exists

LO has no obligation to support non-standards based proprietary MS formats. Writing filter for such formats belongs in extension.

IMHO doing more for MS PowerPoint Picture Presentation remains a clear => WF
Comment 9 Roeland 2021-07-26 13:18:13 UTC
(In reply to V Stuart Foote from comment #8)
> LibreOffice can currently exports all selected slides to SVG (as in see also
> bug 117708) or exports to PDF, rendering a presentation unmodifieable.
> 
> So this feature already exists
> 
> LO has no obligation to support non-standards based proprietary MS formats.
> Writing filter for such formats belongs in extension.
> 
> IMHO doing more for MS PowerPoint Picture Presentation remains a clear => WF

I think you misunderstand what I mean, it doesn't really add a new format (picture presentation just being a denomation of what you get, not a format), this has nothing to do with complying with MS. You just get a presentation where your slides have been transformed to images, if you're working with odp then you get a odp picture presentation, if you're working with pptx then you get a pptx picture presentation.  This helps the user if he/she/x is required to submit a presentation in a propretairy format (Impress is fine but will never deliver a perfect interchangable result, by doing this we circumvent this.)

Anyway, if there's an easy way to get a svg slideshow and convert (import?) this slideshow to (for example) a PPTX or ODP in a usable flow, then this could do the trick as well.
Comment 10 V Stuart Foote 2021-07-26 14:01:52 UTC
(In reply to Roeland from comment #9)

And that is exactly what we will not do--we will not support MS proprietary format of PPTX Picture Presentation.

Impress already exports to standards compliant and opensource SMIL2.0 SVG slideshow.
 
> Anyway, if there's an easy way to get a svg slideshow and convert (import?)
> this slideshow to (for example) a PPTX or ODP in a usable flow, then this
> could do the trick as well.

As noted, neither MS's proprietary Picture Presenation format, nor the SVG produced by LibreOffice are intended to be editable--only viewed. No different than PDF they are not an editable "exchange" format.

The SVG export of presentation slide shows is already provided and => WFM

Providing another external (non-ODF) format for the PPTX derived image presentation is a clear WONTFIX.
Comment 11 Roeland 2021-08-01 18:59:35 UTC
So the SCVG is easily convertible to pptx or odp then? Because this is what this report is about.

Again, this is not a (proprietary) format, just a way of exporting your presentation..
Comment 12 V Stuart Foote 2021-08-01 20:54:13 UTC
(In reply to Roeland from comment #11)
> So the SCVG is easily convertible to pptx or odp then? Because this is what
> this report is about.
> 

No. Multi image SMIL 2.0 SVG is not "easily convertable" to pptx or odp. Think of it more like an uneditable PDF. Delivery of a final viewing only format.

> Again, this is not a (proprietary) format, just a way of exporting your
> presentation..

Sorry, MS pptx "Picture Presentation" is a proprietary format and is not intended to be edited--just viewed.

The LibreOffice supported SMIL 2.0 SVG slide show is the closest you will get from an ODF Presentation. It will open and display cleanly in a web browser.
Comment 13 Roeland 2021-08-30 19:18:52 UTC
(In reply to V Stuart Foote from comment #12)


> Sorry, MS pptx "Picture Presentation" is a proprietary format and is not
> intended to be edited--just viewed.

It is indeed ment not to be edited, which is also the goal of this enhancement request?


So in the end, this request gets closed, without any real alternative when someone wants to have his/her slideshow converted to an uneditable slideshow within the same format? A pity.