Bug 93613 - References to external files with macros in formulas won't update properly
Summary: References to external files with macros in formulas won't update properly
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.4.0.3 release
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Eike Rathke
URL:
Whiteboard: target:5.1.0 target:5.0.3 target:4.4.6
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2015-08-24 07:01 UTC by Karsten Müller
Modified: 2016-10-25 19:19 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Files for testing (53.88 KB, application/zip)
2015-08-24 19:20 UTC, Karsten Müller
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Karsten Müller 2015-08-24 07:01:55 UTC
User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:39.0) Gecko/20100101 Firefox/39.0
Build Identifier: LibreOffice 5.0.0.5

I have a ods-file with links to some external ods-files. The links look like ='file:///D:/projekte/XXX/XXXX___4X.ods'#$Deckblatt.B3. If the cell Deckblatt.B3 in file XXXX___4X.ods contains a number or a text, the update is o.k. If the cell Deckblatt.B3 in file XXXX___4X.ods contains a formula or e reference to onother cell, the update won't work, I get the content #WERT!. Under Linux (LO Rel. 4.3..) all works fine.

Reproducible: Always

Steps to Reproduce:
see Details above
Actual Results:  
#WERT!

Expected Results:  
The Value of the cell

[Information automatically included from LibreOffice]
Locale: de
Module: SpreadsheetDocument
[Information guessed from browser]
OS: Windows (All)
OS is 64bit: yes


Reset User Profile?No
Comment 1 raal 2015-08-24 09:33:36 UTC
Hello Karsten,

Thank you for filing the bug. Please send us a sample document, as this makes it easier for us to verify the bug.
Comment 2 Karsten Müller 2015-08-24 19:20:00 UTC
Created attachment 118129 [details]
Files for testing

Hi,

now it becomes a little strange.
If I do all the procedure from scratch with empty sheets (File -> New -> Sheet), it works fine under LO>=4.4. If I use my template (base of kalk1 and kalk2), the following happens:

Making the links to "kalk1" and "kalk2" in file "summary" works 1 times. After saving, closing LO and reopen the file the error occurs. Opening the same file in LO 4.3, all is o.k. (on Linux and Windows also).

Hope this helps

Best regards
K. Müller
Comment 3 Buovjaga 2015-09-12 15:27:58 UTC
Tested attachment 118129 [details]. Link update on open works ok in 4.3.0.1, but not in 5.0.1.

Win 7 Pro 64-bit, Version: 5.0.1.2 (32-bit)
Build ID: 81898c9f5c0d43f3473ba111d7b351050be20261
Locale: fi-FI (fi_FI)
Comment 4 Buovjaga 2015-09-12 16:39:57 UTC
Confirmed bug on Linux, so added bibisect request.

Manjaro Linux KDE Plasma 5, 64-bit
Version: 5.0.1.2.0+
Build ID: 5.0.1.2 Arch Linux build-1
Locale: fi-FI (fi_FI.UTF-8)
Comment 5 raal 2015-09-24 07:58:01 UTC
Eike, please could you look at this? Thank you

bibisect-win32-5.0:
9dcae5d710665b5bca8a7a13091a00910e51523f is the first bad commit
commit 9dcae5d710665b5bca8a7a13091a00910e51523f
Author: Norbert Thiebaud <nthiebaud@gmail.com>
Date:   Thu May 14 18:04:39 2015 -0500

    source sha:573f5dfba805b733dd2da62bde3cd5d9d25879d9

    source sha:573f5dfba805b733dd2da62bde3cd5d9d25879d9

:040000 040000 04c78aa226117fdb2c4d5c68bd5036b5efa405c7 dc25624aff35869d03907f606bba35b997dfba5a M      instdir

author	Eike Rathke <erack@redhat.com>	2014-12-18 12:26:48 (GMT)
committer	Eike Rathke <erack@redhat.com>	2014-12-18 12:33:48 (GMT)
commit	573f5dfba805b733dd2da62bde3cd5d9d25879d9 (patch)
Resolves: fdo#86978 append formula cells to track instead of tree


 git bisect log
# bad: [575cd25f0560684895018d8fcfb1818dd4dd1c9b] source sha:ab465b90f6c6da5595393a0ba73f33a1e71a2b65
# good: [f449493ae11ac76cc7396bddeaa624a60c565936] source sha:57d6b92b69a31260dea0d84fcd1fc5866ada7adb
git bisect start 'libreoffice-5-0-branch-point' 'oldest'
# bad: [da12357c491a0dce5acc0bd1f00c26f89d8f20e6] source sha:c1b9402d49a7cd4bec383f28d397d9d89541f0e0
git bisect bad da12357c491a0dce5acc0bd1f00c26f89d8f20e6
# bad: [74d1ce30418f1228c11e865e8b6094f15293a528] source sha:9763b55eb946cf425220d26dab91bf220890b180
git bisect bad 74d1ce30418f1228c11e865e8b6094f15293a528
# good: [801e6841079affa45389e59799681460ddabda17] source sha:d13501f194b3a8095e283e0a3d65d1db02e70dad
git bisect good 801e6841079affa45389e59799681460ddabda17
# bad: [9aeba7898c868d083e440ab310a686a3ee541033] source sha:dc08157dff6d997b4e5b19c9496ddf54727ba26f
git bisect bad 9aeba7898c868d083e440ab310a686a3ee541033
# good: [121b74b7cd58e133c226ea4149328003b150b521] source sha:3c363adcbae442d1e56409be466f4c514b89d89a
git bisect good 121b74b7cd58e133c226ea4149328003b150b521
# good: [072674beca1b2ece8ba01805890701ad7d14a532] source sha:270fdd6b788974fa5d8e1ce01cc5358a0824fb99
git bisect good 072674beca1b2ece8ba01805890701ad7d14a532
# good: [0f14b1f6613679afc3a88749da187ddba64ab5ea] source sha:146bd125a01742b2a6561a4a23735f37867d8221
git bisect good 0f14b1f6613679afc3a88749da187ddba64ab5ea
# bad: [923b94784e01067f36a55127733a2ad98a92e567] source sha:a5bdf3c606b562a2af3dd4e4162b734abb1cb24c
git bisect bad 923b94784e01067f36a55127733a2ad98a92e567
# bad: [3a9a90b4f8d624e421f1f0098281d92e9b86de04] source sha:ff926b84508e500fd8b1deda0a7304f0026f6c8c
git bisect bad 3a9a90b4f8d624e421f1f0098281d92e9b86de04
# good: [c98b6e542f6a485a22634f19f8b0e215d786bd40] source sha:18621545e4b33039091283c58e340021199fefbf
git bisect good c98b6e542f6a485a22634f19f8b0e215d786bd40
# good: [c4ca622ca7c3321c5ba191bc160fb84b73f7c14b] source sha:180f0791daa3d3f959f4f70b9f83012bcbf47a64
git bisect good c4ca622ca7c3321c5ba191bc160fb84b73f7c14b
# good: [f44c2f1865f4d7e18361ad27e9444032a4433cd1] source sha:87561f10ba76de6d5453ed906ce24a052df72f18
git bisect good f44c2f1865f4d7e18361ad27e9444032a4433cd1
# bad: [9dcae5d710665b5bca8a7a13091a00910e51523f] source sha:573f5dfba805b733dd2da62bde3cd5d9d25879d9
git bisect bad 9dcae5d710665b5bca8a7a13091a00910e51523f
# first bad commit: [9dcae5d710665b5bca8a7a13091a00910e51523f] source sha:573f5dfba805b733dd2da62bde3cd5d9d25879d9
Comment 6 Eike Rathke 2015-10-09 06:15:36 UTC
This is due to macros not being executed in the referenced document if that is opened by referencing it.
Comment 7 Commit Notification 2015-10-09 07:55:45 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=8e2acdbcbd3afc1777d6e68a83ebbe6d8dd77645

Resolves: tdf#93613 let referenced document evaluate macro config

It will be available in 5.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Commit Notification 2015-10-09 10:17:14 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "libreoffice-5-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=2e566ad837d736c7f465c216916d9b8a6fc695bf&h=libreoffice-5-0

Resolves: tdf#93613 let referenced document evaluate macro config

It will be available in 5.0.4.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Commit Notification 2015-10-09 10:18:46 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "libreoffice-4-4":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=6fb4312af9968631eac0c05129a0e255fc411ad4&h=libreoffice-4-4

Resolves: tdf#93613 let referenced document evaluate macro config

It will be available in 4.4.7.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Commit Notification 2015-10-12 13:01:11 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "libreoffice-5-0-3":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=02515385af34613746d5e43893c4c032bbdd6d6f&h=libreoffice-5-0-3

Resolves: tdf#93613 let referenced document evaluate macro config

It will be available in 5.0.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Commit Notification 2015-10-14 18:42:35 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "libreoffice-4-4-6":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=1f3917feab8fb2630443a580c67fb9a7835098b9&h=libreoffice-4-4-6

Resolves: tdf#93613 let referenced document evaluate macro config

It will be available in 4.4.6.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 13 Robinson Tryon (qubit) 2015-12-17 10:31:36 UTC Comment hidden (obsolete)