Download it now!
Bug 93621 - FILEOPEN: DOCX: incorrect position of inner table
Summary: FILEOPEN: DOCX: incorrect position of inner table
Status: RESOLVED DUPLICATE of bug 79329
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.3.0.4 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, filter:docx
Depends on:
Blocks: DOCX-Tables
  Show dependency treegraph
 
Reported: 2015-08-24 14:03 UTC by Xisco Faulí
Modified: 2019-10-07 10:30 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Comparison between Libreoffice 5.0.0.5 (left) and Word 2010 (right) (75.25 KB, image/jpeg)
2015-08-24 14:03 UTC, Xisco Faulí
Details
How it looks in LibreOffice 6.4 master (7.73 KB, image/png)
2019-10-07 07:59 UTC, Xisco Faulí
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2015-08-24 14:03:11 UTC
Created attachment 118118 [details]
Comparison between Libreoffice 5.0.0.5 (left) and Word 2010 (right)

Steps:
1. Open attachment 100289 [details]
2. Observe

Expected behavior: The document contains 1 table inside another table

Issue reproduced with

Version: 5.0.0.5
Build ID: 1b1a90865e348b492231e1c451437d7a15bb262b
Locale: es-ES (es_ES)

on Windows 7 (64-bit)
Comment 1 Joel Madero 2015-08-24 15:37:37 UTC
Confirmed:

Ubuntu 15.04 x64
LibreOffice 4.4.5.2 (updating version to reflect older version)

Setting as:
NEW
Normal - can prevent high quality work;
Medium - default.

@Xisco - would be nice to find out if this is a regression or not by testing older versions: http://downloadarchive.documentfoundation.org/libreoffice/old/
Comment 2 tommy27 2015-08-24 15:37:57 UTC
I confirm bug under Win8.1x64 using LibO 4.4.5.1 and a recent 5.1.0.0 alpha daily build.

the problem is also present in older releases too, at least in 4.3.0.4 (did not test earlier ones).
Comment 3 Xisco Faulí 2016-08-10 17:48:39 UTC
This issue is still reproducible with

Version: 5.3.0.0.alpha0+
Build ID: 31186a1c7112690735f6d14dcc7fd0c8b033e1d7
CPU Threads: 4; OS Version: Linux 4.2; UI Render: default; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group
Comment 4 QA Administrators 2018-01-24 03:24:35 UTC Comment hidden (obsolete)
Comment 5 Xisco Faulí 2019-10-07 07:51:31 UTC
in

Version: 6.4.0.0.alpha0+
Build ID: 52cda5c5ae426761ccbdb4f20419098eab195303
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

it contains 2 tables, however the inner table's position is incorrect...
Comment 6 Xisco Faulí 2019-10-07 07:59:07 UTC
The missing outer table got fixed in https://cgit.freedesktop.org/libreoffice/core/commit/?id=c1eebcdac9f2b289fd363399130c485ca5ff444c
Comment 7 Xisco Faulí 2019-10-07 07:59:45 UTC
Created attachment 154791 [details]
How it looks in LibreOffice 6.4 master
Comment 8 Xisco Faulí 2019-10-07 08:01:05 UTC
@Miklos, since you fixed the original problem, I thought you might be interested in this issue...
Comment 9 Xisco Faulí 2019-10-07 10:30:11 UTC
Actually, this issue got fixed by https://cgit.freedesktop.org/libreoffice/core/commit/?id=c1eebcdac9f2b289fd363399130c485ca5ff444c
The missing arrow problem in master is another issue introduced by https://cgit.freedesktop.org/libreoffice/core/commit/?id=52bbb04f1e39b2d778275c91f77b6c0714ecd0d0 and already reported in 121649
Closing as duplicated of bug 79329, since the original issue is fixed by the same commit

*** This bug has been marked as a duplicate of bug 79329 ***