Bug Hunting Session
Bug 93649 - FILESAVE: table of content links does not jumps to the proper document part in a Writer document saved as HTML
Summary: FILESAVE: table of content links does not jumps to the proper document part i...
Status: RESOLVED DUPLICATE of bug 93449
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4.5.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-08-25 09:00 UTC by Attila Hammer
Modified: 2015-08-25 15:08 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
The original Libreoffice Writer document with containing table of content (9.54 KB, application/vnd.oasis.opendocument.text)
2015-08-25 09:00 UTC, Attila Hammer
Details
This is the Libreoffice Writer generated HTML file from the previous attached Libreoffice .odt format document (1.67 KB, text/html)
2015-08-25 09:02 UTC, Attila Hammer
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Attila Hammer 2015-08-25 09:00:51 UTC
Created attachment 118166 [details]
The original Libreoffice Writer document with containing table of content

Dear Developers,

If a Libreoffice Writer document containing Table of content and the document saved with HTML file format the File menu Save or Save As dialogs, the generated HTML file added Table of Content links not jumps the proper document part.
I will attaching a test document (.odt format document) and a generated HTML file.
An example table of content link:

First version with I tested this issue:
LibreOffice 4.4.5.2 40m0(Build:2)

Libreoffice 5.0 version producing this issue too.
Testcase:
1. Create a document with containing some heading level 1 style formatted lines and few normal paragraphs.
2. Click Insert menu, and insert index or table dialog.
3. Insert a standard table of content.
4. Save the document with HTML file with file save or save as dialogs.
Expected result:
The HTML file in Table of content part need containing proper document links with jumps the proper section into the HTML document.
Actual result:
the HTML file containing following style links with all table of content elements:
	<p style="margin-bottom: 0in; line-height: 100%"><a href="">Test
	section	2</a></p>
So, the href tag is empty in the HTML file the table of content part.

Attila
Comment 1 Attila Hammer 2015-08-25 09:02:14 UTC
Created attachment 118167 [details]
This is the Libreoffice Writer generated HTML file from the previous attached Libreoffice .odt format document
Comment 2 tommy27 2015-08-25 13:23:19 UTC
edited a very long summary to make it shorter and easier to understand
Comment 3 Vasily Melenchuk (CIB) 2015-08-25 15:08:55 UTC
Reason is the same as in #93449: internal hyperlinks for bookmarks are empty.
Fix created for that bug also eliminates this problem.

*** This bug has been marked as a duplicate of bug 93449 ***