Bug Hunting Session
Bug 93659 - Decrement/increment font sizes of bullet lists relative to sub-level font size
Summary: Decrement/increment font sizes of bullet lists relative to sub-level font size
Status: RESOLVED DUPLICATE of bug 91001
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
4.4.2.2 release
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-08-25 15:23 UTC by Gerry
Modified: 2015-08-25 20:24 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Gerry 2015-08-25 15:23:17 UTC
There is currently no easy way to decrement/increment the font sizes of bullet lists with sub-levels. 

The sub-levels in Impress have different font sizes for each of the sub-levels. If you mark the entire bullet list and click the icon "increment font size" (or decrement font size), the expected behavior is that all font sizes increase/decrease relatively to the current font size of the specific sub-level.

However, in Impress decreasing/increasing the font size first standardizes all font sizes of the sub-levels and then increases/decreases the font size. The result is that all levels have the same font size. Generally, this is not the wished behavior.

Competitive comparison: Powerpoint increases/decreases the font size relatively to the sub-level, so that the relative difference of the font sizes remains the same.
Comment 1 Todd 2015-08-25 16:42:08 UTC
Note: The same misbehavior is experienced when using the increment/decrement font icon with the intention of incrementing or decrementing any block of selected text.

Expected behavior:
* Select text of variety of font sizes
* Click inc/dec font size icon
* Selected text changes font size appropriately and proportional to the size of each character.

Instead, all characters are normalized to one font size... and then incremented or decremented.
Comment 2 Maxim Monastirsky 2015-08-25 16:57:11 UTC

*** This bug has been marked as a duplicate of bug 91001 ***
Comment 3 Gerry 2015-08-25 20:24:57 UTC
@Maxim: Thanks a lot for working on this issue! Thanks for fixing it.

@Todd: Can you test the issue in either 5.1.0, 5.0.0.1 or 4.4.5 whether it works as expected? Thanks! (I don't have a new version on this computer)