Bug 93669 - Problem with printing multi-sided documents via Fax-Printer
Summary: Problem with printing multi-sided documents via Fax-Printer
Status: CLOSED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.0.0.5 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL: https://mkafee-activate.com
Whiteboard:
Keywords: bibisectNotNeeded
Depends on:
Blocks: Print
  Show dependency treegraph
 
Reported: 2015-08-25 23:16 UTC by Michael
Modified: 2022-04-07 15:41 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Tiff file generated by Fax printer. (1.67 KB, image/tiff)
2015-08-26 00:03 UTC, m.a.riosv
Details
Tiff file generated by Fax printer (Win7pro) (1.24 KB, image/tif)
2015-08-26 07:26 UTC, Michael
Details
Tiff file generated by Fax printer (Win7pro 64bit, LibreOffice v6.0.3.2) (1.27 KB, image/tiff)
2018-05-07 10:20 UTC, Michael
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michael 2015-08-25 23:16:21 UTC
If a writer document has more than one side it is not possible to print it via a Fax-Printer. If it is single-sided it works. I'm using the "Microsoft Shared Fax Driver" on a PC with Windows 7 Professional (64bit). I tested it with LibreOffice v4.2.4.2 and v5.0.0.5.

A simple Writer Document which consists of 2 words on two pages (e.g. "hello <manual FormFeed> world") produces a corrupt fax-preview (tiff).

My steps to install the local faxprinter on Windows 7: open the "control panel" -> select "Programs and Features" -> "Turn Windows Features On or Off" -> expand "Print and Document Services" -> set the check mark by "Windows Fax and Scan" -> reboot


The same strange behaviour I had with OpenOffice v4.1.1 - it was possibly patched in OO (see https://bz.apache.org/ooo/show_bug.cgi?id=122984 - Title: "Faxes longer than one side wont' work (I guess wrong TIFF is created)"). Maybe it could be fixed.

Greetings
Michael
Comment 1 m.a.riosv 2015-08-26 00:03:01 UTC
Created attachment 118182 [details]
Tiff file generated by Fax printer.

Hi Michael, thanks for reporting.

Works for me with fax in Win10x64, updated from Win7.
Version: 5.0.1.2 (x64)Build ID: 81898c9f5c0d43f3473ba111d7b351050be20261

Attached the tiff file created by Fax printer.

Have you the issue, from other apps?, e.g. exporting to a pdf file and print to Fax printer from pdf viewer.
Comment 2 Michael 2015-08-26 07:26:50 UTC
Created attachment 118186 [details]
Tiff file generated by Fax printer (Win7pro)
Comment 3 Michael 2015-08-26 07:38:41 UTC
There's no fax-printing problem when I export my two-sided helloworld.odt to a PDF-File. It works also for a multi-sided wordpad- or notepad-document. My Win7 is up-to-date (registered for Win10 but not upgraded yet).

In the Issue 122984 of Apache OpenOffice Bugzilla (see my previous link) the same procedure was discussed. Please read the last comments of  "Armin Le Grand". He wrote that a PrintJob for every single page caused this behaviour. Maybe it's a PrintJob-Problem with the MS Shared Fax Driver on Windows 7, but I seems to be fixable. The OpenOffice Target Milestone was 4.2.0, but it was never released.

Attached the corrupted tiff file created by MS Fax printer - see Comment 2.

Thanks.
Comment 4 m.a.riosv 2015-08-29 13:50:59 UTC
As I can't reproduce, changed the status to unconfirmed, so let's someone else testing it.
Comment 5 raal 2016-03-19 19:32:43 UTC
Armin, maybe your patch from https://bz.apache.org/ooo/show_bug.cgi?id=122984 can be integrated into LO? Thanks
Comment 6 Armin Le Grand 2016-04-01 08:10:57 UTC
@raal: Taking a look...
Comment 7 Armin Le Grand 2016-04-01 08:30:07 UTC
With bugdoc from comment 1 and opened in Office I get a Draw, that prints just one page. With IrfanView I see that the TIFF has two pages, 2nd one with load error.

With bugdoc from comment 2 I get an immediate 'format error' in Office and IrfanView.

How exactly to reproduce the error?
Please add a step-by-step description.
Comment 8 Michael 2016-04-14 08:52:16 UTC
Hello,

here my current system configuration:
- OS: Windows 7 Professional 64 bit, german (with latest updates, but not yet upgraded to Win10prof)
- LibreOffice: Version: 5.1.1.3, Build-ID: 89f508ef3ecebd2cfb8e1def0f0ba9a803b88a6d, CPU-Threats: 2; BS-Version: Windows 6.1; UI-Render: Standard; , Gebietsschema: de-DE (de_DE)

1. For installing the faxprinter for Win7 please see my first post (<https://bugs.documentfoundation.org/show_bug.cgi?id=93669#c0>)
2. start LibreOffice after system reboot
3. create an empty Writer document
4. create at least 2 pages ... e.g. write "hello" on the first page  (+form-feed) and  "world" on the second page
5. open the print dialog and select the printer "Fax" ("Microsoft Shared Fax Driver", "SHRFAX:")
6. use default printer options and properties (paper format: A4  / quality: normal (200x200 DPI) / orientation: portrait)
7. press OK and 2 pages will be printed (a small "print-info"-window is shortly displayed)
8. a fax dialog appears with an attached (and corrupted!) TIFF file like '1D1962108342F.tif' (also placed in users %TEMP%-directory)

... single-sided documents = okay / multi-sided documents = corrupt

By the way - there are no problems with TIFF-preview under WinXP professional.

Greetings
Michael
Comment 9 Armin Le Grand 2016-04-18 09:01:14 UTC
Hi Michael, I'll take a look...
Comment 10 Armin Le Grand 2016-04-18 09:55:40 UTC
Michael, took a 2nd look. The patch mentioned in description (orig from me) is already integrated in LO code, so this will not make it better. With the other findings I would say that the MS fax printer driver just produces invalid formats, nothing we could do anything against. Sorry, but not our bug.
Comment 11 Michael 2016-04-18 10:39:58 UTC
But ohter applications such as Adobe Acrobat Reader, WordPad, Notepad++ support the printing of such documents via MS fax printer. I mentioned that I use exported PDFs as workaround for faxing multisided documents. 
Does Open-/LibreOffice print in a different way?

Michael
Comment 12 Armin Le Grand 2016-04-20 13:00:46 UTC
That is a valid point. This means that with the mentioned other apps, you can create valid TIFFs using the MS service? Please confirm this, have not seen this important point anywhere above.
Comment 13 Michael 2016-04-21 06:48:06 UTC
Yes, I can confirm it. I have successfully printed multisided TIFF previews via  MS fax printer with WordPad, Notepad, FireFox, PDF-Viewer (Acrobat Reader and PDF-Xchanger Viewer) and NotePad++  (all under Windows 7 Professional 64bit).
Comment 14 QA Administrators 2016-11-08 12:28:20 UTC Comment hidden (obsolete)
Comment 15 Michael 2016-11-11 14:38:57 UTC
Hello, 

the problem with the MS Shared Fax Driver is still present.
Under Windows 7 Professional 64 bit, german (with latest updates) it is not possible to print/create multisided Fax-TIFFs (LibreOffice v5.2.3.3). The result is always a corrupt TIFF preview.
However, multi-page documents can easily be "faxed" with other applications such as Adobe Acrobat Reader or Wordpad.

Greetings
Michael
Comment 16 subha 2018-03-30 10:24:48 UTC
Working Fine with LibreOffice 6.0.2,cannot able to Reproduce this issues... Kindly check
Comment 17 Xisco Faulí 2018-05-02 09:35:12 UTC Comment hidden (obsolete)
Comment 18 Michael 2018-05-07 10:20:55 UTC
Created attachment 141950 [details]
Tiff file generated by Fax printer (Win7pro 64bit, LibreOffice v6.0.3.2)

Tested today - but still the same result (LibreOffice v6.0.3.2 / Windows 7 Professional 64 bit, german, with latest updates).

Greetings
Michael
Comment 19 James Joe 2018-08-07 07:38:40 UTC Comment hidden (spam)
Comment 20 Adam Jems 2018-09-12 12:41:20 UTC Comment hidden (spam)
Comment 21 jonnyjain 2018-09-27 06:08:05 UTC Comment hidden (spam)
Comment 22 davidk001 2018-10-30 06:34:41 UTC Comment hidden (spam)
Comment 23 jaydenrobin 2018-10-30 21:53:17 UTC Comment hidden (spam)
Comment 24 Xisco Faulí 2018-12-05 11:45:06 UTC
Hello Michael,
A new major release of LibreOffice is available since this bug was reported.
Could you please try to reproduce it with the latest version of LibreOffice
from https://www.libreoffice.org/download/libreoffice-fresh/ ?
I have set the bug's status to 'NEEDINFO'. Please change it back to
'UNCONFIRMED' if the bug is still present in the latest version.
Comment 25 Michael 2019-02-06 11:26:59 UTC
No changes. Still the same problem - the TIF-File won't opening (Windows 7 Professional 64 bit, german, with latest updates).

LibreOffice (portable) Version: 6.1.4.2
Build-ID: 9d0f32d1f0b509096fd65e0d4bec26ddd1938fd3
CPU-Threads: 2; BS: Windows 6.1; UI-Render: Standard; 
Gebietsschema: de-DE (de_DE); Calc: group threaded


Greetings
Michael
Comment 26 Gisbert Juch 2019-03-04 12:52:07 UTC
I confirm the bug. Windows 7, LibreOffice 6.2.0.3
If the document contains of 1 page, the fax is sent OK. If it contains of more than 1 page, the built tiff is empty (as to see in windows fax protocol). It is reproducible in easy extreme case also, if page 1 is 1 short text following by eject to next page and page 2 contains 1 word. If I export the same document to pdf and send this by Acrobat Reader, all is OK via MS fax printer.
Gisbert.
Comment 27 Sumit 2019-05-09 12:27:38 UTC Comment hidden (spam)
Comment 28 SAIF ALI 2019-05-18 06:57:31 UTC Comment hidden (spam)
Comment 29 Gisbert Juch 2019-10-01 14:54:41 UTC
It is to confirm for 6.3.2 also
Comment 30 johnruth 2019-10-04 07:05:58 UTC Comment hidden (spam)
Comment 31 Gisbert Juch 2019-12-02 10:10:31 UTC
Now I've tested in Windows 10 and LibreOffice 6.3.3.2 (x64). The full fax containing of 4 pages is sent.
Comment 32 Sofia Williams 2019-12-04 04:45:36 UTC Comment hidden (spam)
Comment 33 Xisco Faulí 2019-12-04 12:53:24 UTC
(In reply to Gisbert Juch from comment #31)
> Now I've tested in Windows 10 and LibreOffice 6.3.3.2 (x64). The full fax
> containing of 4 pages is sent.

Let's close it as RESOLVED WORKSFORME then
Comment 34 Gerry Criston 2019-12-05 10:50:47 UTC Comment hidden (spam)
Comment 35 john smith 2019-12-09 06:57:34 UTC Comment hidden (spam)
Comment 36 Eva Smith 2020-10-22 10:41:44 UTC Comment hidden (spam)
Comment 40 allan finch 2021-01-30 08:03:03 UTC Comment hidden (spam)
Comment 41 officecomsetupdownload 2021-02-01 16:25:28 UTC Comment hidden (spam)
Comment 43 travis smith 2022-04-07 09:42:01 UTC Comment hidden (spam)
Comment 44 travis smith 2022-04-07 09:42:36 UTC Comment hidden (spam)
Comment 45 jonasnielsen 2022-04-07 11:40:50 UTC Comment hidden (spam)
Comment 46 david smith 2022-04-07 15:41:44 UTC Comment hidden (spam)