Bug Hunting Session
Bug 93746 - When you protect a cell in a Writer Table, cursor jumps to an adjacent cell
Summary: When you protect a cell in a Writer Table, cursor jumps to an adjacent cell
Status: RESOLVED INVALID
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.0.0.5 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-08-28 13:16 UTC by Charles
Modified: 2015-08-28 17:36 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Charles 2015-08-28 13:16:53 UTC
To reproduce:

1. Open a new blank Writer document
2. Add a simple Table
3. Click inside a cell
3. Protect the cell

Note that the cursor jumps to an adjacent cell.

Note: Unprotecting a cell does not cause the cursor to jump to another cell.
Comment 1 Cor Nouws 2015-08-28 14:19:25 UTC
Hi Charles,

Indeed. Can you explain what is the use of having the cursor remaining in a protected cell ?
thanks,
Cor
Comment 2 Charles 2015-08-28 17:28:40 UTC
Because that is where I put it.

It makes no sense to just randomly jump to an adjacent cell when you protect it, just like it would make no sense to jump to another cell after applying a style to it, or anything else.
Comment 3 Charles 2015-08-28 17:36:52 UTC
Hmmm... just tested and it does the same thing (jumps to an adjacent cell) in 4.3.6, so it isn't a new bug... maybe isn't even a bug at all.

I think the reason I never noticed it before is because when I was protecting cells before, I was usually doing many at once, and doing it from the context menu.

But, to be consistent, I'd say that it shouldn't then allow you to even place the cursor back into the protected cell, if it is going to kick you out.

<shrug> for me it just doesn't feel right.

But, resolving as invalid...

Thanks Cor...