Bug 93819 - Calc opens xlsx file slowly
Summary: Calc opens xlsx file slowly
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.1.0.0.alpha0+ Master
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: XLSX File-Opening
  Show dependency treegraph
 
Reported: 2015-08-31 19:13 UTC by Silviu C.
Modified: 2021-04-12 14:50 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
File causing the problem (8.82 MB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2015-08-31 19:13 UTC, Silviu C.
Details
not opening on osx, LO freezes, log (838.42 KB, text/plain)
2015-09-02 09:17 UTC, steve
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Silviu C. 2015-08-31 19:13:16 UTC
Created attachment 118297 [details]
File causing the problem

Hi,

Previously, Calc could not open this file at all. The bugged was tracked here and fixed.
 
https://bugs.documentfoundation.org/show_bug.cgi?id=68016
 
There is still a performance issue. Calc is still rather slow to open the file and initial switching between the sheets is also slow. Subsequent switching between the various sheets is fast and responsive.

I posted a video to illustrate the problem here:
https://www.youtube.com/watch?v=UQSOiOreLxw

I've attached the problematic file.
Comment 1 steve 2015-09-02 09:17:30 UTC
A 10MB excel file is huge and probably slow opening times are to be expected here.

In my test with LO vanilla 5.0.1002 it took a few minutes without having the file loaded while excel was already done loading after less than a minute. Having to force quit LO. File never opens. Looks as if LO crashed.

Attaching log.

Confirmed → NEW.
Comment 2 steve 2015-09-02 09:17:58 UTC
Created attachment 118326 [details]
not opening on osx, LO freezes, log
Comment 3 Silviu C. 2015-09-02 09:46:20 UTC
Steve, thank you for testing but you should know that the actual problem with hanging while attempting to open this file was fixed in 5.1.0-master.
 
Please see (closed) bug for details:
https://bugs.documentfoundation.org/show_bug.cgi?id=68016
 
I opened this new report as instructed by Tobias and Julien because performance of opening the file will need to be addressed at some point. When someone has the time to look into it.
 
If you can, compare it to the speed with which Excel 2007 or later manages to open the same file. It's way faster.

If you want to, you can try using the daily build in parallel. For OS X the instructions are here:
 
https://wiki.documentfoundation.org/Installing_in_parallel/OS_X
 
I use Ubuntu myself.
Comment 4 Silviu C. 2015-09-02 09:49:23 UTC
Forgot to add link to daily builds:

http://dev-builds.libreoffice.org/daily/master/
Comment 5 steve 2015-09-03 08:09:28 UTC
My bad, sorry. Retested with nightly from today. Opening times on OS X 10.10.5:

LO ~1,5min
Excel ~1,5min

I don't see much difference in the opening time. 9,2MB for an Excel file is pretty big, not sure if this is to be expected.
Comment 6 Silviu C. 2015-09-03 09:22:25 UTC
Hi Steve,

That is odd. Excel 2007 is *really fast* to open this file:

https://www.youtube.com/watch?v=av7UGAWzhec
 
Were you using MS Office for OS X? Which version?
Comment 7 QA Administrators 2016-09-20 10:28:40 UTC Comment hidden (obsolete)
Comment 8 Silviu C. 2016-09-24 08:33:19 UTC
Hi,

This bug is still present in LO. The version I'm currently using:

Version: 5.2.1.2
Build ID: 1:5.2.1~rc2-0ubuntu1~trusty0
CPU Threads: 4; OS Version: Linux 4.4; UI Render: default; 
Locale: ro-RO (en_US.UTF-8); Calc: CL

There is one improvement to what I initially reported. Switching between sheets after the document loaded is happens fast now. Previously it would take a bit until the switching actually happened.

The file still loads very slow compared to Excel 2007 running in CrossOver (wine)
Comment 9 Xisco Faulí 2017-09-29 08:51:11 UTC Comment hidden (obsolete)
Comment 10 Roman Kuznetsov 2019-02-05 14:42:26 UTC
I got 15 sec in Excel and 2 min in LO

Version: 6.3.0.0.alpha0+
Build ID: ed707a4806a489467c6d9be7d1b787dab94b5f78
CPU threads: 4; OS: Windows 6.1; UI render: default; VCL: win; 
Locale: ru-RU (ru_RU); UI-Language: en-US
Calc: threaded
Comment 11 QA Administrators 2021-02-05 04:12:05 UTC Comment hidden (obsolete)
Comment 12 Silviu C. 2021-02-05 08:28:03 UTC
Took about 20s to open up in Calc

Version: 7.0.4.2
Build ID: 00(Build:2)
CPU threads: 6; OS: Linux 5.10; UI render: default; VCL: gtk3
Locale: ro-RO (en_US.UTF-8); UI: en-US
Calc: CL

Takes about 10s to open up in Excel on a Macbook Air 2017, which is significantly less powerful than my current PC running Linux
Comment 13 Roman Kuznetsov 2021-04-12 14:44:53 UTC
It takes 18 sec in 

Version: 7.2.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: 7a0e0a84a02f505200331c19b28d45e898cd5a12
CPU threads: 4; OS: Windows 10.0 Build 18363; UI render: Skia/Raster; VCL: win
Locale: ru-RU (ru_RU); UI: ru-RU
Calc: threaded Jumbo
Comment 14 Roman Kuznetsov 2021-04-12 14:50:01 UTC
I think we have a parity with Excel now by file opening time

So I close it as WFM

But there is an another problem => the file has diagrams but LO doesn't show it at all. I think LO just can't open diagrams that Excel created on different sheets.