Download it now!
Bug 93832 - Import of Word .doc file with frames and drawings objects is wrong
Summary: Import of Word .doc file with frames and drawings objects is wrong
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: filters and storage (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: interoperability
Keywords: filter:doc
Depends on:
Blocks: DOC-Frames
  Show dependency treegraph
 
Reported: 2015-09-01 08:45 UTC by Peter
Modified: 2019-10-03 02:59 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
.doc to reproduce flaw, .pdf to demonstrate flaw (112.75 KB, application/x-7z-compressed)
2015-09-01 08:45 UTC, Peter
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Peter 2015-09-01 08:45:01 UTC
Created attachment 118308 [details]
.doc to reproduce flaw, .pdf to demonstrate flaw

There is a flaw when importing a .doc file originating from MS Word 2010.
The document contains some boxes that are shifted around by LibreOffice.

Attached one can find an archive with three files:

TestBeschreibung3.doc           – file as written by MS Word 2010
TestBeschreibung3_Word2010.pdf  – how it is displayed in Word2010 (target state)
TestBeschreibung3_LO4.4.5.2.pdf – how it is displayed in LO 4.4.5.2 (flawed)
Comment 1 Peter 2015-09-01 09:17:01 UTC
The version I reported is just the version I used when I encountered this bug.
This isn't necessarily (probably isn't) the first version affected by this bug.

Thanks for debugging!
Comment 2 Cor Nouws 2015-09-01 09:44:56 UTC
Hi Peter,

Thanks for filing the issue and the clear sample document and PDF files.
I confirm the problem in 5.0.0.5 and 3.3.0 - so it must be a long standing issue.

Note: when grabbing the second large frame (RP) with the mouse and dragging it left, the next frame moves too!

Cheers - Cor
Comment 3 Robinson Tryon (qubit) 2015-12-14 05:59:31 UTC Comment hidden (obsolete)
Comment 4 QA Administrators 2018-10-02 02:54:33 UTC Comment hidden (obsolete)
Comment 5 Peter 2018-10-02 19:51:39 UTC
The bug is still present with the latest version of LibreOffice

Version: 6.0.6.2
Build ID: 0c292870b25a325b5ed35f6b45599d2ea4458e77
CPU threads: 8; OS: Linux 3.13; UI render: default; VCL: gtk2; 
Locale: de-DE (de_DE.UTF-8); Calc: group
Comment 6 QA Administrators 2019-10-03 02:59:24 UTC Comment hidden (spam)