Bug 93874 - FILEOPEN: DOCX import table: colors and structure lost
Summary: FILEOPEN: DOCX import table: colors and structure lost
Status: RESOLVED DUPLICATE of bug 79329
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.1 all versions
Hardware: Other All
: high normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisectRequest, filter:docx, regression
Depends on:
Blocks: DOCX-Tables
  Show dependency treegraph
 
Reported: 2015-09-03 07:06 UTC by Andras Timar
Modified: 2016-12-29 14:34 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
bugdoc (DOCX) (24.83 KB, application/wps-office.docx)
2015-09-03 07:06 UTC, Andras Timar
Details
reference rendering (PDF) (42.76 KB, application/pdf)
2015-09-03 07:07 UTC, Andras Timar
Details
KOMIR.pdf: what the disaster looks like (for the record). (100.24 KB, application/pdf)
2016-12-29 13:05 UTC, Justin L
Details
KOMIR_08Nov2016.pdf: what the fixed version looks like (97.69 KB, application/pdf)
2016-12-29 14:34 UTC, Justin L
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andras Timar 2015-09-03 07:06:49 UTC
Created attachment 118370 [details]
bugdoc (DOCX)

The layout of the table is completely broken in LibreOffice Writer.
Comment 1 Andras Timar 2015-09-03 07:07:17 UTC
Created attachment 118371 [details]
reference rendering (PDF)
Comment 2 MM 2015-09-03 18:37:50 UTC
Confirmed with v5.0.1.2 under mint 17.2 x64.
Confirmed with v4.1.6.2 under mint 16 x64.
Unconfirmed with v3.3.4 under windows7 x64.

Loads just fine with the old version, might have been broken since v4 ?!
Comment 3 Xisco Faulí 2016-09-12 12:45:30 UTC
Adding keyword 'bibisectRequest'.
Comment 4 Xisco Faulí 2016-10-05 16:19:09 UTC
Reproduced in

Version 4.1.0.0.alpha0+ (Build ID: efca6f15609322f62a35619619a6d5fe5c9bd5a)
Comment 5 Justin L 2016-12-29 13:05:54 UTC
Created attachment 130002 [details]
KOMIR.pdf: what the disaster looks like (for the record).
Comment 6 Justin L 2016-12-29 14:26:45 UTC
This has since been fixed on Nov 8 and likely is available in LO 5.2.4.

bibisected the fix. Almost certainly, this is the one:
author	Miklos Vajna <vmiklos@collabora.co.uk>	2016-11-08 08:11:33 (GMT)
commit	c1eebcdac9f2b289fd363399130c485ca5ff444c
tdf#79329 DOCX import: fix missing outer table with floattable at cell start

*** This bug has been marked as a duplicate of bug 79329 ***
Comment 7 Justin L 2016-12-29 14:34:47 UTC
Created attachment 130007 [details]
KOMIR_08Nov2016.pdf: what the fixed version looks like