Bug 93934 - Entire row and column export to and import from MS Excel 97-2003 format broken
Summary: Entire row and column export to and import from MS Excel 97-2003 format broken
Status: RESOLVED DUPLICATE of bug 93878
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.0.1.2 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-09-05 03:48 UTC by Óvári
Modified: 2015-09-05 12:11 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Óvári 2015-09-05 03:48:21 UTC
Version: 5.0.1.2 (x64)
Build ID: 81898c9f5c0d43f3473ba111d7b351050be20261

1.  Open LibreOffice Calc
2.  In cell C1048576 enter: 1
3.  In cell AMJ3 enter: 2
3.  In cell A1 enter: =SUM(3:3)
    a) A1 value is: 2
4.  In cell A2 enter: =SUM(C:C)
    a) A2 value is: 1
5.  File --> Save As...
6.  In 'Save as type' select: Microsoft Excel 97-2003 (.xls) (*.xls)
7.  Click 'Save'
8.  Click 'Use Microsoft Excel 97-2003 Format'
9.  Close LibreOffice
10. Open LibreOffice
11. Click on the file Untitled 1
12. Cell A1:
    a) Value is   : #REF!                         [incorrect should be 2]
    b) Formula is : =SUM($#REF!#REF!:$#REF!#REF!) [incorrect should be =SUM(3:3)]
13. Cell A2:
    a) Value is   : 0                             [incorrect should be 1]
    b) Formula is : =SUM(C$1:C$983040)            [incorrect should be =SUM(C:C)]

Thank you
Comment 1 m.a.riosv 2015-09-05 12:11:44 UTC

*** This bug has been marked as a duplicate of bug 93878 ***