Download it now!
Bug 93942 - Autocorrect capitalisation not affecting word in quotes
Summary: Autocorrect capitalisation not affecting word in quotes
Status: RESOLVED DUPLICATE of bug 54409
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4.5.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-09-05 14:45 UTC by Lynne Connolly
Modified: 2015-09-15 17:53 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
examples of capitalisation inconsistencies (10.74 KB, application/vnd.oasis.opendocument.text)
2015-09-05 14:45 UTC, Lynne Connolly
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Lynne Connolly 2015-09-05 14:45:38 UTC
Created attachment 118433 [details]
examples of capitalisation inconsistencies

This has been reported before, but the bug is too old to add to. Automatic capitalisation doesn't work when you start a sentence with either a word that has an apostrophe in it, or quotation marks, single or double.
If automatic capitalisation is to be consistent, these should be addressed. 
Example:
. "isn't it a nice day?" isn't auto-capitalised.
. isn't it a nice day? isn't capitalised
. Is it not a nice day? is capitalised.

I know what the cause is, but in use the practice doesn't make much sense. Textmaker from Softmaker, WPS Office and Scrivener all cope with the capitalisation issue. Microsoft Word capitalises the words in apostrophes but not in quotation marks.
This happens whether the quotation marks are opening ones or closing ones. So when you end a sentence with ." the next word isn't capitalised, as it should be.
Comment 1 tommy27 2015-09-06 07:12:18 UTC
tell your LibO version and O/S

in my LibO 4.4.5 under Win8.1x64 I get correct auto-capitalization of: 
Isn't a nice day.

while this is not capitalized:
“isn't a nice day?”.
Comment 2 Lynne Connolly 2015-09-06 15:33:39 UTC
Maybe it's because I use curly quotes?
Comment 3 Buovjaga 2015-09-15 17:51:17 UTC
. isn't it a nice day? is auto-capitalised for me (both US & UK English).
. "isn't it a nice day?" isn't auto-capitalised.

Adjusted summary. Could not find a duplicate report.

Win 7 Pro 64-bit, Version: 5.0.1.2 (32-bit)
Build ID: 81898c9f5c0d43f3473ba111d7b351050be20261
Locale: fi-FI (fi_FI)
Comment 4 Buovjaga 2015-09-15 17:53:36 UTC
Ahh, now I noticed the dupe :)

*** This bug has been marked as a duplicate of bug 54409 ***