Bug Hunting Session
Bug 93970 - Writer: default Heading styles 1 - 10 defined with negative indent for first line, results in odd multi-line Heading formats
Summary: Writer: default Heading styles 1 - 10 defined with negative indent for first ...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: ux-advise (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: low minor
Assignee: Samuel Mehrbrodt (CIB)
URL:
Whiteboard: target:5.1.0
Keywords:
Depends on:
Blocks:
 
Reported: 2015-09-06 15:43 UTC by Yan Pas
Modified: 2016-10-25 19:17 UTC (History)
10 users (show)

See Also:
Crash report or crash signature:


Attachments
ms word and LO screenshot (194.23 KB, image/png)
2015-09-06 15:43 UTC, Yan Pas
Details
TESTFILE (11.69 KB, application/vnd.oasis.opendocument.text)
2015-09-06 21:14 UTC, Yan Pas
Details
screenshot (148.07 KB, image/png)
2015-09-06 21:19 UTC, Yan Pas
Details
weird progressive indent of multi-line Heading styles (73.44 KB, image/png)
2015-09-18 14:22 UTC, V Stuart Foote
Details
File create in Word. First line should NOT be indented (22.00 KB, application/msword)
2015-09-22 15:51 UTC, Luke
Details
Word Doc have same wrong indent values (179.44 KB, image/png)
2015-09-24 10:12 UTC, Luke
Details
test file showing the new behavior (13.70 KB, application/3dr)
2015-09-26 16:37 UTC, Cor Nouws
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yan Pas 2015-09-06 15:43:28 UTC
Created attachment 118468 [details]
ms word and LO screenshot

Header 1 Header 2 Header 3 styles have indent of the first line equal to 0.76 cm.  What's the reason for it? It's not typographical standart, at Russia at least. MS Word deosn't have such indent in it's styles. Change default template, please. I see no reason to attach sample file, you may create it yourselft, I'll attach screenshot
Comment 1 Jean-Baptiste Faure 2015-09-06 18:22:48 UTC
(In reply to Yan Pashkovsky from comment #0)
> I see no reason to attach sample file, you may
> create it yourselft, I'll attach screenshot

Ok, so closing as INVALID, because many testers can't create a ms-word document as they do not have MS-Word.

Best regards. JBF
Comment 2 Yan Pas 2015-09-06 20:41:39 UTC
What does MS Word have to do with it? The problem is in unresanoble indent. MS Word is a STANDART in the world of text processors, it was just an example. U can also use web version of ms word which is availible for everyone.
Comment 3 Jean-Baptiste Faure 2015-09-06 21:04:50 UTC
Removing myself from CC because I am not interested in MS formats problems. I have lost enough time for that.
Comment 4 Jean-Baptiste Faure 2015-09-06 21:12:01 UTC
Try something else: a test file is needed, please attach one.
Comment 5 Yan Pas 2015-09-06 21:14:11 UTC
Created attachment 118483 [details]
TESTFILE

OK, then. And again what does MS Word have to do with it? I CREATE NEW DOCUMENT IN LIBREOFFICE AND I HAVE THESE IDIOTIC INDENTS IN HEADER STYLE!!!!! NOT IN MS WORD, NOT IN F**ING WINDOWS, NOT DOCX, NOT DOC. I CREATE NEW DOCUMENT IN LIBREOFFICE WITH DEFAULT CONFIGURATION; AND HEADERS' FIRST LINE IS MOVED TO THE LEFT FOR 0.76 CM. WHY??? SHOW ME BOOK, MAGAZINE OR ANY OTHER PUBLICATION WITH SUCH BIZARE HEADERS.
PS I hope when I type in Capital letters, people will finaly understand me. If this didn't help, someone another from LO support should review this issue
Comment 6 Yan Pas 2015-09-06 21:19:34 UTC
Created attachment 118484 [details]
screenshot

Additional clarification is never extra
Comment 7 Buovjaga 2015-09-17 15:50:09 UTC
UX: do we change the default indent of Heading styles?
Comment 8 Yousuf Philips (jay) (retired) 2015-09-17 16:48:34 UTC
Hi Yan,

Yes i find it strange as well, but never noticed it before because i've never had headings that went over a line. I would assume the default should be that there is no indent and if a user wanted to change the style to have an indent, then they have that option.

@Cor, @Stuart, @Heiko: What are you guy's opinion of this?
Comment 9 Heiko Tietze 2015-09-17 20:12:19 UTC
Agreed since I change it always myself. Zero indent ftw.
Comment 10 Samuel Mehrbrodt (CIB) 2015-09-18 09:22:44 UTC
Would also support this. If noone objects, I can prepare a patch for this.
Comment 11 sophie 2015-09-18 11:37:08 UTC
Hi all, supported also on my side, much better for i18n too. Sophie
Comment 12 V Stuart Foote 2015-09-18 14:22:19 UTC
Created attachment 118825 [details]
weird progressive indent of multi-line Heading styles

Yes, unclear why/how we have formatted multi-line Heading with a negative indent for first line. Also, there is some weird juxtaposition in editengine in that the successive HEADING levels increase the base line of the indent. That doesn't seem correct either.

However, checked LO 3.3.0, 3.4.6, 4.0.6.2, this formatting of multi-line Headings has been with LO from the start, setting Inherited from OOo

Would probably be simplest to remove the negative first line indent (if we can locate where that is assigned), but we will need to test extensively as it could cause problems elsewhere in Navigator, numbered/bulleted, content, and index styles.
Comment 13 Commit Notification 2015-09-22 09:26:02 UTC
Samuel Mehrbrodt committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=05fd8cb848ecba425124d61cd76e2f9418d5378c

tdf#93970 Outline indents should not affect paragraph indents

It will be available in 5.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 14 Yan Pas 2015-09-22 10:10:48 UTC
Are there any regressions? Table of contents e. G.?
Comment 15 Cor Nouws 2015-09-22 13:31:12 UTC
(In reply to Yan Pashkovsky from comment #14)
> Are there any regressions? Table of contents e. G.?

God question :)
Would you please like to test? Download end of this day / today from 
  http://dev-builds.libreoffice.org/daily/master/
and if the patch is in, try it :)
Comment 16 Luke 2015-09-22 15:51:03 UTC
Created attachment 118938 [details]
File create in Word. First line should NOT be indented

Thank you Samuel. This is working well for new documents. Unfortunately, it is still using the wrong defaults for .doc files. 

When we import .doc files, we are still adding an erroneous +.3 before indent and -.3  first line to word docs. I believe this may be related to Bug 65865.
Comment 17 Samuel Mehrbrodt (CIB) 2015-09-23 05:16:02 UTC
(In reply to Luke from comment #16)
> This is working well for new documents. Unfortunately, it
> is still using the wrong defaults for .doc files. 

Hi Luke, please create a new bug report for that. That's an unrelated bug.
Comment 18 Luke 2015-09-24 09:24:56 UTC
Samuel,
Are you sure there is no relationship? The symptoms are identical. If I follow the steps to reproducing this in Word instead of Writer, I end up with the same results in Writer. Both the erroneous paragraph style values and the fix are the same.
Comment 19 Luke 2015-09-24 10:12:09 UTC
Created attachment 118988 [details]
Word Doc have same wrong indent values

A: attachment 118483 [details] opened in Writer
B: Results of C opened in Writer
C: Text of attachment 118483 [details] pasted in Word, Style=Heading 1, saved as DOC

Samuel,
Both A and B have same, wrong indent values. Your patch only addresses A. Since B is still broken, is it possible that you are fixing the problem at the wrong level?

Miklos you’re the import/export expert. What do you think?
Comment 20 Cor Nouws 2015-09-26 16:37:29 UTC
Created attachment 119044 [details]
test file showing the new behavior

Hi,

Up until now, in Writer usually (and AFAIK – which is limited) also in the ODF specs, the indent (margins) of the list styles prevail over those from the paragraphs.

So I think this change is problematic, I think..
Comment 21 Cor Nouws 2015-09-26 16:37:44 UTC
.
Comment 22 Cor Nouws 2015-09-26 16:39:35 UTC
Hmm, looks as if I commented to the wrong issue. Apologies!
Comment 23 Cor Nouws 2015-09-26 16:40:11 UTC
Comment on attachment 119044 [details]
test file showing the new behavior

comment on wrong issue
Comment 24 Heiko Tietze 2015-09-26 18:38:46 UTC
(In reply to Cor Nouws from comment #20)
> in the ODF specs...

The ODF specs contain of typographic guidelines? Even when your comment was made regarding lists that would be relevant for headings too.

PS: It feels a little bit weird to discuss issues with resolved feature requests / fixed bug reports.
Comment 25 Cor Nouws 2015-09-26 18:59:02 UTC
(In reply to Heiko Tietze from comment #24)

> PS: It feels a little bit weird to discuss issues with resolved feature
> requests / fixed bug reports.

Especially when it's the wrong issue :p
Comment 26 Miklos Vajna 2015-10-10 18:28:27 UTC
(In reply to Luke from comment #19)
> Miklos you’re the import/export expert. What do you think?

I agree that it would be better to file a new bug if you're not 100% happy with the current situation, since this bug has a fix associated with it already, and it's confusing when multiple commits reference the same bug. Thanks. :-)
Comment 27 Luke Deller 2016-05-04 12:37:37 UTC
(In reply to V Stuart Foote from comment #12)
> Yes, unclear why/how we have formatted multi-line Heading with a negative
> indent for first line.

I did some digging to understand this.  The old behaviour actually makes sense when outline numbering is enabled: it means that the indent of the second line will align with the heading text on the first line, taking into account that the first line starts with a number followed by a tab stop before the heading text begins.

I can also see that the default back in early 1996 was to have outline numbering enabled, from some old German comments in revision 84a3db80 of sw/source/core/doc/number.cxx

> Also, there is some weird juxtaposition in editengine
> in that the successive HEADING levels increase the base line of the indent.
> That doesn't seem correct either.

This increase in the indent amount makes sense when fully-qualified (dotted) section numbering is used.  For example a level 3 heading may have a dotted number like "5.1.7", and deeper levels have even more dots, so they need more room for the numbering.  I guess that such numbering used to be the default.
Comment 28 Luke 2016-05-05 03:28:09 UTC
(In reply to Miklos Vajna from comment #26)
> (In reply to Luke from comment #19)
> > Miklos you’re the import/export expert. What do you think?
> 
> I agree that it would be better to file a new bug if you're not 100% happy
> with the current situation

The doc version of this bug is filed at Bug 95576

Luke Deller & V Stuart,
It might make more sense to continue your discussion there.