Bug Hunting Session
Bug 93993 - Impress/Draw on opening cursor movement controls canvas rather than advancing slides/pages
Summary: Impress/Draw on opening cursor movement controls canvas rather than advancing...
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.0.1.2 release
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-09-07 14:30 UTC by jddcef
Modified: 2016-05-16 13:40 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jddcef 2015-09-07 14:30:46 UTC
I'm trying to get new users to use this application, but I get so embaressed when they open a ppt file, and the very first thing they do is press the right or down arrows to go to the next slide.  Instead, the slide just starts moving around on the screen.  This is totally unexpected and confusing.  Someone who opens a presentation with many slides isn't expecting to move the slide around if they just opened it and pressed an arrow. They are obviously expecting to move to the next slide.

Please make the arrows move to the next slide, even if it's just during the time that a presentation was opened but no clicks were made yet.
Comment 1 Julien Nabet 2015-09-07 19:25:04 UTC
There's left pane where all slides are in thumbnails. There, arrows work as you expected.
Comment 2 jddcef 2015-09-07 19:37:07 UTC
There are other ways to do this like you have mentioned one, but this is a very common case in my original issue.  You could believe me or have some analytics running in the app to measure usage and where people get stuck or repeat actions many times.
Trust me, the temptation to pay the $99 for Office seems like a small price to pay at times, but instead I'm choosing to spend the time to give feedback and suggestions to improve the quality of LO. 
  (In reply to Julien Nabet from comment #1)
> There's left pane where all slides are in thumbnails. There, arrows work as
> you expected.
Comment 3 Julien Nabet 2015-09-07 19:47:14 UTC
I'm not ergonomic expert so don't know what should be the expected behaviour and cc UX-team.

I trust you but suppose (perhaps I'm wrong) it's because they're just accustomed to MsOffice.

BTW, I confirm the behaviour on LO testing Debian x86-64 with 5.0.1.2 package.
Comment 4 Heiko Tietze 2015-09-08 14:50:57 UTC
There is a horizontal scrollbar that receives the keyboard events. If you focus another control the events are processed there. In case of the layout sidebar you select the next or previous item (even up/down doesn't go to the next slide here), and when you click the slides pane you can use left/right and up/down for navigation. 
Microsoft and many other office suites does not have sidebars (or rather do not use them extensively). If we would override the behavior of left/right and redirect any cursor event to the slides pane it would be very annoying for the disabled people and probably as well for the expert users.
Perhaps there is a special shortcut that works everywhere. If not that would be an option, from the usability POV.
Comment 5 jddcef 2016-05-10 20:29:14 UTC
I don't think it's about someone who is used to MSOffice - these are users who never used such products before.  I can't see of any case in which someone would want to move a slide around with the arrow keys? Because everything that is on the slide is shown already and unless the user is zoomed in explicitly, the arrows shouldn't do this because there is no good reason for it.

And remember, this is the case when a file has just been opened, if that's the case then I'm most likely not trying to edit the presentation but just browse through it.
Comment 6 V Stuart Foote 2016-05-16 13:37:53 UTC
(In reply to jddcef from comment #5)
> I don't think it's about someone who is used to MSOffice - these are users
> who never used such products before.  I can't see of any case in which
> someone would want to move a slide around with the arrow keys? Because
> everything that is on the slide is shown already and unless the user is
> zoomed in explicitly, the arrows shouldn't do this because there is no good
> reason for it.
> 
> And remember, this is the case when a file has just been opened, if that's
> the case then I'm most likely not trying to edit the presentation but just
> browse through it.

Sorry, do not agree nor do I see an issue. By design LibreOffice Impress opens into *edit* mode, focus is on the document canvas and cursor (Lft,Rgt,Up,Down) position the canvas. Suitable tools are provided to advance through the slides/pages (as this is also default in Draw).

That is that <PgDown>, <PgUp>, <End>, <Home> are immediately available to advance between slides/pages. 

In edit mode the opening focus and cusor movement is for editing, it is not for review. That is and has been the default from the StarOffice era.