Bug 94037 - Crash when uncheck Protect this... in Protec Sheet window
Summary: Crash when uncheck Protect this... in Protec Sheet window
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.0.1.2 release
Hardware: All All
: high major
Assignee: Katarina Behrens (CIB)
URL:
Whiteboard: target:5.1.0 target:5.0.3
Keywords: regression
Depends on:
Blocks:
 
Reported: 2015-09-08 21:31 UTC by f.rr
Modified: 2016-10-25 19:24 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description f.rr 2015-09-08 21:31:44 UTC
To reproduce the bug:
1. Tools
2. Protect Document
3. Sheet
4. uncheck "Protect this sheet and..."

It go in crash.

I tested on Debian, Windows 7 and OSX 10.10
Comment 1 m.a.riosv 2015-09-08 23:18:24 UTC
Hi @f.rr, thanks for reporting.

Reproducible.
Win10x64
Version: 5.0.1.2 Build ID:: 81898c9f5c0d43f3473ba111d7b351050be20261
Version: 5.0.2.1 (x64) Build ID: 9a18d52abbdfbdc2ac9acebec2b92e7859eb73b7
Version: 5.1.0.0.alpha1+ Build ID: ca77ec422ea617c84400370b082e71437e4590cc
  TinderBox: Win-x86@39, Branch:master, Time: 2015-08-31_13:54:42

No issue with:
Version: 4.4.6.0.0+ Build ID: 319d725c73b8bf60158961aa0b014258708effab
Comment 2 Cor Nouws 2015-09-10 11:14:03 UTC
crashes too in 5.0.2.1 on Ubuntu 32 bits
Comment 3 Katarina Behrens (CIB) 2015-09-10 12:12:49 UTC
Someone who does their own builds and can pull patches from gerrit please give this a try: https://gerrit.libreoffice.org/#/c/18469/

I can't reproduce the crash as reported as I only have a debug build and I'm getting abort() much sooner
Comment 4 Julien Nabet 2015-09-12 11:01:49 UTC
On pc Debian x86-64 with master sources updated today, I had a crash by doing:
1. Tools
2. Protect Sheet
=> crash

Here's the relevant part of bt:
#5  0x00002aaad3bfef27 in VclBuilderContainer::get<VclContainer>(VclPtr<VclContainer>&, rtl::OString const&) (this=0x34c5588, ret=..., sID="options")
    at /home/julien/compile-libreoffice/libreoffice/include/vcl/builder.hxx:464
#6  0x00002aaad3d995ea in ScTableProtectionDlg::ScTableProtectionDlg(vcl::Window*) (this=0x34c5360, pParent=0x2eddb60)
    at /home/julien/compile-libreoffice/libreoffice/sc/source/ui/miscdlgs/protectiondlg.cxx:38
Comment 5 Commit Notification 2015-09-12 11:08:24 UTC
Katarina Behrens committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=27304ec7c2b6037cf0a24b7b671092c5353567ec

tdf#94037: Don't try to manipulate non-existent widget container

It will be available in 5.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 6 Julien Nabet 2015-09-12 11:19:42 UTC
I submitted the patch because at least with it, I didn't reproduce the crash + indeed there was a regression ("options" replaced by "box3" in ui file only).
Then, I gave a try to initial description (even if "Protect Document" option doesn't exist, only "Protect Sheet..." and "Protect Spreadsheet...") and didn't reproduce this.

Now someone may try the next non debug build (see http://dev-builds.libreoffice.org/daily/master/) which includes the patch and confirms if it's ok or not.
Katarina: what about setting the tracker to FIXED meanwhile? (at worst, it'll be reopened)
Comment 7 Adolfo Jayme 2015-09-12 14:47:04 UTC
Sorry for the oversight in my original commit! :(
Comment 8 Julien Nabet 2015-09-12 15:01:24 UTC
(In reply to Adolfo Jayme from comment #7)
> Sorry for the oversight in my original commit! :(
Don't worry, only those who do nothing, never make mistakes! :-)
Comment 9 Björn Michaelsen 2015-09-13 17:32:08 UTC
(In reply to Commit Notification from comment #5)
> Katarina Behrens committed a patch related to this issue.
> It has been pushed to "master":

@Bubli: Can this one be thus marked as resolved?
Comment 10 Katarina Behrens (CIB) 2015-09-14 08:40:03 UTC
> @Bubli: Can this one be thus marked as resolved?

It WFM and for Julien, so ye, if bad comes to worse, someone can reopen any time.

Will cherry-pick for 5.0, as that one's affected as well
Comment 11 Commit Notification 2015-09-14 10:24:48 UTC
Katarina Behrens committed a patch related to this issue.
It has been pushed to "libreoffice-5-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=7108b46723750dd390d28afda37ecf1e85581f6a&h=libreoffice-5-0

tdf#94037: Don't try to manipulate non-existent widget container

It will be available in 5.0.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.