Bug 94065 - FILEOPEN: LibO hangs loading a .docx exported by LibO 4.5
Summary: FILEOPEN: LibO hangs loading a .docx exported by LibO 4.5
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: filters and storage (show other bugs)
(earliest affected) release
Hardware: Other All
: medium normal
Assignee: Not Assigned
Keywords: filter:docx
Depends on:
Blocks: DOCX-Opening
  Show dependency treegraph
Reported: 2015-09-09 16:59 UTC by Patrick Georgi
Modified: 2021-09-04 07:15 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:

7z compressed document because it exceeds the file size limit (9.44 MB, application/x-7z-compressed)
2015-09-09 17:05 UTC, Patrick Georgi
a screenshot (69.04 KB, image/jpeg)
2016-12-11 12:59 UTC, fiftyigfuci_f_mi

Note You need to log in before you can comment on or make changes to this bug.
Description Patrick Georgi 2015-09-09 16:59:28 UTC
I got the file by an acquaintance (and got permission to publish it) who reports that it was created by LibreOffice 4.5 on Windows.

He tried to re-open it on 4.5, I tried to open it on LibreOffice 4.4.2 on Ubuntu as well as 5.0.1 on Windows, but in all instances it hangs Writer without even showing the first page.

He also reported that OpenOffice can open it.
I tested that Windows 8.1's Wordpad can open it, but with the usual distortions because it only supports a subset of the OOXML features.
Comment 1 Patrick Georgi 2015-09-09 17:05:02 UTC
Created attachment 118554 [details]
7z compressed document because it exceeds the file size limit
Comment 2 tommy27 2015-09-17 05:06:13 UTC
I confirm hanging at fileopen under Win8.1 x64 using LibO and a recent daily build
Comment 3 QA Administrators 2016-09-20 10:32:25 UTC Comment hidden (obsolete)
Comment 4 tommy27 2016-09-21 03:53:11 UTC
still hangs with LibO under Win8.1 x64
Comment 5 Telesto 2016-12-07 19:58:38 UTC
Repro with:
Build ID: a9f56091b6422ec8c42f09b8472200ae4ab12548
CPU Threads: 4; OS Version: Windows 6.19; UI Render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2016-12-05_23:12:26
Locale: nl-NL (nl_NL); Calc: CL
Comment 6 fiftyigfuci_f_mi 2016-12-11 12:59:27 UTC
Created attachment 129495 [details]
a screenshot

The pages does not show up, but Writer can response to a mouse.

I confirmed on both:
Build ID: 1:5.2.2-0ubuntu2
CPU Threads: 2; OS Version: Linux 4.9; UI Render: default; 
Locale: en-US (en_US.UTF-8); Calc: group

(My debug dev build)
Build ID: f35d29c8388744be1f95ec4acfca12eec706911a
CPU Threads: 2; OS Version: Linux 4.9; UI Render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); Calc: group
Comment 7 QA Administrators 2017-12-13 09:29:43 UTC Comment hidden (obsolete)
Comment 8 QA Administrators 2019-12-14 03:41:07 UTC Comment hidden (obsolete, spam)
Comment 9 Justin L 2021-09-04 07:15:20 UTC
repro 7.3+ that looks like the screenshot in comment 6.

MS Word 2016 struggles with this document. It gave an error and failed to export to PDF. Looking at the page size (Layout - Page), the dialog indicates that the page size is invalid - too large.

Since there has been little interest in this for a very long time, the document was created by an old LO, and it has invalid sizes, I'll close as INVALID.