Bug Hunting Session
Bug 94066 - Doesn't display the right font for Noto Sans/ Source Han Sans Fonts on elementary OS
Summary: Doesn't display the right font for Noto Sans/ Source Han Sans Fonts on elemen...
Status: RESOLVED INSUFFICIENTDATA
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.0.3.2 release
Hardware: x86-64 (AMD64) Linux (All)
: high normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Font-Rendering CJK
  Show dependency treegraph
 
Reported: 2015-09-09 17:17 UTC by laichiaheng
Modified: 2016-10-19 20:16 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
The way it should look like. (106.99 KB, image/png)
2015-12-23 15:21 UTC, laichiaheng
Details
But it looks like this, it is the wrong fonts (134.43 KB, image/png)
2015-12-23 15:24 UTC, laichiaheng
Details

Note You need to log in before you can comment on or make changes to this bug.
Description laichiaheng 2015-09-09 17:17:36 UTC
As title. It doesn't display the right font for Noto Sans fonts and Source Han Sans fonts.
Comment 1 Adolfo Jayme 2015-09-10 06:52:26 UTC
Please provide us with steps to reproduce the issue, and attach a screenshot of it. It would also be nice to know what Linux distribution you use, and what format of the Source Han Sans fonts you have installed (since there are multiple kinds: fonts subsetted by language, all-in-one, OTF versus TTF, et cetera).
Comment 2 laichiaheng 2015-09-10 15:06:08 UTC
System: elementary OS (based on Ubuntu 14.04.3LTS)
Fonts which I have installed: SourceHanSansTC-xxx.otf, SourceHanSansSC-xxx.otf, SourceHanSansK-xxx.otf, SourceHanSans-xxx.otf

Should be like this:
[img]http://i.imgur.com/G0a85DS.png[/img]

But it looks like this:
[img]http://i.imgur.com/h4E8VYI.png[/img]
Comment 3 laichiaheng 2015-09-10 15:07:00 UTC
System: elementary OS (based on Ubuntu 14.04.3LTS)
Fonts which I have installed: SourceHanSansTC-xxx.otf, SourceHanSansSC-xxx.otf, SourceHanSansK-xxx.otf, SourceHanSans-xxx.otf

Should be like this:
http://i.imgur.com/G0a85DS.png

But it looks like this:
http://i.imgur.com/h4E8VYI.png
Comment 4 laichiaheng 2015-12-23 15:21:47 UTC
Created attachment 121518 [details]
The way it should look like.
Comment 5 laichiaheng 2015-12-23 15:24:02 UTC
Created attachment 121519 [details]
But it looks like this, it is the wrong fonts
Comment 6 Xisco Faulí 2016-09-11 21:31:30 UTC Comment hidden (obsolete)
Comment 7 Yousuf Philips (jay) (retired) 2016-09-20 19:17:45 UTC
Hi laichiaheng,

Can you attach a document to the bug report containing the character you did the screenshot with, so we can test it.
Comment 8 laichiaheng 2016-09-21 15:11:31 UTC
It has been fixed on elementary OS Loki (Ubuntu 16.04).