Download it now!
Bug 94080 - HELPAUTHORING: the localize="false" attribute not imported
Summary: HELPAUTHORING: the localize="false" attribute not imported
Status: RESOLVED DUPLICATE of bug 93981
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Documentation (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: HelpAuthoring-Extension
  Show dependency treegraph
 
Reported: 2015-09-09 23:14 UTC by Yousuf Philips (jay) (retired)
Modified: 2015-09-10 22:32 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2015-09-09 23:14:32 UTC
When a paragraph tag has the localize entry set to false, it is supposed to append '_NOL10N' to the paragraph id on import, as the code to toggle L10N relies on that appended text in the paragraph id in order to know if it is on or off. Not setting this causes saving the file to lose the localize entry.

Example file - source/text/sbasic/shared/03020104.xhp

In

<paragraph role="bascode" localize="false" xml-lang="en-US">Sub ExampleReset</paragraph>

Out

<paragraph id="" role="bascode" xml-lang="en-US">Sub ExampleReset</paragraph>
Comment 1 Yousuf Philips (jay) (retired) 2015-09-10 22:32:36 UTC

*** This bug has been marked as a duplicate of bug 93981 ***