Bug 94101 - Extra spaces at the end of lines in RTL complex script (Persian) causes misplaced space, and garbled formatting.
Summary: Extra spaces at the end of lines in RTL complex script (Persian) causes mispl...
Status: RESOLVED DUPLICATE of bug 89034
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.0.0.0.alpha0+ Master
Hardware: x86-64 (AMD64) macOS (All)
: medium critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-09-10 15:56 UTC by Morty
Modified: 2015-09-11 06:03 UTC (History)
0 users

See Also:
Crash report or crash signature:
Regression By:


Attachments
Before pressing the enter with extra spaces at the end of line (end line is left in RTL). (9.51 KB, image/png)
2015-09-10 15:56 UTC, Morty
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Morty 2015-09-10 15:56:35 UTC
Created attachment 118578 [details]
Before pressing the enter with extra spaces at the end of line (end line is left in RTL).

When you are typing and enter a space (between words), the spaces will be entered at a wrong position (at the right-most position, instead of end of a sentence), and the text loses its formatting. After finishing a line, and returning to the next line, it will be corrected.

Here is how one can reproduce it:

1. Enable CTL (set it to Persian, Arabic, or other options. Under all languages this bug happens). And set the default font.
2. Create a new Writer document.
3. Change system language to Persian.
4. Start typing in Persian, when you enter a space the bug occurs and text loses its formatting in addition to the wrong placement of the space character (or zero width space character).
5. Press "Enter" to return to the next line, the formatting will be corrected, and extra spaces moves to the end of the previous line.
Comment 1 Morty 2015-09-10 16:06:40 UTC
This all happens when you are typing in a RTL language. For the LTR ones, as English, all things work out as expected.
Comment 2 Alex Thurgood 2015-09-11 06:03:58 UTC

*** This bug has been marked as a duplicate of bug 89034 ***