Bug Hunting Session
Bug 94152 - Reading / writing files to NFS volumes
Summary: Reading / writing files to NFS volumes
Status: RESOLVED DUPLICATE of bug 75488
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 98949 (view as bug list)
Depends on:
Blocks: Network
  Show dependency treegraph
 
Reported: 2015-09-12 02:02 UTC by delt
Modified: 2017-12-18 20:33 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description delt 2015-09-12 02:02:24 UTC
Trying to load a file on a NFS volume results in an error, where i am prompted to either edit the file read-only (which results in more errors) or edit a copy of the file.

Trying to save the file results in various errors, mostly involving locks on the file being saved.

In the following examples, my NFS server is running Linux Slackware 14.1 and is mounted from the client as /net/deimos - each client (a PC running Linux Mint and a guest OSX on the same machine under VirtualBox, using bridged networking) has a symlink 'deimos' in the home directory pointing to /net/deimos/home/user - so that ~/deimos points to the user's home account on the server.


Attempting to load a file on a NFS volume (linux mint client, linux slackware server) results in:

Document file 'test.ods' is locked for editing by:
Unknown User
Open document read-only or open a copy of the document for editing.


Attempting to load a file on a NFS volume (osx client, linux slackware server) seems to work fine.


Attempting to save to a file on a NFS volume (linux mint client, linux slackware server) results in:

Error saving the document Untitled1:
Error during shared access to /home/user/deimos/test.xls.


Attempting to save to a file on a NFS volume (osx client, linux slackware server) results in:

Error saving the document test.otd:
/net/deimos/home/user/temp/test.odt does not exist.


It is also worth noting that LibreOffice is the *ONLY* software which gives me this problem.
Comment 1 Joel Madero 2015-09-12 04:42:14 UTC
What version of LibreOffice are you running? Marking as NEEDINFO - once you tell us what version please set to UNCONFIRMED. Thanks
Comment 2 delt 2015-09-12 10:36:10 UTC
Oops, sorry. Totally forgot to include version.


Linux: (from the linux mint / ubuntu repositories)

Version: 4.4.3.2
Build ID: 40m0(Build:2)
Locale: en_CA


OS X: (from the libreoffice.org website)

Version: 5.0.1.2
Build ID: 81898c9f5c0d43f3473ba111d7b351050be20261
Locale: en-US (en.UTF-8)
Comment 3 delt 2015-09-12 11:07:16 UTC
I just tested with 5.0.1.2 on the Linux Mint computer, and it gives me the same result as with 4.4.x.
Comment 4 delt 2015-09-12 11:34:24 UTC
If i mount my NFS volumes with -o nolock, this works around the problem, but might cause other issues.
Comment 5 delt 2015-09-12 11:50:32 UTC
...Except for saving on osx. Opening files over nfs forces read-only, though the error box no longer shows up, and saving to nfs still gives the error "<location>/<file> does not exist".

(sorry for the bunch of comments, there's no way to delete or edit them)
Comment 6 Buovjaga 2016-04-07 10:46:54 UTC
*** Bug 98949 has been marked as a duplicate of this bug. ***
Comment 7 Buovjaga 2016-04-07 10:47:11 UTC
NEW per dupe.
Comment 8 QA Administrators 2017-12-18 03:26:43 UTC Comment hidden (obsolete)
Comment 9 Christophe Lyon 2017-12-18 20:24:07 UTC
I think this is a duplicate of bug #75488
Comment 10 Buovjaga 2017-12-18 20:33:44 UTC
Indeed, thanks.

*** This bug has been marked as a duplicate of bug 75488 ***