Bug Hunting Session
Bug 94162 - Zero page margin after FB2 import
Summary: Zero page margin after FB2 import
Status: RESOLVED FIXED
Alias: None
Product: Document Liberation Project
Classification: Unclassified
Component: General (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other All
: medium trivial
Assignee: David Tardon
URL:
Whiteboard: libe-book
Keywords:
Depends on:
Blocks:
 
Reported: 2015-09-12 14:24 UTC by daniel.plachotich
Modified: 2015-12-24 20:37 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description daniel.plachotich 2015-09-12 14:24:10 UTC
Right page margin is always 0 after importing FB2 book.
Comment 1 David Tardon 2015-09-14 07:00:41 UTC
The filter does not set any margins, because the format does have no notion of "page", so this is either libodfgen default, libreoffice default or a bug in libodfgen in computing default margins. If it is not a bug in libodfgen, I'll just set all margins to 0.
Comment 2 daniel.plachotich 2015-09-14 10:27:29 UTC
I just found that after importing the pages have new style named PM2 instead of Default. Maybe this can help somehow.

Is it possible just set the Default style for FB2, as it done for plain text files (.txt), which are, by the way, also don't have any layout information?